Linux on a new blade

Discussion in 'Systems' started by _ramsey_, Feb 4, 2015.

Thread Status:
Not open for further replies.
  1. ProudSikh

    ProudSikh Member

    That battery life seems way off. My 13" retina gives me 10+ hours of web browsing, coding, etc on OS X and about 7 on ubuntu. I need to do more fine tuning but I'm happy with 7 hours so I haven't complained.

    I haven't looked at the suggested battery life the blade should get on windows, but you should definitely get that if not more with Linux on it. Windows is a power hog, linux and os x are not.

    Also it doesnt help that only the nvidia gpu is running all the time, i wish the support for switching gpu's on the fly was available in linux. I hope someone figures out a way because thats a big power draw
     
  2. _ramsey_

    _ramsey_ Active Member

    According to pcmag, it's about 4:50 for a new blade. Source

    They tested at 50% brightness playing a 24hr long MP4. So it sounds about the same as mine running under Intel graphic. In my case, display was ~75-80% brightness. I'll try again with brightness reduced, but I don't expect to get > 5 hrs out of it.

    The Razer has a 70 whr battery. A 13.3 Macbook Retina has a 71.8whr battery and a much lower res screen, so I'd expect better battery life from it.
     
  3. ProudSikh

    ProudSikh Member

    "Much lower" is not really how I would explain it since its 2600x1600. The screen resolution shouldnt make that much of an energy difference. I can look up the exact panel but right now i don't care enough to.

    What I would do is, in ubuntu disable the touch panel is you can, I assume thats taking up a lot of unnecessary power and I also assume your not using it, so disabling it won't hurt anything.
     
  4. _ramsey_

    _ramsey_ Active Member

    Not knocking it. It's just ~4M pixels vs ~6M pixels on the Blade. That's got to have a significant impact on power usage. Probably not as significant as just turning my screen brightness down a bit though.

    I haven't seen an easy way to turn that on/off yet.

    In any event, I'm not disappointed by these numbers, though it would certainly be nice if they were a bit better.

    Thought I would test the read/write speed of the new 2015 blade's 256GB SSD. The results are as follows.

    Write:

    $ time sh -c "dd if=/dev/zero of=bigfile bs=8k count=4000000 && sync"
    4000000+0 records in
    4000000+0 records out
    32768000000 bytes (33 GB) copied, 69.578 s, 471 MB/s

    real 1m15.033s
    user 0m0.261s
    sys 0m18.185s

    Read:

    $ time dd if=bigfile of=/dev/null bs=8k
    4000000+0 records in
    4000000+0 records out
    32768000000 bytes (33 GB) copied, 73.8713 s, 444 MB/s

    real 1m13.873s
    user 0m0.415s
    sys 0m11.533s

    Interestingly, the write was faster than the read.
     
    Last edited by a moderator: Aug 13, 2016
  5. tamashumi

    tamashumi New Member

    Does it still work for you? How the heck did you achieve that?
    Which version of Razer Blade do you have and which version uf linux kernel?

    I have Razer Blade 2014 and I tried on ubuntu 14.04.02 LTS as well as on 14.10.
    I had some success applying driver from github repo on 14.04 (with kernel 3.14 if I remember well) and touchpad worked as touchpad but only till another system reboot. I couldn't bring it back.
    I tried upgrading kernel version through 3.15, 3.16 up to 3.17 on which touchpad stopped working at all (not even as a mouse). I tried applying github driver on each kernel version too. No success which is no surprise as driver patch author stated his change is not compatible with 3.17.
    Then after more recent updates with apt-get touchpad got back but again as a mouse. Applying github driver didn't help.

    After reading your post I've just tried 14.10 with kernel version 3.16 (fresh install without any updates) it doesn't work. I can apply driver from github but it doesn't change anything. Touchpad still works as mouse only. No multi touch.

    I feel great pain having such a nice piece of rig and not being able to enjoy working comfortable under linux. Windows is ok for games and other entertainment but for development is a no-go.
     
  6. _ramsey_

    _ramsey_ Active Member

    Still working without problems. 2015 Blade with QHD+ display and 256GB SSD

    $ uname --kernel-release
    3.16.0-30-generic

    Did you make your 14.10 usb install stick on 14.04? I'm under the impression that only 14.10 can make a 14.10 stick.

    This may not be relevant, but what I did was install 14.04.1, then use it to upgrade to 14.10. Once I updated, I started getting an error message on boot about something not being signed properly, with an OK button. So I let it boot up and then made my 14.10 stick on 14.10 and reinstalled again using that stick. The boot message went away.

    I proceeded to reinstall 14.10 a few more times trying to figure out the magic GPU driver install dance before I got that right. After that, I tried the touchpad thing again and it just worked perfectly first try. I don't remember if I had to reboot after installing the touchpad driver. I think I did need to reboot.
     
  7. tamashumi

    tamashumi New Member

    Thanks for quick reply,

    I guess I have some message about boot too. Straight away after power on, so tiny I'm not sure what was it about (will check).

    I'm going to try your reinstallation sequence. Graphic card doesn't bother me yet. Even Intel's will do for coding :] Lack of scroll in touchpad is killing me though.

    Be careful with kernel updates. You may loose touchpad features on such.

    No matter what I try touchpad doesn't work for me unfortunately.

    I tried recreating USB stick under 14.10, reinstall and reapply driver patch from git.
    Nothing, always mouse only. I even tried your steps for nvidia hoping they may affect something. Nvidia driver was loaded, still no touchpad features though.

    I noticed one more thing (not new though). Often it's impossible to shutdown clearly. Instead Ubuntu on Blade freezes.

    BTW. Boot message I had was about insecure boot, I enabled secure boot in BIOS and it disappeared. Live USB stick with 14.10 created under 14.04 was working the same as created under 14.10.

    Pity Razer doesn't do linux drivers for their custom touchpad neither even support community efforts to implement such. I guess I need stick to using windows which makes me really sad :slightly_sad:
     
    Last edited by a moderator: Aug 13, 2016
  8. _ramsey_

    _ramsey_ Active Member

    Sorry to hear it isn't working for you. Maybe check dmesg if you haven't already. That might indicate the trackpad driver failed to load or something. FWIW:

    $ dmesg | grep Mouse
    [ 1.629557] hid-generic 0003:1532:011D.0004: input,hidraw3: USB HID v1.11 Mouse [Razer Razer Blade] on usb-0000:00:14.0-5/input3

    $ dmesg | grep Pointer
    [ 1.628333] hid-generic 0003:1532:011D.0001: input,hiddev0,hidraw0: USB HID v1.11 Pointer [Razer Razer Blade] on usb-0000:00:14.0-5/input0
    [ 16.463812] hid-rmi 0003:1532:011D.0001: input,hiddev0,hidraw4: USB HID v1.11 Pointer [Razer Razer Blade] on usb-0000:00:14.0-5/input0
     
  9. tamashumi

    tamashumi New Member

    That looks pretty the same to me:

    $ dmesg | grep Mouse
    [ 2.592502] hid-generic 0003:1532:011D.0004: input,hidraw3: USB HID v1.11 Mouse [Razer Razer Blade] on usb-0000:00:14.0-5/input3
    $ dmesg | grep Pointer
    [ 2.591268] hid-generic 0003:1532:011D.0001: input,hiddev0,hidraw0: USB HID v1.11 Pointer [Razer Razer Blade] on usb-0000:00:14.0-5/input0


    I don't remember what I tried exactly as my first attempt was about half a year ago. It was many tries. I had it working like twice, maybe. Each time only until 1st reboot. Can't say it's deterministic. Hardware looks pretty the same according to your log. On arch linux forum somebody exercises the driver with success on 2013 blade version. They are not too responsive though. I asked twice and never got any answer.
    How likely is Razer did the same touchpad in versions 2013 and 2015, but different in 2014? It must be working, argh...

    On the Arch they are saying that git repo driver won't work on newer kernel versions without patching.
    Not sure did he mean before but including 3.16? Have you done any additional patching? He posted some urls. I'm not sure are those git patches or what (why not just commit to git repo then?), how am I suppose to patch the patch? ;)
    Additionally there is something about specific xorg.conf options
    Have you done any of these?

    https://bbs.archlinux.org/viewtopic.php?id=173356&p=4

    Sorry about this questions avalanche. I'm desperate :F
     
  10. _ramsey_

    _ramsey_ Active Member

    I have done no additional patching. I only did what I mentioned earlier.

    Seems you're missing the hidraw4 line my dmesg has in output though. Maybe dmesg has some error where that line should be?

    $ dmesg | grep 0003:1532:011D.0001
    [ 1.628166] input: Razer Razer Blade as /devices/pci0000:00/0000:00:14.0/usb3/3-5/3-5:1.0/0003:1532:011D.0001/input/input8
    [ 1.628322] hid-generic 0003:1532:011D.0001: input,hiddev0,hidraw0: USB HID v1.11 Pointer [Razer Razer Blade] on usb-0000:00:14.0-5/input0
    [ 13.855426] hid-rmi 0003:1532:011D.0001: Scanning PDT...
    [ 13.858131] hid-rmi 0003:1532:011D.0001: Found F34 on page 0x00
    [ 13.861135] hid-rmi 0003:1532:011D.0001: Found F01 on page 0x00
    [ 13.864126] hid-rmi 0003:1532:011D.0001: Found F11 on page 0x00
    [ 13.871156] hid-rmi 0003:1532:011D.0001: Found F54 on page 0x01
    [ 13.878155] hid-rmi 0003:1532:011D.0001: Found F55 on page 0x02
    [ 13.885167] hid-rmi 0003:1532:011D.0001: Found F30 on page 0x03
    [ 13.892128] hid-rmi 0003:1532:011D.0001: rmi_scan_pdt: Done with PDT scan.
    [ 13.906119] hid-rmi 0003:1532:011D.0001: no read request pending
    [ 13.912208] input: Razer Razer Blade as /devices/pci0000:00/0000:00:14.0/usb3/3-5/3-5:1.0/0003:1532:011D.0001/input/input18
    [ 13.912373] hid-rmi 0003:1532:011D.0001: input,hiddev0,hidraw4: USB HID v1.11 Pointer [Razer Razer Blade] on usb-0000:00:14.0-5/input0
     
  11. tamashumi

    tamashumi New Member

    Actually you are right. I'm missing the entry which is 'hid-rmi' - the crucial one, I suppose.
    This probably means that patched driver is not loaded. According to the discussion on arch forum in kernel 3.16 hid-rmi got upstreamed (not the one with Razer patch though) so unpatched is not being loaded as well (i tried dmesg before and after applying the driver from github repo).

    This is quite strange as aduggan, who is from Synaptics and the author of the hithub repo, says it won't work from github repo rb14 branch for kernels 3.16 and above without applying patches. And it works for you on 3.16...
    Those patches are for linux kernel. I may try to apply them, compile kernel and install it. I've never done that before so it may take a while though. Besides as it works for you without such a gimnastics - why it doesn't for me? OMG, this is so frustrating.

    I wonder whether any BIOS settings may affect that. Maybe those USB related?

    This is how my dmesg output looks like for the device id:

    $ dmesg | grep 0003:1532:011D.0001
    [ 7.275160] input: Razer Razer Blade as /devices/pci0000:00/0000:00:14.0/usb3/3-5/3-5:1.0/0003:1532:011D.0001/input/input13
    [ 7.275354] hid-generic 0003:1532:011D.0001: input,hiddev0,hidraw0: USB HID v1.11 Pointer [Razer Razer Blade] on usb-0000:00:14.0-5/input0


    Clearly I'm missing a lot here :/

    Some more for 'hid':

    $ dmesg | grep hid
    [ 1.309887] hidraw: raw HID events driver (C) Jiri Kosina
    [ 7.270382] usbcore: registered new interface driver usbhid
    [ 7.270386] usbhid: USB HID core driver
    [ 7.275354] hid-generic 0003:1532:011D.0001: input,hiddev0,hidraw0: USB HID v1.11 Pointer [Razer Razer Blade] on usb-0000:00:14.0-5/input0
    [ 7.276405] hid-generic 0003:1532:011D.0002: input,hidraw1: USB HID v1.11 Keyboard [Razer Razer Blade] on usb-0000:00:14.0-5/input1
    [ 7.276609] hid-generic 0003:1532:011D.0003: input,hidraw2: USB HID v1.11 Keyboard [Razer Razer Blade] on usb-0000:00:14.0-5/input2
    [ 7.276779] hid-generic 0003:1532:011D.0004: input,hidraw3: USB HID v1.11 Mouse [Razer Razer Blade] on usb-0000:00:14.0-5/input3
    [ 7.288406] hid-multitouch 0003:04F3:0423.0005: input,hiddev0,hidraw4: USB HID v1.10 Device [ELAN Touchscreen] on usb-0000:00:14.0-6/input0


    Not sure is it relevant but here more dmesg for 'usb' and 'fail' strings (for warn and error nothing interesting):

    $ dmesg | grep fail | grep usb
    [ 0.563418] usb: failed to peer usb4-port5 and usb3-port9 by location (usb4-port5:none) (usb3-port9:usb4-port3)
    [ 0.563420] usb usb4-port5: failed to peer to usb3-port9 (-16)


    Any other suggestions what could I check/do?
    Thanks for your help!
     
    Last edited: Feb 24, 2015
  12. _ramsey_

    _ramsey_ Active Member

    I get:

    $ modprobe --show-depends hid-rmi
    insmod /lib/modules/3.16.0-30-generic/kernel/drivers/hid/hid.ko
    insmod /lib/modules/3.16.0-30-generic/extra/hid-rmi.ko

    Do you get the same?
    Is the hid-rmi.ko you built in the /extra/ directory?
     
  13. tamashumi

    tamashumi New Member

    Yup it's there. I wasn't aware of the command you used but after building and installing hid-rmi from github I did find / -name hid-rmi.ko and both of those locations were listed. Kernel one with Jan something modification date and extra one with the current date at that day.

    I'll use the proper command today's evening to double check that and post the result here. I'm not expecting any surprises though.

    Do you know by any chance how could I debug/check which logs to see whether this module is being loaded and with what result?

    The most frustrating thing is that I had it working at least twice (half a year ago) but only till next reboot. Here is somebody's post who faced similar issue: http://zhehou.blogspot.co.uk/2014/07/razer-blade-14-touchpad-multitouch-in.html
    He explains a bit and messes something with grub options. It has never helped in my case though and now it's even worse. I can't get it working even once on freshly installed Ubuntu. I may try older version with kernel 3.14 on which I succeed once. However I'm pretty sure (if remember well) I succeed once on 3.17 as well despite what hid-rmi github repo author wrote - that it's not compatible with 3.16 and above. I saw on the arch forum that one guy wrote something about "replacing a module". I believe he was overwriting hid-rmi ko file in kernel folder to force loading it as it was not compatible for that kernel version. I'm not sure though.

    EDIT:

    Mine output is different.

    $ modprobe --show-depends hid-rmi
    insmod /lib/modules/3.16.0-30-generic/kernel/drivers/hid/hid.ko
    insmod /lib/modules/3.16.0-30-generic/kernel/drivers/hid/hid-rmi.ko


    Seems 'extra' compiled driver doesn't get loaded (if I understand it well). It exists though:

    $ ls -l /lib/modules/3.16.0-30-generic/extra/hid-rmi.ko
    -rw-r--r-- 1 root root 19763 Feb 24 18:27 /lib/modules/3.16.0-30-generic/extra/hid-rmi.ko

    By the way, I have an output dump from the installation which I'm pasting below. There is one warning(?) which worries me: Can't read private key. Did you have it too?

    $ git clone https://github.com/aduggan/hid-rmi.git -b rb14
    Cloning into 'hid-rmi'...
    remote: Counting objects: 111, done.
    remote: Total 111 (delta 0), reused 0 (delta 0), pack-reused 111
    Receiving objects: 100% (111/111), 32.77 KiB | 0 bytes/s, done.
    Resolving deltas: 100% (68/68), done.
    Checking connectivity... done.
    $ cd hid-rmi
    $ make
    make -C /lib/modules/3.16.0-30-generic/build SUBDIRS=/home/topr/hid-rmi modules
    make[1]: Entering directory `/usr/src/linux-headers-3.16.0-30-generic'
    CC [M] /home/topr/hid-rmi/hid-rmi.o
    Building modules, stage 2.
    MODPOST 1 modules
    CC /home/topr/hid-rmi/hid-rmi.mod.o
    LD [M] /home/topr/hid-rmi/hid-rmi.ko
    make[1]: Leaving directory `/usr/src/linux-headers-3.16.0-30-generic'
    $ sudo make install
    make -C /lib/modules/3.16.0-30-generic/build SUBDIRS=/home/topr/hid-rmi modules_install
    make[1]: Entering directory `/usr/src/linux-headers-3.16.0-30-generic'
    INSTALL /home/topr/hid-rmi/hid-rmi.ko
    Can't read private key
    DEPMOD 3.16.0-30-generic
    make[1]: Leaving directory `/usr/src/linux-headers-3.16.0-30-generic'
    /bin/bash install.sh hid-rmi hid-generic
    $ sudo depmod -a
     
    Last edited: Feb 25, 2015
  14. _ramsey_

    _ramsey_ Active Member

    Software updated to 3.16-31 last night and pretty much rekt my setup :/ no mouse. I reinstalled but haven't tried the track pad patch yet.
     
  15. tamashumi

    tamashumi New Member

    Sorry to hear that, mate. As I thought - update broke the touchpad support for you.

    Anyway, now I understand why I couldn't achieve what you had. All my recent battles were done on 3.16-31 (I think). I need to double check the number version to be sure but I think that's the same one.
    Do you remember the exact version of kernel on which github driver was working for you?

    What do you mean by 'I reinstalled'? Did you reinstalled Ubuntu or reinstall GitHub hid-rmi rb14 branch driver after the kernel update?

    I tried yesterday to apply patches given by aduggan on the arch forum into Ubuntu sources checked out from git://kernel.ubuntu.com/ubuntu/ubuntu-trusty.git, tag: Ubuntu-lts-3.16.0-31.41_14.04.1 but git apply --check path/to/file.patch failed on the first patch. Either that's not a proper kernel version it should be applied to or Ubuntu kernel version is not compatible with the patch or it's not a proper command kernel patch should be applied with. Any thoughts about that? I may have some time over the weekend to try it out.
     
  16. _ramsey_

    _ramsey_ Active Member

    All your output above indicates 3.16-30

    Erased drive. Installed Ubuntu from stick. Tried installing nvidia-drivers first. Didn't go so well. I didn't include bumblebee this time, so maybe that's it. I don't think that is it though, as I removed it with no ill effects.

    I'll erase again and try trackpad first just to see if that still works.

    I didn't expect a point update in the kernel to hose the nvidia drivers :/ Maybe I'll try the nvidia.run installer this time instead of the xorg-edgers.
     
  17. tamashumi

    tamashumi New Member

    Crap, I'm so not knowing wtf that I'm starting to deny obvious things...

    Of course I have 3.16-30, only sources I checkout out for ubuntu git repo is 3.16-31 but I haven't even compiled it as I didn't manage to successfully apply the patches.

    BTW. do you know how to apply those patches from arch forum posted by aduggan? Should I use git apply or linux patch command? (I try the latter today).

    So did you install hid-rmi rb14 driver this time after system re-installation?
     
  18. _ramsey_

    _ramsey_ Active Member

    The hid-rmi isn't working on 3.16-31 either for me
     
  19. tamashumi

    tamashumi New Member

    I guess the thing is that since 3.16 hid-rmi is being shipped with a kernel. Thus why it's kernel what should be patched and installed.
    Strange it worked for you well on that kernel though. I think it worked for me once a time ago on 3.17 (until reboot as I mentioned). That's even stranger.

    Patches are GIT patches but I get:

    $ git apply ../../0001-HID-rmi-Scan-the-report-descriptor-to-determine-if-t.patch
    error: patch failed: drivers/hid/hid-core.c:783
    error: drivers/hid/hid-core.c: patch does not apply


    Too late for me today to review what's the problem and patch diff.

    I see support for the Razer Blade Touchpad got upstreamed in the kernel v4.0-rc1.

    I wonder to which of 3.xx patch can be successfully applied though.

    EDIT: Instead of patching I just upgraded kernel to v.4.0-rc1. Here are deb package links.
    Touchpad works after the first boot. l'll see is the kernel stable enough. To say hello it throws me compiz crash error (but it works).
    I see left button doesn't work. Tap to click does though.
    I'll try xorg conf touchpad conf from the arch forum topic.

    EDIT2: sudo apt-get update then upgrade fixed compiz error on start, synaptics file for xorg.conf.d solved left button issue.

    I still have one more issue though which has been with my ubuntu-razer experience from the very beginning with different kernels. Almost always when I shutdown or restart out of Ubuntu it freezes (still on desktop with partially GUI unloaded). Have you ever experienced such a thing?
    Sometimes if I wait long enough it will actually reboot. Usually I don't wait just do Ctrl-Alt-SysRq + sequence REISUB and it goes down. Sometimes it's even frozen for this ultimate reboot way.
    Any ideas what that may be and what to check?

    BTW. Is there any way to setup lower resolution or scaling on the logon screen?
     
    Last edited by a moderator: Aug 13, 2016
  20. _ramsey_

    _ramsey_ Active Member

    That's great news! I'm glad to hear you finally got it working! :)

    I just got the trackpad back on 14.10. Now that you've mentioned it, I notice my left mouse button doesn't work either. I never noticed because I always use the trackpad.

    I installed fresh from my usb stick, but without connecting my wifi. That way it couldn't download kernel updates during the install.

    After that, I did

    $ sudo apt-get update
    $ sudo apt-get install linux-image-3.16.0-30-generic linux-image-extra-3.16.0-30-generic linux-headers-3.16.0-30-generic linux-signed-image-3.16.0-30-generic
    $ sudo apt-mark hold linux-image-3.16.0-30-generic linux-headers-3.16.0-30-generic linux-image-extra-3.16.0-30-generic linux-signed-image-3.16.0-30-generic linux-libc-dev
    $ sudo reboot

    After reboot, uname -r reports I'm back on the 3.16-30 kernel. Then the patch from github works again. 3.16.0-30-generic definitely seems to be the magic kernel at the moment. I'm glad to hear it works out of the box on 4.0-rc1. I wonder if that would fix the black screen issue with the nvidia drivers as well.

    Next I'll try to reinstall the nvidia drivers. Hopefully that works again too.

    GPU drivers and cuda now work again too. 3.16.0-30 is magic. Maybe I'll try 4.0 once it's final and give @razervinh 's advice a try. Until then I hope to just enjoy the fact that it works as well as it does :D
     
    Last edited by a moderator: Aug 13, 2016
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >