New Razer Blade Stealth + Razer Core Monitor Issues

Discussion in 'Systems' started by zeezaw, Jul 12, 2017.

Thread Status:
Not open for further replies.
  1. Hi Everyone,

    I am new to the forum and new to Razer products. I recently got the New Razer Blade Stealth and also the Razer Core with the 1070 Graphics Card. I am having a quite a few issues.

    1. The monitor keeps on blacking out and would also flicker for a second before going back to normal while using the browser or Excel (Both on power and battery)

    2. When playing CS GO, the screen would also black out/ stutter / flicker about 2 or 3 times in 2 hr game plays. When the electricity goes out while playing, I will get kicked out of the application.

    3. Also when playing CS GO the sensitivity feel changes 3 out of 10 times i play.

    Anyone facing these same issues or faced them before?

    Thanks
     
  2. AssembIer

    AssembIer Active Member

    Hi and welcome !

    First we need more information on your issues:

    1 + 2. Do you mean the internal screen of the stealth or an external monitor and are you connected to the Core while that happens ? If you are connected to the Core and playing on the 1070 while there is a power outage, it is only natural that you will be kicked out of the application.

    3. "Sensitivity" in terms of frame rate or the input lag of your mouse ? If latter, is the mouse connected to the Core or directly to the Stealth. It is recommended to connect all your input devices directly to the Stealth instead of the Core.

    If you did not reach out to Razer Support yet, you are advised to do so, as this is not a support forum.
     
  3. Thanks Assembler. I will also reach out to Razer Support. I just wanted to know if other people were facing the same issues.

    1. I am still using the internal monitor. I guess it is normal then to get kicked out of the application when there is a power outage.

    2. "Sensitivity" as in the game setting which is based on the mouse movement. The frame rates are reasonable and they don't change. Its just that when I move the mouse, the speed is slower so it is difficult to be consistent. The mouse is also connected to the Stealth itself.

    Thanks
     
  4. AssembIer

    AssembIer Active Member

    That seems odd to me, i have the Stealth+Core (other GPU) since last December and never encountered any of your issues. Hopefully the Razer Support has some ideas on how to solve this.
     
  5. I have RBS 13.3 + core/1070 I have had no problems.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >