Razer black widow x not working

Discussion in 'Razer Support' started by MothySays, May 31, 2018.

Thread Status:
Not open for further replies.
  1. MothySays

    MothySays New Member

    I've had the blackwidow x for a few months now and abaoabsoly love it. However, when I sat down at desk today the keys were unresponsive, though still lit up by chroma, so I proceeded to try a different usb port, only this time no chroma light and still no ability to type.

    I've tried uninstalling synapse as well as uninstalling all of the drivers, but to no avail.

    Has anyone else had this issue or should I just file a RMA.

    EDIT: I found a Razer Bootloader in my devices and printers which seems to be my keyboard.
     
    Last edited: May 31, 2018
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Yo! Was there any change in your system before this happened? From your description, this sounds more like a software/driver issue kind of thing. I'll shoot you a PM so we can try to troubleshoot.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >