Razer Blade: anyone using precision drivers for the touchpad?

Discussion in 'Systems' started by diegoesp, Aug 26, 2017.

  1. cmorg

    cmorg New Member

    This is not an acceptable solution, though. For us users using the 128 GB versions, the update eats away at our already limited SSD capacity. After the update, before the issue showed itself, I had 3.7 GB of storage remaining, and had no option but to delete the Windows.old folder to free up space that I needed for documents and other updates.

    From what I've been able to see, the issue has only ever presented itself to me when my system is running on battery, as opposed to AC. Were there any new battery changes that 1709 brought that the trackpad isn't playing nicely with?
  2. chris.pen

    chris.pen New Member

    Does anyone know how to roll back the Fall Creator Update if I've deleted the Previous Windows Update?
  3. vistar

    vistar Active Member

    If you deleted the windows.old folder then it is not possible to roll back. You need an image backup, if you have one, or search on the net for windows ISO of the 1703 version and do a clean install.
  4. Late 2016 kabylake i7500U 16GB 512GB RBS Win 10 Pro -
    No problems with the 1709 Fall Creators Build Sleep Issue as descibed here.
    It sleeps on lid close or bluetooth (iphone proximity) and wakes up on key or trackpad touch.
  5. vistar

    vistar Active Member

    The issue arises only on battery, when waking from sleep or hibernation. There are a few lucky people that haven´t encountered this particular issue, but on reddit the scale of those affected is a lot larger than here.
    I will try a clean install of windows pro then, see if that helps...worth a try.
  6. Yes you are an idiot.

    I know what the issue is and explained I do not replicate it - this is useful for people like me that own a support business - instead of writing poor english and only complaining useful info is also - “my version works ok”. Maybe its a batch specific touchpad. Maybe not.

    Whinging like little kids and no one saying that it works ok is just not helpful.

    I use my device to run a business supporting 400+ seats. You play games. Reckon reinstall of 1709 is not gonna work in the slighest. But enjoy that waste of time.

    If it ain’t working then wait for the Razor update.

    It is that easy.

    Oh and Home is for amateurs - pay the $99USD kids.
  7. vistar

    vistar Active Member

    Good for you.
  8. Joikansai

    Joikansai Well-Known Member

    Home is not for Amateurs. There’s no need to use Pro if you don’t use its extra features. It’s mostly for business purposes.
    Last edited: Oct 27, 2017
    vistar likes this.
  9. vistar

    vistar Active Member

    The only thing I find useful, sometimes, in the Pro version is group policy. I have no need for bitlocker or Hyper V....maybe remote desktop at some point.
    Last edited: Oct 27, 2017
  10. Death_Angel

    Death_Angel New Member

    So how exactly will we know this is fixed? will we be sent a mass email aboout the fix? I don't want to keep coming back here just to know when i can update back to the latest windows features :/
    vistar likes this.
  11. buzzWisteriawire718

    buzzWisteriawire718 New Member

    This worked for me. I have a 2016 stealth.

    1. On the "Power Options" screen click on "Change plan settings" next to whatever plan you are using.

    2. In this next window click on "Change advanced power settings".

    3. In the window that pops up click to open "PCI Express" and then click to open "Link State Power Management".

    4. Depending on how many options are there, you may need to click on a few of them, and select "Off" from the available list. Make sure you change this for both "Battery" and "Plugged In".

    5. Save all the changes you made and then try putting the system to sleep and waking it back on.
  12. jaseow

    jaseow Active Member

    I tried the precision drivers but the touchpad would not work if the keyboard was in use at the same time so I went back to the default that shipped with the blade
    vistar likes this.
  13. Brisingr_Phoenix

    Brisingr_Phoenix Active Member

    TL,DR: does it work with the deathstalker ultimate tho?
  14. Joikansai

    Joikansai Well-Known Member

    Works on my Blade 2017 with my BWX Te, and Lancehead or diamondbacks plugged.
  15. jaseow

    jaseow Active Member

    Not external keyboard. I mean the keyboard on the Blade itself.

    I have the Blade 14" 7700HQ / GTX1060
  16. Joikansai

    Joikansai Well-Known Member

    Did you follow instructions on YouTube and instead automatically driver search install synaptics 11.2 driver manually? Btw I’m still on Creator don’t know how it is after FCU.
  17. Brisingr_Phoenix

    Brisingr_Phoenix Active Member

    I meant this touchpad, since the drivers that ship with the deathstalker ultimate conflict with my blade stealth (7500u) touchpad
  18. Joikansai

    Joikansai Well-Known Member

  19. xalanxlp

    xalanxlp New Member

    I have been getting the same problem. Trackpad freezes and activates only when I put the laptop to sleep and wake it up again. As much as I am happy that the issue is being worked on, it is shocking that it was overlooked. It is 30th October now.
    vistar likes this.
  20. Brisingr_Phoenix

    Brisingr_Phoenix Active Member