Razer Blade Stealth Linux

Discussion in 'Systems' started by Fl3a, Feb 3, 2016.

Thread Status:
Not open for further replies.
  1. shadygunz

    shadygunz Member

    As owner of multiple OSX, linux and windows systems I have to that for me every OS works fine in it's own aspect, except for windows.... the OS that sometimes has trouble with it's own software like, "these programs wont allow windows to shutdown" and then lists things as skype, windows explorer and task manager, how bad can a OS be at handling tasks?
    But ehmm the point I was trying to make, every OS has it's own place for me, I tried hackintosh myself a few times, but the experience it's self is far from nice and smooth compared to OSX on a macbook, where everything just works and does whatever you gave as input(except for games ofc they run shitty) OSX is great, aslong you are keeping it on a mac or are willing to fiddle around with the install for every driver update that comes along, same for linux it's great especially in a server environment where a GUI is overrated.
    and windows, well... the only reason to use that is because nearly everything is made for it and has a mainstream status, but it's kinda holding back the market lately.
     
  2. Doaky

    Doaky New Member

    Don't me wrong, I'm not a big fan of any of the desktop OS's (OSs, OSes, plural OS?)
    Each has their own major flaws and I totally get what you mean about windows fighting itself, my favorite is when explorer crashes and you're just looking at a black screen waiting for everything. OSX has given me grief on multiple occasions for just trying to do simple things like enabling network sharing. Why do I have to go into terminal just to enable the option in the settings menu to be changed to allow access to my NAS. Linux is a entirely different beast as this thread itself points out but because of zero market share it'll never really take off a consumer OS despite its monumental share in enterprise.
    Windows I use as a main daily driver for my game library and all around support for up to date hardware.
    Linux I use at work, while it drives my nuts sometimes, it's just so versatile.
    OSX I used a lot at school / uni but I found it's lack of high end hardware support and the ability to tinker with it a bit disappointing.

    I don't think anyone in their right mind could say anything bad about Apple's hardware build quality, internal components maybe, but not external design. Hell even this Blade Stealth I'm typing on is clearly inspired by the Macbook Air.

    And I do agree with you, there just isn't really enough competitive edge anymore. Windows 10 is great, but not perfect yet
     
  3. I found that Ubuntu 14.04 works really well on the stealth. You need a Linux Kernel 4.2 or above for the track pad support The only manual update I had to perform was the firmware files for wifi, as mentioned above. I created a script to accomplish that here:

    https://github.com/stuartwells4/razer-laptop/tree/master/stealth

    You can download the script and wifi files in a zip file here:

    https://github.com/stuartwells4/razer-laptop/archive/master.zip

    I do not use Ubuntu 15 yet, but tend to stay with the long term support versions. Has anyone tried CentOS?
     
    Last edited: Mar 9, 2016
    wired00 and flaminbjuggler like this.
  4. metawall

    metawall New Member

    I tried both Ubuntu 15.10 and Linux Mint 17.3 and I can confirm this works. Havent tried the scripts, but I basically did the same exact thing. Its important to update the kernel first then apply the script.

    I also tried antergos (Arch based) but had issues with uefi, nvme, and the bootloaders. Couldn't figure it out for dual booting.

    Quick question, whats the board-2.bin file for? I didnt put that in on my machine and it still works. Maybe there's better performance?
     
  5. joonatoona

    joonatoona New Member

    This works, but if you close the lid the random sleep issue persists. Anyone solved this yet?
     
  6. zillaofthegods

    zillaofthegods New Member

    I was wondering, what is everyones experience with battery life in linux. I'm looking at getting the QHD version, and I'd like to know how the (already borderline) battery life holds up? Also would disabling the touchscreen increase batterlife?

    Many thanks bitches.
     
  7. tommizzy

    tommizzy New Member

    Hey guys,

    I got the track pad operational in Ubunto 15.10 4.2.0.34-generic but the wifi is still a no go.

    I have board.bin in /lib/firmware/ath10k/QCA6174/hw3.0 but still not seeing any wifi. Any ideas?

    Nevermind. I deleted the QCA6174 directory then used Count Dispair's script and it worked like a charm. ggz!!
     
    Last edited by a moderator: Aug 13, 2016
  8. YuenX

    YuenX Member

    Dont do this to your blade ... :confused_:
     
  9. Fl3a_no_id

    Fl3a_no_id New Member

    Did no one test the battery? I would really appreciate the info :smile_:
     
  10. metawall

    metawall New Member

    The battery life is comparable to windows. I'm getting 6 hours with 30% brightness in Linux Mint with my qhd stealth.

    Also, i think the trackpad is much better in linux vs windows. (At least with the default config)
     
  11. Fl3a_no_id

    Fl3a_no_id New Member

    Thanks a lot. Did u get suspend to work?
     
  12. metawall

    metawall New Member

    Honestly, I haven't really tried. The pci ssd is so fast that I just turn off the stealth every time. I tried closing the lid once and it seemed to suspend the machine. Didn't modify any of that intel blacklist stuff. I'll try it when I get the chance.
     
  13. Fl3a_no_id

    Fl3a_no_id New Member

    Thanks man. Would u recommend the stealth overall? and especially with linux? I'm still waiting for a release in europe and getting kind of impatient^^
     
  14. metawall

    metawall New Member

    It's a great machine. I highly recommend it.
     
  15. jngtt84

    jngtt84 New Member

    Which directory did you delete? the one from the zip file or the one in the /lib/firmware/ath10k?
    Please help...

    I ran the script and it said that board.bin and firmware-4.bin already exist.
    Did i do something wrong?
     
  16. metawall

    metawall New Member

    Overwrite the files in /lib/firmware/ath10k with the files from the zip
     
  17. jngtt84

    jngtt84 New Member

    Thanks.
    well i tried to copy and paste the files and it didnt work.
    do i have to do it via command in terminal?
    sorry this is my first time using linux and its a bit confusing.

    if you have to do the task via terminal, whats the command?

    Thank you in advance.
     
  18. metawall

    metawall New Member

    No worries, ask as much as you want. You also need to change the owner of the files and make them executable.

    The first thing to try is to run the script on the previous page. Make sure you run it as root. "sudo ./wireless.sh" in the terminal once you cd into the directory that you extracted the zip.

    Let me know if that works
     
  19. jngtt84

    jngtt84 New Member

    yea did that and the wifi still didnt work.
    after running the sudo ./wireless.sh
    i rebooted the system and see if the wifi was picked up but nothing.
    so i decided to run it again and it said that the 2 files are already existed.
     
  20. metawall

    metawall New Member

    What distro are you using and what kernel are you at?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >