Razer Synapse 3 can't open

Discussion in 'Razer Synapse' started by ahhaolee, Sep 16, 2018.

  1. ahhaolee

    ahhaolee New Member

    i tried re-install fucking 10times
    i tried the steps from google, go to device manager uninstall etc...firewall etc...
    still cant open the synapse
    come on RAZER
    you are one of the top gaming gear company in the world still cant fix this kind of small issue?

    i using win 10 pro
     
  2. ahhaolee

    ahhaolee New Member

    [2018-09-16 19:16:50:704] Starting Language Set up
    [2018-09-16 19:16:50:707] Base Directory Path : C:\ProgramData\Razer\Synapse3\Settings\ApplicationSetting.txt
    [2018-09-16 19:16:50:707] ApplicationSetting.txt does not exist, Synapse will create file with default values
    [2018-09-16 19:16:50:907] InitializeSignalRRazer Synapse Service
    [2018-09-16 19:16:50:907] Skip Service Check:
    [2018-09-16 19:16:50:912] Start of method: Checking if Synapse service is running
    [2018-09-16 19:16:50:913] Service status: Stopped
    [2018-09-16 19:16:50:913] Refreshing service status
    [2018-09-16 19:16:50:914] Service status: Stopped
    [2018-09-16 19:16:50:914] Service status: Return true if service is running
    [2018-09-16 19:16:55:941] Stack Trace:
    Could not establish the connection.
    [2018-09-16 19:16:55:941] app ended
    [2018-09-16 19:17:05:988] Already Synapse 3 instance is running, Close this instance and show other one
    [2018-09-16 19:17:05:995] CheckIsRunning
    [2018-09-16 19:17:06:987] Error CheckIsRunningSystem.TimeoutException: The operation has timed out.
    at System.IO.Pipes.NamedPipeClientStream.Connect(Int32 timeout)
    at SingleInstance.CheckIsRunning()
    [2018-09-16 19:17:07:085] Starting Language Set up
    [2018-09-16 19:17:07:085] Base Directory Path : C:\ProgramData\Razer\Synapse3\Settings\ApplicationSetting.txt
    [2018-09-16 19:17:07:193] InitializeSignalRRazer Synapse Service
    [2018-09-16 19:17:07:193] Skip Service Check:
    [2018-09-16 19:17:07:196] Start of method: Checking if Synapse service is running
    [2018-09-16 19:17:07:196] Service status: Stopped
    [2018-09-16 19:17:07:197] Refreshing service status
    [2018-09-16 19:17:07:197] Service status: Stopped
    [2018-09-16 19:17:07:198] Service status: Return true if service is running
    [2018-09-16 19:17:12:214] Stack Trace:
    Could not establish the connection.
    [2018-09-16 19:17:12:215] app ended
     
  3. ahhaolee

    ahhaolee New Member

    lol nobody take care of this problem...
    GGWP Razer Team
     
  4. FiszPL

    FiszPL Well-Known Member

    Run "CMD" as an administrator, and run sfc /scannow - it will scan & fix your OS files, if corrupted.
    Then uninstall Synapse, run CCleaner, then do full system clean including registry, do system reboot, and install it again.
    Firewall has nothing to do, when app doesn't open. It could be also corrupted local profile in Windows, try to create a new user profile, and try to open synapse.

    In most cases it's an OS issue, rather than Synapse.
     
    ahhaolee likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >