Razor Blade Stealth charger problem

Discussion in 'Systems' started by ihate1234, Apr 4, 2016.

Thread Status:
Not open for further replies.
  1. ihate1234

    ihate1234 New Member

    Hi everyone! I recieved my Razer Blade Stealth late last month and I've fallen in love with it. Unfortunately when I woke up today I found out my charger had stopped working. I can see the small green light on the charger brick when I plug it into the wall but it won't charge the laptop.

    I already contacted support via email but I just can't wait since I use my stealth as my main laptop. I'm really hoping that I don't have send the charger back and not be able to use the laptop for like 2 weeks.

    If anyone has ideas for a possible fix I would really appreciate it.
    Thank you.
     
    Darkness7 likes this.
  2. Psyjin

    Psyjin Well-Known Member

    Sorry, I don't have a fix for you, but I wonder if it's the charger that's broken. In the scenario you described above...it could also be the laptop, no?

    Anyways, Razer Support will probably send you another charger free of charge. Either way, you're going to have downtime.
     
    Darkness7 likes this.
  3. :slightly_sad: OMG I have the same problem. I just got mine last week and this morning it wont charge anymore. Charger shows green light too.
     
    Darkness7 likes this.
  4. rtwarpath

    rtwarpath New Member

    I had the same provlem, don't know if its the laptop or the charger, it took me a couple of tries before finally able to charge a little of my laptop, green light too. I don't think its a hardware issue, maybe there r some bug in charging? The system thinks it has full battery so it stops it from charging?
     
    Darkness7 likes this.
  5. PrzemoXX

    PrzemoXX New Member

    The only issue that I had with charger was the weird noise but it's still working how long you used your laptop/charger before it stopped working? Have you heard the same noise from charger? I wonder if I'll face the same issue I hope not...
     
    Darkness7 likes this.
  6. rtwarpath

    rtwarpath New Member

    well, not really, i dont have any noises. IDK if this is battery related but sometimes my screen flashes, as if the gpu crashed sth.. it would really help if someone could explain some of this
     
    Darkness7 likes this.
  7. ihate1234

    ihate1234 New Member

    Well I called them when they didn't reply to my email and they said they'd send me a replacement in a few days. But then I got a Fedex RMA label from Razer shortly after. The guy on the phone didn't mention that I would have to send back my current charger. I guess I'll call them again tomorrow and see.

    Hopefully I'll get my replacement charger like next week and it will work. I REALLY hope the problem isn't with my machine...
     
    Darkness7 likes this.
  8. I'm having the same problem with my charger. It sometimes doesn't register as being plugged in and says I'm still running on internal battery. I will send an email and call tomorrow.
     
    Darkness7 likes this.
  9. rtwarpath

    rtwarpath New Member

    well for me, it registered as plugged in, however did not charge, but its fine now. However recently the screen turns black and come back on in a second every now and then, which didnt happen before. Its getting in the way of gaming. Idk if i could be a loose cable inside? or wut.
     
  10. Hey guys I'd like to chime in here. The charger that came with the laptop would cause it to BSOD and most of the time it wouldn't charge. I bought a replacement 3rd party charger off of amazon and it works perfectly, no charging issues. http://www.amazon.com/Innergie-Powe...&redirect=true&ref_=oh_aui_detailpage_o01_s00 ( I don't know why it went $20 up in price) I received my replacement charger from razer and it worked for a bit and now it doesn't...second defective one in a row....c'mon razer...
     
  11. SilverFly

    SilverFly New Member

    I'm having the same problem. But for me it's kind of finicky, sometimes it will charge other times it wont. I messaged razer and I'm hoping to hear back from them soon. In the mean time I ordered a replacement charger off amazon (^^^^) and i'm gonna see how that works out.
     
    Darkness7 likes this.
  12. Brastic

    Brastic Active Member

    I had this issue once and I rebooted the charger and never had the issue again.
     
    Darkness7 likes this.
  13. 9377519279

    9377519279 Active Member

    I believe it could be the charger. Restart the charger. I have not worked on any laptops that charge over USB C, but im willing to bet if your screen goes black or something or if you have charging issues its the charger. If not its probably the mobo or a software issue.
     
    Darkness7 likes this.
  14. ammobizFaluRed924

    ammobizFaluRed924 New Member

    The same thing happened to my charger, and now it's happened again to the replacement that Razer sent. Their customer service has been very responsive, but it's still pretty frustrating considering how expensive these are. I hope they are able to remedy this.
     
    Darkness7 likes this.
  15. stuckseife

    stuckseife New Member

    I have the same problem and i found that removing the cable from the power brick and reconnecting it solves the issue. The problem is i have to do it every time i connect the charger.
     
    Darkness7 and Thuggles like this.
  16. ammobizFaluRed924

    ammobizFaluRed924 New Member

    Thanks for the suggestion! I hadn't thought of that. Unfortunately it still doesn't work. Razer has shipped another adapter. However, I purchased the Innergie adapter that Scoots mentioned above and it seems to be working fine. If the same problem occurs with their third replacement, perhaps they'll reimburse me for the Innergie. Maybe?

    I certainly hope that other Stealth owners don't have to go through this. As I've mentioned earlier, their customer support has been great, but I find it frustrating to purchase a high end product to not have it work properly. : /
     
    Darkness7 likes this.
  17. Ryhart

    Ryhart Active Member

    I would just RMA the charger. I had the same issue back in jan when I first got mine. They sent me a new charger and I haven't had the issue since.
     
    Darkness7 likes this.
  18. ammobizFaluRed924

    ammobizFaluRed924 New Member

    Yes, I'll be returning the defective charger. I just hope I don't have the same issue with the third one that I'll be receiving.

    Does anyone know if there's been any word from Razer on this issue? It seems to be systemic...
     
    Last edited: May 14, 2016
  19. Same here. I got my blade last month and the charger is not working now. What makes things even worth is that I'm currently in China and Razer China refused to offer any kind of help since I bought the system in US.
     
  20. Xarga

    Xarga New Member

    I just got mine Friday 5/13, only to find out Saturday it didn't charge. I'm actually a bit relieved people are having the same issue with the charger, as I thought it was a defect with the connection on the board itself.

    I opened a ticket with Razer immediately, and they have been prompt on all of their responses.

    The numerous issues with this does make me a bit uneasy though. I really hope they offer some sort of compensation for this.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >