Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

[Update] Razer Synapse and macOS Sierra

Discussion in 'General Discussion' started by Razer.WolfPack, Sep 7, 2016.

Thread Status:
Not open for further replies.
  1. gurukaos

    gurukaos New Member

    10.12.1 here, my products seem to work, but it does seem that it is double clicking when I am playing WoW. Also loading the Synapse application, and trying to load the settings for each device, takes forever. Or I have to unplug, plug back in, etc, to be able to make any changes
     
  2. 10.12.1 here as well. I still get the freezing mouse cursor and eventual kernel panic. Mouse won't connect over regular bluetooth, even though it's seen and paired. It won't connect to it. When I get the Razer Synapse software it installs and installs the kext. Upon reboot it connects, and works for a very short time. It will then kernel panic in less than 5 minutes... or even less than that if you're using the mouse (moving/clicking).

    This is getting really old. I bought this mouse to replace the horribly unergonomic Magic Mouse, and I've waited for a while for at least a version that doesn't cause a KP. Still nothing.
     
  3. 10.12.1 here too. I run a Mamba on a Firefly, but sometimes the mouse just freezes. Also the mouse wheel stops working for an unknown reason.
     
  4. I submitted a kernel panic report to the OP of this thread.
     
  5. Jaisani

    Jaisani Cat

    To anyone who has any scroll speed issues, you are able to adjust the scroll speed from the MacOS system preference.

    Do contact me if you need any further assistance.
     
    Kale and Vaypron like this.
  6. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Yeah, it doesn't do anything. That's what people are saying: that changing mouse settings in System Preferences doesn't actually change mouse settings now.

    **Update**
    I found another way to adjust scrolling speed. Still in System Preferences, but this time under the Accessibility tab. UNFORTUNATELY, even putting the scrolling speed on maximum here makes no changes. Just informing that another method has been tested and failed.
     
    Last edited: Nov 3, 2016
    Kale and konfetas like this.
  7. RedWolfTech

    RedWolfTech New Member

    Exactly, only this doesn't actually change anything no matter *where* you set it. The setting in Sys Prefs does stick (its still at the same tick mark even after reboots) but it never makes any difference to the actual scroll speed. (and the speed that IS used is very very slow)
     
  8. Jaisani

    Jaisani Cat

    Hey @PTSinger and @RedWolfTech thanks for the info, really appreciate it. I'll notify our Support Team about this.

    Our team will update any news here.
     
  9. coachsharte

    coachsharte New Member

    I don't know if anyone else is having this issue as me, but it seems like you guys aren't. :/ So I recently updated to Sierra OS and the problem for me is that the Razer Synpase doesn't ever finish loading so I can't manage to change my mouse settings. I've been sending out messages to support center and the Facebook group and tried googling the issue, but nothing seems to help. I've also tried to reinstalling razer synapse multiple times. Is there a solution to this?
     

    Attached Files:

    DaveWoodX likes this.
  10. I'm completely unable to use my Naga mouse - I can move the cursor around the screen but I cannot click and the side buttons do nothing. I've tried uninstalling synapse and reinstalling but it's still broken.
     
    DaveWoodX likes this.
  11. Lundruf

    Lundruf New Member

    I am still having issues with my Razer Naga. As mentioned earlier in the thread, I cannot use a modifier key and my side number pad. When I hold shift and press 1 on the mouse, it reacts as if I have only hit 1.

    This has impacted my ability to play WoW at the level I enjoy. I am running Sierra 10.12.1 and I have been in contact with the support team. As of now, I have been told there is no fix for this problem. Very frustrating.
     
    DaveWoodX likes this.
  12. directhitBone895

    directhitBone895 New Member

    I am having exactly the same problem as LUNDRUF.
    Since 4 weeks nog without solution from support team.
    Unable to play without modifier keys.
    Inderdaad very very frustrating!
     
  13. DarkTaninfodaily772

    DarkTaninfodaily772 New Member

    i've experienced everything in this thread and it is ridiculous. (naga 2014)

    synapse has always been the most broken, crappy piece of software that makes me think i am using a windows pc. from day one. nothing but workarounds and putting up with bugs.
    the last 2 months were on another level.

    i use macs since 1993. razer? 2014-2016. never again.
     
  14. Lundruf

    Lundruf New Member

    I am getting close to purchasing a Logitech G600 or another similar gaming mouse that provides num pad on the mouse like razer naga. People I talk to in game are not having the same issues with their non-razer mouse that I am having with Naga. This is unfortunate because I love the Razer hardware.
     
  15. Yesterday I updated from El Capitan to Sierra 10.12.1.

    1) Extremely slow scroll speed, can't change it in OS X menu as well.
    2) Led is off forever for my Abussys 2014.
    3) After the system is restarted, I see my mouse settings profile is being activated and the mouse is going ok, but 10-15 second later it just resets all the setting and my mouse has different DPI and frequency (maybe the one is set in OS X menu, I don't know.). Then I need to open Razer Synapse and right after opening it up, all my normal mouse setting are back.
    4) I set my settings to 3000 dpi, 3 acceleration and 1000 frequency. However, every time I open Synapce, I see that it's set 1000 dpi, 3 and 1000 frequency. And the most weird thing is even it shows me 1000 dpi, it is actually feeel like 3000 dpi. Because when I change 1000 dpi to 3000 dpi - nothing change and the mouse feel the same. And when I make it back to 1000 dpi, it's much slower, right just it should be. So basically it remembers that I set 3000 dpi, but after restarting it shows me that it's 1000 dpi, although it's actually 3000.

    It's all very annoing, to be honest :slightly_sad:
     
    Kale likes this.
  16. Yes, I have this thing too.
     
  17. DarkTaninfodaily772

    DarkTaninfodaily772 New Member

    this is a visual bug i think and it has been introduced in 1.58. bug submitted right then. of course it hasn´t been dealt with. EVERYTHING in this thread has been reported to them numerous times. support mails back and forth. and they simply do not fix it. because mac.

    no surprise when u know that they let their customers run into a disastrous kernel panic restart loop bug for a whole month. what would it take to fix a visual bug? a phone call from tim cook himself?
     
  18. Razer.WolfPack

    Razer.WolfPack Community Specialist Staff Member

    Hey everyone! If you're encountering any new issues, we encourage you not post in the thread about the bugs you are facing, instead click on the gear icon at the top right hand corner of Razer Synapse and submit your bug report there. Alternatively, please reach out to us through our Support Team. The team is looking into each report accordingly. If you have any questions, feel free to drop me a message directly.
     
  19. I am having the scroll speed issues, how did you fix it?
     
  20. Did not change anything since Sierra day one, nor after 3 Razer updates.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >