Vodafone UK - keeps dropping signal

Discussion in 'Razer Support' started by NK.33, Nov 7, 2018.

Thread Status:
Not open for further replies.
  1. NK.33

    NK.33 Active Member

    I have had a Razer Phone 1 and used it on Vodafone for a year and everything was fine.

    I have transfered the SIM to the Razer Phone 2 and it seems that the connection to Vodafone just drops randomly.

    Thats not the qorst bit - I use this phone foir business and its often not until i look at my phone, AND turn off wifi before i realise i have no signal.

    The fix is to put it in flight mode then turn off flight mode.

    Should i return the phone? is this a problem that will be fixed? is there a setting i need to change for Vodafone?
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there. When did this issue start? Please try to manually set the preferred network type and see if the issue persists. Also, have you tried to use another SIM to see if the issue persists?
     
  3. NK.33

    NK.33 Active Member

    thanks for the advice but this is the first thing i tried. However - i troubleshooted by changing the network firstly to 2g only. no issues. i then upped it to 3g only - again no issues. As soon as i changed it to 4g the issues started.

    i then tested it again when i got home from the office - transpires its fine at home also - i just didnt clock it was only specific to my office which is where i was most of the week.

    So seems vodafone are having 4g issues in that area - simple as.
     
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. I see. Please let us know if you need more help.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >