Weird keyboard issue with my RBS. Can anyone help me?

Discussion in 'Systems' started by AlphaCureButt, May 12, 2016.

Thread Status:
Not open for further replies.
  1. AlphaCureButt

    AlphaCureButt New Member

    Okay, so I'm having an issue with how the lighting is working with my "tab" and "shift" keys. On all the pre-made profiles, and all the game specific profiles, the keys light up fully and perfectly. It's when I go into static keys, where I get the problem.

    The shift and tab keys glow dimmer than the rest of my keys on my keyboard. It's almost as if the keys have more than one row of lights underneath and only on row is lighting up. I've tried multiple profiles and even changing the colors. They even light up fine when the ripple gets to them, but they go back to the dim colors. Synapse is up-to-date. I've contacted support and they're willing to replace the stealth but I currently need it for school and work and I don't want to send it back right now. I love the laptop otherwise and it works fine, it's just a bummer that those keys don't light up. Seeing as how the keys light up with the preset themes in synapse and profiles in games, it might be a synapse problem. I've tested it with Rocket League, Stardew Valley and Overwatch and all of which are great. I know this is support, but I thought that if Reddit and customer support didn't have any ideas, maybe this would be my last stop before sending it in. Thanks to anyone who may be able to help me!

    http://i.imgur.com/zEYcphV.jpg

    http://i.imgur.com/U3SXotJ.jpg
     
  2. TrueLightbringer

    TrueLightbringer Active Member

    Yeah, I have that problem too. Not sure if it's because of backlight LED placement, as it seems most egregious when I have static colors on dim; otherwise its not noticeable at all. I really am not sure what's going on, and I can't really help you since I've already ordered an RMA for my current system.
     
  3. falomari95

    falomari95 Member

    Yo.. I have the same problem. All premade profiles work perfectly except when I choose my own custom settings... The shift stops working and the tab becomes dimmer. I contacted Razer support and they asked me if I wanted to send my unit back. I really think its a software issue from Razer Synapse because if you use the Audio Visualizer the lights work perfectly again.
     

    Attached Files:

  4. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Hey Guys,

    I tried it on a RBS here but I couldn't reproduce the issue. Could you guys help us out and send me your Synapse log files, so that we can investigate further?

    The log files can be found in "C:\ProgramData\Razer\Synapse\Logs" folder.

    A dropbox/google drive link would work a treat. You can PM the link to me directly if you don't want to share them in a public post.

    Thanks, @AlphaCureButt @Lightbringer @falomari95 for reporting this.

    Thanks,
    Razer|The_Fiend
     
    Last edited: May 13, 2016
    jae_ likes this.
  5. mintouch

    mintouch Active Member

    I agree. I even did RMA because of backlit keyboard malfunction.
     
  6. Predator5

    Predator5 Well-Known Member

    Try contacting the official Razer Support team.

    Not many people on this forum will be able to help you, and I want to remind you that creating support related threads on this forum is against the rules.
     
  7. TrueLightbringer

    TrueLightbringer Active Member

    Check your PMs! ...Tomorrow or next business day, if you're off on the weekend.

    Also, since you're here regard keyboard lighting issues, could you help confirm if the preloaded keyboard profiles that are triggered by FN + random number key (without Synapse on/during boot up), that turns red when triggered, is a firmware/BIOS thing? Mine seemed to have shipped without it; despite basically wiping everything and recovering via the inbuilt Recovery system, I can't seem to get it to work, which means it's probably not a Windows issue, and more like it wasn't installed during production.

    I would typically agree, and that's why I haven't posted anything about this issue here...

    But the fact that this got attention from an actual staffer themself, when it probably would have been given light lip service from Support themselves, isn't really helping your argument, to say the least.
     
  8. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    I don't know if I understand the question correctly. The profile switching works only with Synapse (since your profiles are managed by Synapse). When you press the Fn key, all the keys that are affected by the Fn key light up as a tip.
     
  9. JETcoolCoolBlack681

    JETcoolCoolBlack681 Active Member

    By fact, you can remove that synapse together with Widows and default profiles will still work.
     
  10. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    I've actually just contacted support about this same issue. I've noticed that it isn't exactly custom profiles- it reliably happens whenever I set the FN keys to white, so as to differentiate the brightness keys from the other ones. Every time I do this the tab doesn't light properly.

     
  11. ididntmemeto

    ididntmemeto Member

    This happens to me whenever I try to modify any settings with the custom chroma settings. It is definitely a software issue.

    Example: In synapse, I set the colors to the Wave setting, all the keys work fine. If I try to customize the Wave in Chroma settings, shift and tab don't light up. Very annoying!
     
  12. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    Really frustrating having to deal with synapse. I don't leave it running because it stops my CPU from idling properly, but then the only thing you need it for- chroma configuration- makes it not work. Great.

    Support wants me to wipe my computer and restore. I thought it was already established it's a synapse problem :/
     
    Last edited by a moderator: Sep 27, 2016
  13. ididntmemeto

    ididntmemeto Member

    I've already tried that and it doesn't do anything. Chroma in Synapse probably doesn't have some IDs right for the LEDs or something. It needs a software fix inside of Synapse to be fixed.
     
  14. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    They want me to send the laptop in for inspection... I can't understand, isn't this obviously a software issue? I don't see any possible positive outcome from sending it in.
     
  15. ididntmemeto

    ididntmemeto Member

    Yes, it is obviously a software issue. Regardless, I would be interested in what they determine from you sending it in...
     
  16. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    I told them that I'm not sending it in for such a minor issue. They said they couldn't reproduce the issue on their model and want to look at mine. Anyone here willing to be without their stealth for two weeks?

     
  17. falomari95

    falomari95 Member

    I feel like razer support arent actually computer experts.... It's CLEARLY a software issue and the moderator here said it has to be. He told me that he passed my logs (with my permission) to engineers. Hopefully they resolve it soon.
     
    DouglasHK likes this.
  18. falomari95

    falomari95 Member

    The second proof is that when you play the Audio Visualizer that makes your keyboard dance to music, the lights work properly.
     
  19. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

  20. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    Thanks for the reply- I'll check this and reply asap
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >