2m Thunderbolt 3 cable (40Gbps) with Razer Core

Discussion in 'Systems' started by BlueRaiderVol, Dec 2, 2016.

Thread Status:
Not open for further replies.
  1. Has anyone been successful getting a Blade Stealth (6500U or 7500U) + Core + RX 470/480 to function correctly with one of the new 2m (6.6 feet) 40Gbps cables? I've purchased two different 2 meter cables, from Belkin and Cable Matters and both of them have caused my Stealth (6500U/4K/512GB/AMD RX 480) to have constant BSOD's within minutes of AMD Xconnect becoming active. The Core + RX 480 functions perfectly with the cable it shipped with as well as another 0.5m cable I have. I have 2 GTX 1070's I could try but they both have waterblocks on them. I don't want to waste my time disassembling my desktop to try a 1070 if there's a known reason the new cables won't function correctly!
     
  2. JETcoolCoolBlack681

    JETcoolCoolBlack681 Active Member

    It can be a latency problem for example.
     
  3. Any way to fix it OR make the laptop tolerate it?
     
  4. JETcoolCoolBlack681

    JETcoolCoolBlack681 Active Member

    It should be a matter of drivers or cables themselves. Trying Nvidia is actually a relevant idea.
     
  5. Zorn_

    Zorn_ Active Member

    Anyone else have any experience using this cable with the Core? Curious if OPs issues are an AMD thing or more universal.
     
  6. Definitely not an AMD issue. I finally figured out it was the Killer WiFi card that was causing all my issues. If you google around you'll find an endless number of threads about the Killer 1535 cards causing interference with USB 3.1/Thunderbolt 3 peripherals. Your mileage may vary, some systems never have a problem but others do. The only way I've been able to resolve the issue is to put my Stealth into Airplane mode and use Ethernet ONLY for networking. I've got an Intel 8260 WiFi card that I haven't installed yet but am hoping will allow me to keep WiFi and Bluetooth enabled.
     
    ThirdDegreePun and marching_cow like this.
  7. JETcoolCoolBlack681

    JETcoolCoolBlack681 Active Member

    Please post your findings here. It is good to know that 2m Thunderbolt USB-C cables actually work.
     
  8. GR8-Ride

    GR8-Ride Member

    I just ordered one of the 2m, Thunderbolt 3 (40 Gbps) cables from Startech. They claim it was pre-order, but it has already shipped, so by Monday, I should have some idea of whether it will work with my 2016 Blade and Core.
     
  9. GR8-Ride

    GR8-Ride Member

    Okay, so I just received my 2m (6.6ft) Thunderbolt 3 cable (40 Gbps) from Startech. It works brilliantly with the Razer and my 2016 (late) Razer Blade. I'm running a GTX-1080, overclocked in my Core, and my scores are basically identical in Firestrike with the 18in cable and the 6.6 ft cable.

    So I now have my Razer Core parked inside a cabinet in my desk, with my Blade on top of the desk, and all running off a 34" Ultrawide display. Pretty happy with the config.

    The cable was pricey ($116 CAD all in), but given that my desk is a lot tidier, it's worth the expense.

    No performance hits as far as I can tell.


    Patrick
     
  10. JETcoolCoolBlack681

    JETcoolCoolBlack681 Active Member

    OMG. Hope this is temporary.
     
  11. Cody8417

    Cody8417 New Member

    any updates on these cables with a razer blade stealth? Hoping the killer nic issues have been resolved or mysteriously stopped being issues!
     
  12. 100% guaranteed fix for mine was to take the Killer nic out and throw it away then replace with an Intel 8265. I consider anything made by Killer to be absolute garbage now and I really wish Razer would stop using them in future products.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >