Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

assassins' creed unity issues

Discussion in 'Game Talk' started by sambogaming, Feb 5, 2015.

Thread Status:
Not open for further replies.
  1. sambogaming

    sambogaming Member

    hello, since the newest update for ACU i have been unable to launch the game. i click the icon and it starts loading then i get ACU.exe has stopped working. anyone know how to fix this? (i have tried deleting and reinstalling)
     
    Last edited: Feb 5, 2015
  2. Have you attempted to verify game file integrity? It's what helped me solve the problem. You can find information here:

    https://support.ubi.com/en-US/FAQ/6...ll--verify-a-game-in-uplay/kA030000000ee85CAA

    Verifying a Game's Files in Uplay

    *Please note that this feature is only available to games that released after 11/15/2013 and will not be available to all Uplay games.*

    Verifying the game cache can be useful if you are having technical issues with your game. This process checks your game install folder and compares the files to the files on the download server to look for differences. If it finds any issues with corrupt or missing files on your install folder, Uplay downloads and repairs those files to your install folder.

    1. In the Uplay client, click on Games.

    [​IMG]


    2. Click on the game you wish to verify the files for. You will land on a window that looks like the one below. Click on the down arrow to the right of Play and choose Verify files from the list.

    [​IMG]


    3. Uplay will then begin the process of checking your files.

    [​IMG]


    4. When the process is complete, you will be met with the following window that will display the results of the scan and tell you whether or not files need to be redownloaded or not.

    [​IMG]
     
  3. sambogaming

    sambogaming Member

    yep, tried that, didn't work. thanks anyway
     
  4. sorry about that, hope you find a solution, you should post it in here, in case someone else is looking
     
  5. Subject4S

    Subject4S New Member

    I sometimes had with Windows 8(.1) that some games tend to crash randomly, I've had that with League of Legends and some Steam games, solution for me was either run it as Administrator or put compatibility to Windows 7
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >