Atheris wont re-connect!

Discussion in 'Razer Support' started by buzzPatriarchguide657, Jun 15, 2018.

Thread Status:
Not open for further replies.
  1. Just got a Razer Atheris and connected it via Bluetooth to my Surface Book 2 which all worked like a charm! Problem is when I brought it back out and turned it to bluetooth it won't connect to my computer. I have to remove the mouse from the computers bluetooth device and re-pair it every time! The mouse just shows the blinking blue indicator until I put it back in pairing mode and re-pair it. This is extremely frustrating.
     
  2. FiszPL

    FiszPL Well-Known Member

    Try to delete it from device manager (with drivers), If you don't see the mouse you can check to view hidden devices. Windows 10 is pretty bugged when it comes to bluetooth.
     
  3. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Yoh! Have you tried reinstalling Razer Atheris drivers on device manager? Also, was there a significant update on your Surface Book 2 before this started?
     
    freakydoctor likes this.
  4. Giolon

    Giolon New Member

    I am having the exact same problem, only my computer is the new Razer Blade 15". I have deleted the mouse from Device Manager. I have used both the factory original Bluetooth drivers and upgraded to the latest Bluetooth drivers from Intel. I Razer Synapse 3 installed and updated to the latest version. I'm not sure what else I'm supposed to do to make this problem go away. It's looking like the Atheris may have to be returned in favor of something else unless this problem can be solved.
     
  5. parlin44

    parlin44 New Member

    The same problem here with my Surface Book 2 (15). Prior to posting here I've tried the typical suggestions (like reinstalling devices, drivers, synapse and stuff) without success. I think it's inherent to Atheris, my friend and I purchased at the same time, I used it with Asus Zenbook without much issues, but my friend had been having (reconnection) issue with his AsusPro. Now it's my turn on Surface Book 2. I don't think it's the Surface because the keyboard (which I'm currently typing this comment with) and the headset are all OK.
     
  6. diegoesp

    diegoesp Member

    Any news about this problem? I'm experiencing this same issue with an Atheris connected to my Razer Blade (2017). What is worse, when connected to the dongle, I'm experiencing "hiccups" now and then that are very consistent through time and drive me nuts :slightly_sad:
     
  7. Giolon

    Giolon New Member

    No update at all. I'm currently attempting to engage with Razer Support about the issue, but every response I get from them is as if they haven't read my prior reply to them at all, and I'm constantly having to restate the same information in every e-mail. I've been bounced from Razer Blade support to Razer Peripheral support and now back to Razer Blade support.

    Clearly it's not just the Razer Blade, because people are experiencing it with the Surface Book 2 also, but it definitely has problems with the Intel 9260 in the Blade 15 on driver versions 20.60.0.4 and 20.70.0.4.
     
  8. diegoesp

    diegoesp Member

    I've also open an issue on my side. Let's see how that goes.
    Man, this is pretty bad... it is a very big issue for such a costly mouse
     
  9. gelangenie

    gelangenie New Member

    Can also replicate this on my Razer Blade 2018.

    Currently:
    - OS is Windows 10
    - uninstalled Razer Synapse
    - installed Razer Atheris driver v10.0.17134.1 atherisDriver.PNG
    - updated bluetooth driver v20.30.0.3 bluetoothDriver.PNG
    - bluetooth power setting "Allow computer to turn off this device" disabled ( bluetoothPower.PNG )
    - linked my Razer Atheris through bluetooth to my laptop linkedAtheris.PNG

    To replicate issue
    1. Turn-on Atheris in bluetooth mode
    2. Boot-up laptop while plugged-in to power supply (issue occurs only when laptop was completely shutdown/sleep)
    3. Notice that mouse pointer is not responding to Atheris

    Workaround
    1. In Start menu, run "Troubleshoot"
    2. Under "Find and fix other problems", select "Bluetooth"
    3. Under "Bluetooth", click "Run the troubleshooter" troubleshooter.PNG
    4. Wait for troubleshooter to "Turn on bluetooth" turningOnBluetooth.png
    5. Wait for troubleshooter to finish fixedBluetooth.PNG
    6. Confirm that mouse pointer is responding to Atheris
     
    Last edited: Aug 16, 2018
  10. Giolon

    Giolon New Member

    This is interesting b/c I a pretty extensive amount of testing on my machine w/ version 20.30.0.3 (and all versions up to the latest release), and I didn't experience any re-connection problems with the Atheris on this version. I did experience all sorts of other problems that Intel fixed in later versions like Bluetooth disappearing from Windows, poor HFP audio quality, and the mouse lagging during HFP audio sessions. I only got those problems to go away by using driver version 20.60.0.4 or newer, and that's the version where the Atheris re-connection issues start for me.
     
  11. gelangenie

    gelangenie New Member

  12. Giolon

    Giolon New Member

  13. gelangenie

    gelangenie New Member

    Thanks Giolon!

    Tried the 20.70.0.4 but still didn't keep Atheris connected after boot. My workaround also didn't work anymore with this newer bluetooth driver (needed to unpair-repair Atheris), so I reset back to the 20.300.3 bluetooth driver (only needed to run windows troubleshoot).

    I tried some different scenarios to isolate the issue
    - old Logitech m555b bluetooth mouse (https://support.logitech.com/en_au/product/bluetooth-mouse-m555b/specs) with Blade 15 : no issues
    - dell desktop with qualcomm bluetooth driver ( desktopbluetoothdriver.PNG ) and Atheris : no issues either

    I can only speculate that the Razer Blade 15 intel bluetooth driver isn't compatible with Atheris / Bluetooth LE. After the Razer Blade reboots, the Atheris can't reestablish bluetooth pairing until a manual troubleshoot by windows 10.

    This is really disappointing, considering that these are both Razer products.
    I guess all that's left is hope razer support can fix this somehow.
     
  14. I will add to this since I am having the same issue as well. Bought the Atheris 3 months ago as it seemed like it would be the perfect fit for a portable gaming mouse and regular use mouse with my Surface Book 2 15". Out of the box it connected fine to Bluetooth. Seemed to work like a charm....until I shut down and restarted my SB2. Mouse would not reconnect. So removed it from blueTooth devices and re-added. Worked like a charm again, until I shutdown or restart. It would just never reconnect. I work in the IT field so I did all the normal stuff, uninstalled drivers, reinstalled and even reimaged my SB2 with Windows 10. Same issue though. So I contacted Razer support and went through the fun run around with them, Honestly was useless and a waste of my time. So I returned it back to Amazon thinking it is surely just this isolated hardware issue with this mouse. Got a replacement from Amazon......yea, guess what....same issue! So I tried it on some other laptops that I have handy, A Lenovo T470, T440, Surface 4 Pro and my custom built desktop. Guess what, same issue on all of them! And I will also mention that the 2.4 wireless is very shady as well. Lags at times and just plain out stops responding for seconds. And yes, same results on all the other devices that I have tried it on. I have many other Razer devices that work great for me. This one however, is just plain junk for the amount of money it was. I am keeping it in the hopes that razer will actually put out a firmware or driver update that fixes this useless device. But I am not holding my breath. :/
     
    gelangenie likes this.
  15. TACT314

    TACT314 New Member

    Has anyone found a solution for this? I've been having the same problem. I've been in communication with razer support for weeks, tried updating every driver under the sun multiple times, even RMA'd the mouse (as some mentioned they did as well above) and it still can't reconnect. I'm also using a razer blade 15 (2018) so i figured if any system should work it would be the same brand. At my wits end here.
     
    gelangenie likes this.
  16. gelangenie

    gelangenie New Member

    Hi @geoLightGreenlife340 @TACT314
    Only workaround i've seen so far is the one i posted previously:
    - In bluetooth driver power settings, set "Allow computer to turn off this device" disabled
    - On device boot, from windows button, run "Troubleshoot" and run "Troubleshoot bluetooth" to re-enable the mouse

    Note that:
    - razer synapse can be installed or not installed; synapse makes no difference
    - issue occurs on device(laptop) power-off, so also occurs for both hibernate and shutdown
    - issue is possible related to mice that use the bluetooth LE (low energy) standard that allows device to turn-off the mouse during standby events (ie. hibernate and shutdown)

    I've just been watching this thread waiting for Razer support to reply if they have any updates. So far nothing though :frown_:
     
  17. Nothing but crickets from Razer...….shame.
     
  18. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hey there, guys! Can you PM me the following info? I'll review the case and see what we can do.

    When did the issue start:
    Bluetooth driver:
    OS Version:
    Case number (if any):
     
    gelangenie and freakydoctor like this.
  19. madcapacity

    madcapacity New Member

    I'm not sure how to PM you - but i'm having this exactly issue with my Razer Atheris ever since I got the new Razer Blade 15". The bluetooth used to reconnect fine on my previous generation Razer Blade. I've tried to fix the problem by updated to Intel Wireless bluetooth driver v20.70 but have since reverted back to v20.30.

    I'm running Windows 10. Can you please help?
     

    Attached Files:

  20. Good luck, I am just going in circles with Razer support....
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >