Blade 14 Battery With Linux

Discussion in 'The Linux Corner' started by wesley27, Dec 13, 2016.

Thread Status:
Not open for further replies.
  1. wesley27

    wesley27 Active Member

    Hey everyone,

    I run fedora linux most of the time, it's my day-to-day normal use OS. So I run it on my blade as well, almost all the time unless I am gaming or need something windows specific. I have it installed (only OS) on a Samsung 850 Evo, which I connect to my laptop and run via a USB 3.0 connector. My Blade is set to automatically boot from this drive when it is connected to my laptop.

    This is the early 2016 Blade 14, QHD+ screen, 16gb ram, chroma keyboard, Gtx 960m, etc.

    When booted into windows, under normal usage (web browsing and such), I get 5-6 hours of battery life easily. This is without any power saving settings on, 40% brightness. When booted into fedora, I get 2.5 to 4 hours of battery life. I'm pretty sure fedora has less processes running constantly than windows does, and I don't think the external USB 3.0 setup could be draining battery, as USB 3.0 is just above the speed of this drive.

    Anyone have any idea what could be causing the battery drainage, and how I might be able to fix it? Any help would be appreciated! Thanks!
     
  2. RaptureHearts

    RaptureHearts Gamer Geek Girl

    Let our support team help you with your battery drainage. Contact our team through http://rzr.to/help.
     
  3. wesley27

    wesley27 Active Member

    I don't think they will help as running Linux on the blade isn't officially supported. Its a windows machine to them.

    Bump, anyone have any thoughts?

    Hmm so this just got moved, I'd given up on getting a response but now since I got the moved to linux section notification, I thought I'd give it another try.

    When I originally posted this thread, I had the early 2016 model (GTX 970m). Now I have the late 2016 model (GTX 1060).

    I get 5-7 hours on windows with normal browsing and usage, 40% brightness.

    When booted into Fedora 24 from an external SSD via USB 3.0, I get around 3.5 hours.

    Does anyone have any ideas why this would be?
     
    Last edited by a moderator: Mar 27, 2017
  4. labotsirc

    labotsirc Active Member

    Have you checked which GPU is working during the usage? the Nvidia or the Intel one.
     
  5. wesley27

    wesley27 Active Member

    @labotsirc I'm pretty sure it's the Intel graphics. When I go to the system settings, it only displays the Intel integrated graphics. Also, in order to boot up fedora, I have to apply "nouveau.modeset=0" to the grub config, disabling the Nvidia card because there's some issue with fedora and the Nvidia drivers, it took me forever to find this fix for why I initially couldn't even start fedora.

    So I'm pretty sure it's the Intel card.
     
  6. labotsirc

    labotsirc Active Member

    Strange. A couple of things that might provide insights.

    1) what is the driver used for the intel graphics?

    2) Once the battery is drained in linux, can you make sure it is physically drained by trying to boot windows if it can.

    3) Try these solutions
    http://askubuntu.com/questions/649389/battery-drains-very-fast-on-ubuntu
    http://askubuntu.com/questions/387388/ubuntu-drains-battery-very-fast-compared-to-windows
    http://askubuntu.com/questions/776851/ubuntu-drains-battery-very-fast-on-16-04

    4) You might want to try installing the propietary nvidia driver along with bumbleblee.
     
  7. Is your USB 3.0 drive externally powered or drawing from the USB port?
     
  8. wesley27

    wesley27 Active Member

    @labotsirc I will try everything you said asap, was planning to respond once I do, I've just been quite busy with school and haven't had a chance yet. I really appreciate the help.

    @VelvetMoose It's not powered externally, its just connected to the Blade so I suppose the Blade is powering the external enclosure and SSD.
     
  9. wesley27

    wesley27 Active Member

    After learning some things and based off of the above comments, I've come to the conclusion that the sub-par battery life is due to the following reasons:

    1. The blade is powering the external drive from which I am booting fedora.
    2. I have fedora 24, which doesn't support hybrid graphics, only the most recent version (25) does, and even that is buggy. So this means that both of my graphics adapters are running, even though I disabled the GTX card on boot in the grub config, and this saps power.
    3. Fedora is apparently a decent bit power hungry when stock, and there's quite a few optimizations and changes that can be made to change this. I have to research and apply, and feel free to let me know if you know of any!
     
  10. nicomv95

    nicomv95 New Member

    Hi! I have exactly the same Razer Blade but instead of Fedora, I'm running Ubuntu 16.10.

    I'm getting 3 to 4 hours of battery using web browser and programming. I believe that Ubuntu supports hybrid graphics, so that might not be the problem. I installed Ubuntu besides Windows on the SSD, so I don't think powering your USB drive is making a big difference. This may help you by comparing both cases.

    I hope you can improve battery performance, and if you do, please tell us how :D
     
    Amarok Blue and wesley27 like this.
  11. Mr.ShoNuff

    Mr.ShoNuff New Member

    If you don't want to upgrade you should be able to compile your own kernel from kernel.org and turn on the feature so that it is supported and configure from there.
     
  12. wesley27

    wesley27 Active Member

    @Mr.ShoNuff I actually did want to upgrade, I just couldn't because of an issue with my grub config that has since been fixed, and I'm now running fedora 25. I'll have to look into the hybrid graphics. Do you know about it, I mean does it fix graphics/power issues due to having two cards?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >