Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Can't install ubuntu on Razer Blade 15 (2018)

Discussion in 'The Linux Corner' started by smartCadetGrey705, Oct 16, 2018.

Thread Status:
Not open for further replies.
  1. smartCadetGrey705

    smartCadetGrey705 New Member

    Booting into Live USB works great, and its awesome.

    I just can't install to the internal SSD.

    I have tried along side windows and clean partition table. Tried ubuntu 18 and ubuntu 17.

    The install will finish and then will boot to grup, but then when trying to boot into the OS, I always get

    "Gave up waiting for root file system ...... /dev/nvme0n1p5 or whatever does not exist...

    does this sound familiar to anyone? seems like linux been having issues with the nvme ssd with the razer blade or maybe somethign with the bios

    Common solutions on the internet often include adding a root delay and rebuilding grub. I was able to do that, however it doesn't fix the issue.
     
  2. cultavix

    cultavix New Member

    I installed the latest version of Ubuntu 18.10.1 I believe, and everything works, other than the fact that it hangs and crashes constantly. I was having an issue installing Ubuntu to begin with, the problem I had, was that I was using a 64GB USB stick, once I switched to an 8GB one, for some reason, it installed it just fine.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >