Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Insider Achievements not earning zsilver

Discussion in 'Razer Cortex' started by poh2ho, Dec 14, 2017.

Thread Status:
Not open for further replies.
  1. poh2ho

    poh2ho Well-Known Member

    Awarded: Today at 2:40 AM
    Part-time author

    Publish 50 posts

    I'm supposed to acquire 25 points for the award Part time Author.
    However, there seems to be no response to getting zsilver in my account.

    Although the other achievements like Get on the Hype Train works perfectly fine.
    This seem to have bugged out.

    And I'm not sure why.
    Does anyone have the same issues?

    PS: Sorry if this is the wrong place to post, I'm really confused on the achievements being not registered properly.
    pancholr likes this.
  2. mo-iro

    mo-iro Active Member

    Have you tried log out and log in again to redeem the points? Just asking because some people just forget to do it sometimes
    poh2ho likes this.
  3. poh2ho

    poh2ho Well-Known Member

    A million thanks! That actually did solved the problem!
    You are a hero.

Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >