Latest Synapse 3 update broken

Discussion in 'Razer Synapse 3 Beta' started by zorn_, Dec 1, 2017.

Thread Status:
Not open for further replies.
  1. zorn_

    zorn_ Active Member

    I don't know what happened with the latest update to Synapse 3, but it's completely broken. Anytime I try to update from inside the app, it just freezes up on the progress bar installing, and never stops. I have tried downloading the full installer from the site, and installing it manually, and the same type of thing happens. It gets to Installing... and goes to 99%, then jumps back to 80% then climbs all the way back to 99% again, and repeats forever.

    Anyone have a fix?
     
  2. PalZer0

    PalZer0 Member

    I had that and I got around it by rebooting my PC and attempting the update again.
     
  3. Arelmunda

    Arelmunda Well-Known Member

    @PalZer0's solution didn't work for me, but I found by killing all Razer processes and service from task manager and manually deleting the Synapse3 folder I could get the installer to complete. It really shouldn't need that kind of work, but it is beta software, hopefully the final release will be a little more graceful.
     
  4. Grimmwor

    Grimmwor Active Member

    I know this is a social forum and not a support forum, but this is a perfect example of why there needs to be a support forum...make it separate site and only accessible for people who have registered products...
    Razer has a dedicated fan base, take advantage of that, let them help each other.
     
    Arelmunda likes this.
  5. zorn_

    zorn_ Active Member

    I fixed it. Rebooted 3 different times with no luck, then on the 4th try I tried the built in updater again and it finally completed practically instantaneously.
     
    Grimmwor likes this.
  6. Brisingr_Phoenix

    Brisingr_Phoenix Active Member

    Synapse 3 is a broken mess all around, can't even reset my Trinity because it crashes if I try
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >