Overwatch Chroma - FIXED (June 28)

Discussion in 'Overwatch Talk' started by Razer|Quis, Jun 11, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. RazerQuis

    RazerQuis Team Chroma Staff Member

    We’re aware of a current issue with Razer Chroma effects not functioning with the most recent patch of Overwatch, and we are currently working with the Overwatch Development Team to pinpoint this issue. Rest assured that this will be fixed and you’ll be able to enjoy Razer Chroma effects with Overwatch again. We'll update you once it's up and running!
     
    Last edited: Jun 11, 2017
    Puppetier, Azhp12, HrMystik and 12 others like this.
  2. Did your Dev Team get this tidbit of info:

    [<06:10:2017:16:05:53:826>RazerIngameEngine(RzWinMgrSrv)(0x2854)(0xfe8)!!!!!***** Error ] RMLUser::GetRDDData - RPM failed LE 0x12b Read 0x0 Expected 0x25bc pid 0xc10 path C:\Program Files (x86)\Overwatch\Overwatch.exe

    I found it yesterday, seems relevant :)
     
    Sinisterj12 likes this.
  3. RazerQuis

    RazerQuis Team Chroma Staff Member

    Thanks for this! I believe the developers have identified the issue and should be quite close to a fix. I want my keyboard to glow again!
     
    Pancode and Sinisterj12 like this.
  4. Gneekman

    Gneekman New Member

    Maybe this is relevant:
    I just got a BlackWidow and a Mamba, both Chroma, and was disappointed to find the OW integration had become broken for everyone...
    Although I haven't seen another forum post on it yet, it seems Diablo III's Chroma effects have stopped working too. I already had a Tartarus keypad with the not-per-key Chroma, and saw a limited version of the D3 effects (red, flash on low health, change color on active skill). But I haven't been able to get the effects on my new mouse and KB, nor on the Tartarus that was working previously.
    Maybe it's a similar bug, as D3 does cause my default profile's wave effect to freeze, just like OW does to me. I'm afraid I don't know where to access the info such as Noodles posted above.
    Hope that helps somehow!
     
  5. Glad to hear :) I dabble in troubleshooting (lol), so I know how to read logs and try to provide useful info for the most part :)

    @Gneekman, its in a log file located here: C:\ProgramData\Razer\InGameEngine\logs

    in the ingame engine log file. you'll likely see something similar to this:

    [<06:11:2017:20:55:58:900>RazerIngameEngine(RzWinMgrSrv)(0x1e78)(0x1e8c)!!!!!***** Error ] Overlay::CheckGameStart - WFV: WS 2 IC 1 OFFF 0 (395490) - Window 0x000A027A class TankWindowClass process Overwatch.exe PID 0x1b78 Valid 1 - LT (-32000, -32000) WH (160, 28) SWINC 395490 Conn 3

    Now what is interesting in my newest log file is this happens:

    [<06:11:2017:21:37:43:107>RazerIngameEngine(RzWinMgrSrv)(0x1e78)(0x1e8c)] Overlay::VerifyState - _GAME_ACTIVE_***: Time 0x23c FPS 0 GameInfo: Overwatch.exe Graphics Dx11 Windowed 0 64Bit 1 PID 0x7032 hWnd 0x000A027A (TankWindowClass) (1920, 1080) Owner 0x000A027A Desktop (1920, 1080)


    but then goes on to fail anyway:

    <<dspdrv>> - [<06:11:2017:22:14:24:449>Overwatch(rzdspsrv)(0x1b78)(0x354)] ++++++ RZDSPSRV NP instance is disconnecting due to read failure last error 0x6d

    [<06:11:2017:22:14:24:464>RazerIngameEngine(RzWinMgrSrv)(0x1e78)(0x1e9c)] -OsrWinMgr::eek:verlayStateChangeAsync

    <<dspdrv>> - [<06:11:2017:22:14:24:450>Overwatch(rzdspsrv)(0x1b78)(0x354)!!!!!***** Error ] CCommLayer::Entry - Named pipe instance is disconnecting due to read failure last error 0x6d


    This is also interesting:

    [<06:10:2017:23:02:29:334>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)] RzProcMon::Indicate path: [C:\Program Files (x86)\Overwatch\ErrorReporting\x64\CrashMailer_64.exe], parentPID: [8084], pid: [11668], created: [1]
    [<06:10:2017:23:02:29:342>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)] RzProcMon::Indicate: Found child of running game, PID: [11668], ParentPID: [8084], game pid: [8084]
    [<06:10:2017:23:02:29:342>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)] +ProcessUtilities::AddChildProcessToGame
    [<06:10:2017:23:02:29:342>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)] -ProcessUtilities::AddChildProcessToGame: result: [1]
    [<06:10:2017:23:02:29:342>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)] +ProcessUtilities::AddChildProcessToProcess
    [<06:10:2017:23:02:29:342>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)] -ProcessUtilities::AddChildProcessToProcess: result: [0]
    [<06:10:2017:23:02:29:343>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)] RzProcMon::Indicate: Issuing child Start event
    [<06:10:2017:23:02:29:385>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)] RMLUser::stuck_out_tongue_winking_eye:rocessInfoEvent - Process Start - PID 0x28b0 Parent 0x1e78 Path c:\program files (x86)\razer\ingameengine\64bit\RazerIngameEngine.exe
    [<06:10:2017:23:02:29:386>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)] RzProcMon::Indicate path: [c:\program files (x86)\razer\ingameengine\64bit\RazerIngameEngine.exe], parentPID: [7800], pid: [10416], created: [1]
    [<06:10:2017:23:02:29:398>GameScannerService(RzProcessManager)(0x1a94)(0x1a8c)!!!!!***** Error ] RzProcMon::Indicate: Not a recognized process: PID: [10416], ParentPID: [7800]



    Hopefully this doesn't throw the developers completely off track :)


    If there is a regekey for extended logging, i could go deeper...
     
  6. Vth94

    Vth94 New Member

    I hope this will be fix soon ^^
     
    Sinisterj12 likes this.
  7. Outahismind

    Outahismind New Member

    My Diablo III still works, But OW does not. I thought I was the only one and thought it was something I did to make it stop. I'm so glad I'm not the only one with this issue.
     
    russell.anas likes this.
  8. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Just in case, make sure you contact Razer Support about this, as it might just be you and your peripherals.
     
  9. Gneekman

    Gneekman New Member

    I have now done so, since it seems NO Chroma apps are currently working with my system, not just Blizzard games.
     
  10. JoaoVitorPBN

    JoaoVitorPBN New Member

    Same problem here...its not working.
     
  11. russell.anas

    russell.anas New Member

    I am facing the exact same issue as you. Diablo 3 works. Overwatch doesn't. I tried re-installing synapse, razer chroma sdk etc., but nothing worked. Overwatch ended up disapparing from the chroma apps section.
     
    Outahismind likes this.
  12. ItsTory

    ItsTory New Member

    yes I'm using the razer blackwidow chroma v2 and in the razer synapse app chroma apps section for some reason Overwatch disappeared. And the chroma for Overwatch stopped working when the game is launched. Pls fix this asap. I want my keyboard to glow again :slightly_sad:
     
  13. Mosie100

    Mosie100 New Member

    So I contacted Razer a few days ago -- and after going back and forth for four days this is what they said:

    Hello There,

    Thank you for taking the time to submit your Bug report for Razer Synapse. Unfortunately we don't have a fix for your issue as of yet, however we have forwarded it to our development team, and will notify you if a fix is released in a future update. We are always looking to improve the functionality of our software, and your feedback helps. Please ensure you keep your Razer software up to date to take advantage of bug fixes.
    Thank you and have a nice day ahead.
    Best regards,
    Razer Software Team


    I'd like to know if this is actually being worked on because it's almost been a week and chroma app functionality was the main reason I purchased my razer ornata keyboard.
    Please fix this!
     
  14. pancode

    pancode New Member

    I am having the same issue on the Blackwidow Chroma v2, but I am very sure that it is being worked on. They have a whole entire chain of periphreals with overwatch branding, so they wouldn't just not lol. I'd give it another few days, probably by saturday.
     
  15. VengefulAncient

    VengefulAncient New Member

    Pretty sure this has nothing to do with Overwatch. It's Synapse. I deliberately ignored the update after seeing comments on /r/razer about it breaking Chroma effects in Overwatch and they are still working for me with the latest patch.
     
  16. pancode

    pancode New Member

    So maybe, if we downgrade to a different version of Synapse (say: 2.10), then it should work?
     
  17. Outahismind

    Outahismind New Member

    Problem is no matter which version of Synapse you install it auto updates to the latest version. If someone finds the old one please let me know. Otherwise the only way to have the previous version is to deny the prompt after you already have synapse installed.
     
  18. 9377519279

    9377519279 Active Member

    Why you heff break my lights developerz
     
  19. Sinisterj12

    Sinisterj12 New Member

    Waiting for this to be fixed myself. I've submitted feedbacks and logs. Razer Ornata Chroma Keyboard.
     
  20. Sinisterj12

    Sinisterj12 New Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >