Overwatch Stutter with Core and 1080ti

Discussion in 'Overwatch Talk' started by Katana_x_II7, Jan 23, 2018.

Thread Status:
Not open for further replies.
  1. Katana_x_II7

    Katana_x_II7 Well-Known Member

    Ever since the patch that introduced Moira, I have had stutter when trying to play overwatch. The game will stutter about every 3-5 seconds, and freeze for about half a second.

    It works fine when using the internal 1060, only stutters when using the 1080ti. And this is the only game it happens with. Other games in the Blizzard client are fine, and so are games outside blizzard client, as I've played steam games and windows store games fine with no stutter.

    Things I've tried:
    - updating GPU drivers
    - updating overwatch
    - scan and repair overwatch
    - uninstall and reinstall overwatch
    - disabling all programs on startup to see if any newly installed programs interfere with overwatch
    - contacting blizzard support (they pretty much said they dont support eGPUs so im out of luck)

    Maybe some other things I'm forgetting to mention as well, but I've pretty much tried everything except for reinstalling the whole OS

    Does anyone else have this issue? Or any ideas for things I can try? I've searched the blizzard forums and pretty sure I've tried most of the stuff that other people have tried, but maybe I missed something.

    Any help or ideas would be appreciated :)
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >