Problem with NVIDIA Graphics card on Razer Pro 2015

Discussion in 'Systems' started by Sheen The Sheep, Mar 26, 2016.

Thread Status:
Not open for further replies.
  1. I don’t know if anything similar has happened with anyone before, but my Razer Blade Pro 2015 won’t detect the NVIDIA graphics card anymore and only runs on the significantly less powerful Intel graphics card.

    One day it was working properly. I was playing Fallout 4 without a hitch. Eventually it got late, so after several hours of gaming I set my laptop down safely and went to bed. When I picked it up in the morning everything seemed normal, but when I tried playing Fallout 4, it suddenly started lagging and in addition only one of the two fans was running. It was very odd because the settings remained exactly the same from the night before. So I thought maybe the NVIDIA settings had changed to save power and I decided to check it.

    I normally go to the NVIDIA settings by right clicking my desktop then clicking on NVIDIA settings however that option had disappeared from the right click menu. So I decided to go to the NVIDIA control panel directly by searching but when I clicked on it, it crashed saying “NVIDIA Control Panel Application, 8.0.820.0 has stopped working”. I then tried opening Geforce Experience but it crashes without so much as an error message.

    So I tried updating it to see if it would work. I downloaded the same NVIDIA driver (NVIDIA GTX 960M) from NVIDIA’s site, however when I tried installing, I was given the error message, “NVIDIA Installer cannot continue. This graphics driver could not find compatible graphics hardware”. So I checked the device manager and the NVIDIA card did not show itself under Display Adapters (only the Intel card showed). After clicking show hidden devices the NVIDIA card finally showed itself saying however “Currently, this hardware device is not connected to the computer. (Code 45) To fix this problem, reconnect this hardware device to the computer”.

    Seems simple enough, open up the laptop and push the card back into place right? However I have some concerns. I don’t know for sure if the NVIDIA card is integrated into the motherboard of the laptop, which I’m guessing would make the problem far more complex than just pushing it back into place. And considering I paid nearly $3000 for this laptop, I’m afraid of doing something wrong and messing the laptop up completely.

    So I need to know how to fix this problem preferably without opening up the laptop unless there’s no other option.


    TL;DR: My laptop won’t detect the NVIDIA card making it less powerful. Updating didn’t work. Might need to open up the laptop to fix it and not in the mood for accidently breaking my laptop.


    Thanks
     
  2. Blockmonster57

    Blockmonster57 Active Member

    I think your card died :c if it isn't the case, try to remove it and place it back in
     
  3. :slightly_sad: What could have caused the card to die? Everything seemed to be working normally before that day
     
  4. KakashiSharingan

    KakashiSharingan Active Member

    Contact support. In the meantime try and see if you can detect it in device manager.
     
  5. Predator5

    Predator5 Well-Known Member

    Don't! Contact the support or send it to an official servicer if it's still under warranty!
     
  6. I can detect in device manager only if I enable the option to show hidden devices. And even then it says its disconnected
     
  7. And I guess I'll contact support. Sending it to an official servicer though, would be a problem. I'm in Ghana, and the country has a nasty habit of losing almost everything that's sent or received... I don't feel safe sending my laptop overseas.
     
  8. Blockmonster57

    Blockmonster57 Active Member

    Running the Witcher III on maxed out settings?
     
  9. Blockmonster57

    Blockmonster57 Active Member

    Is gsinc on? If it is try to turn it off
     
  10. How do I do that?
     
  11. KakashiSharingan

    KakashiSharingan Active Member

    If it shows it is disconnected that means the computer knows the card was there but can't detect it now. So yea, I think your GPU might be fried... You could try backing up your data and doing a factory reset to see if it now sees it, if not then I'm almost 100% sure it fried...
     
  12. Blockmonster57

    Blockmonster57 Active Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >