Razer blade 15 1070maxq and CUDA programming Ubuntu 18.04

Discussion in 'The Linux Corner' started by Fceku, Mar 29, 2019.

  1. Fceku

    Fceku New Member

    Hey, yesterday I tried to install CUDA toolkit on my machine on Ubuntu 18.04, I followed the official nVidia instructions to do that and well, it didn't go so well, linux crashed, and I couldn't repair it. I suspect that integrated intel card was the culprit, but I might be wrong.
    I formatted the linux and I want to try again, and here's my question, did anyone tried to install CUDA on the blade?? If so, can you share with me the steps to do that?
     
  2. PalmPanda

    PalmPanda New Member

    This is the initial step process I used: https://www.pugetsystems.com/labs/hpc/How-to-install-CUDA-9-2-on-Ubuntu-18-04-1184/ Some thing you may have to figure out otherwise. There are multiple methods of installing it, the one that worked for me was using the CUDA runfile and pressing ctrl-alt-f1 to go into terminal with no GUI and installed it trough there. Had to use this process here: https://askubuntu.com/questions/149206/how-to-install-nvidia-run

    If you have specific issues with your CUDA installation I recommend googling the issue. As of now CUDA runs perfectly as far as I can tell on my Razer Blade 15 2019 with rtx 2060.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >