Razer Blade Battery

Discussion in 'General Discussion' started by iamck, Apr 5, 2016.

Thread Status:
Not open for further replies.
  1. iamckhehe

    iamckhehe Member

    Hi guys , recently my blade battery seems to be having a little problem.
    Once the battery hit 75% it shows (plugged in , not charging ) and blade auto shut down when it reaches around 20-30%. Is this a sign that the battery is damaged already?
    Anybody with similar experience can share any method to rectify this issue?

    Greatly appreciate any help given :)
     
  2. Ur2eZ_4_Me

    Ur2eZ_4_Me Active Member

    Well the issue will either be OS related, battery circuitry, the battery itself, or the charger. I've seen this happen with 2 different laptops (Alienware and HP Omen) and both were the results of faulty charging cables. Do you have any other cables you could use to charge the blade? That would be the first thing I would check.
     
  3. Kringe7

    Kringe7 Member

    I had some battery problems after I had my Blade 2014 overheat, there's a battery software reset you can do if it's not a hardware failure. I can't remember the exact steps so you should search the forums or Google for it, it's how I found it. Fixed it right up.
     
  4. David-El

    David-El Member

    I had the battery on my laptop stop holding a charge as it neared it's EOL. At first it was just like what you're describing, then it got to the point where if I unplugged it from the wall it would shut down within seconds, so I removed it, as I was inspecting it, I saw that it had started to expand.
    Just something to consider, depending on how old the laptop is, and if none of the above fixes work, you may want to at least look at the battery.
     
  5. iamckhehe

    iamckhehe Member

    1st Click Start and type device in the search field, then select Device Manager. 2nd Expand the Batteries category. 3rd Under the Batteries category, right-click the Microsoft ACPI Compliant Control Method Battery listing, and select Uninstall. 4th Restart the computer. Please do the following: Turn off the Blade Allow it to charge overnight while powered off (not sleeping/hibernating) Unplug the Blade Turn it on Use the Blade off of battery until it powers down Charge the Blade fully again.

    This will calibrate the charging sensor. Overnight = 8 hours

    is this the method u talking about?
     
  6. iamckhehe

    iamckhehe Member

    hi guys, my blade battery has gotten worse as it shows (eg 50% available , plugged in, charging ) but in fact the battery level just keep dropping.
     
  7. TyMcLean

    TyMcLean Active Member

    Sounds like your charger isn't allowing enough "juice" to get to the battery.
     
  8. iamckhehe

    iamckhehe Member

    hi , what do u mean?

    Now it shows the battery as charging. but % doesnt go up but keep dropping.
    not sure if its my battery or charger thats damaged.

    Anybody from Singapore could lend me a charger so i can test .
     
    Last edited by a moderator: Apr 11, 2016
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >