Razer Blade Stealth Linux

Discussion in 'Systems' started by Fl3a, Feb 3, 2016.

Thread Status:
Not open for further replies.
  1. Hi,

    I installed Ubuntu 14.04.4 that comes with Kernel 4.2. Everything works great except the sound, sometimes works and sometimes not and if I plug headphones I do get sound, and the wireless. I run your script and it worked. However, after some use, rebooting the system and change to Windows, it stop working and it says "Device not ready".

    Can someone help me?
     
  2. wired00

    wired00 New Member

    Anyone else having issues with the keyboard when clicking the same button quickly? For example clicking enter very fast or 000 for example?

    For me if i click space, enter, any letter rapidly it does not respond. If i plugin a USB wireless keyboard it works perfectly :/

    I suspect it started happening after installing polychromatic controller to manipulate the chroma keyboard colours while in linux.

    I'm using Mint 18 FWIW

    Edit: it has nothing to do with key repeat or delay

    Edit2: well I ended up scrapping mint 18 and going with Ubuntu. the keyboard issue is gone... no idea what was causing it but was driving me mad!

    just wanted to confirm the master.zip archive worked for me to fix wifi in ubuntu. I ran the script, then when i ran a second time it spat an error something about two files already existing. I then rebooted and finally i have wifi without my dongle. Annoying thing is I already ordered an intel replacement m2 card, oh well.

    just wish I could fix that suspend issue. i've tried all the proposed fixes on this thread nothing works.

    I'm running Ubuntu 16.04 LTS
     
    Last edited by a moderator: Aug 13, 2016
  3. same here everything works out of the box except the suspend and none of the fixes worked for me, i did however find a workaround. in gnome shell, there is an extension that adds the suspend button to the user menu in the top right corner, i just make it a habit to hit the before i close the laptop
     
  4. wired00

    wired00 New Member

    Ahh interesting i'll have to check that out. I've basically just disabled auto suspend all together in the OS both for timeout and lid close, then just manually click suspend before shutting the lid. seems to work then, far from ideal obviously though... :/
     
  5. i agree, id would rather it just work .. but the only other option i can think of is just binding a hotkey to enable suspend.. still not ideal but, hey if it work , it works . hopefully someone will find a fix that will work soon
     
  6. wesdalelio

    wesdalelio Member

    The system itself could support Linux easily just like it can for Windows, but it would not be practical to try this on such a great system, unless you had a really good reason, or wanted to see the result, and did it by partitioning a drive!
     
  7. some of us want nothing to do with windows.. this machine was exactly what i was looking for down to every detail. and it was practical for me to completely wipe windows for linux as i am a linux musician and dj and the applications i use were meant for and work better on linux...other than the suspend issue (which is really not that big of a deal to me) and proper chroma support everything works with out the need to install drivers ..at least for me, so it being a practical move is completely up to the user..
     
  8. sololinkHeatWave167

    sololinkHeatWave167 New Member

    For the drivers on the Ubuntu related post above to work, you need to be on kernel 4.6+. This applies to Mint 18 specifically, as it ships with 4.2.
     
  9. i have it working on ubuntu gnome with 4.4, last i tried with 4.6 it wouldn't work at all, (though that could have been because i usually opt for the low latency kernel) ill update to the standard 4.6 tonight and see if it works better


    UPDATE: can confirm the low latency kernel interferes with the drivers. however, i just installed 4.6.3 standard kernel and all is still good
     
    Last edited: Aug 4, 2016
  10. easySalmonpoint069

    easySalmonpoint069 New Member

    I tried to update the kernel but I get a weird error when booting up to it something about lvmetad.
     
  11. HeartGoldrushup474

    HeartGoldrushup474 New Member

    Latest Fedora 24, WiFi script doesn't work.

    Anything I should try?

    Edit:

    Figured it out! Go into the BIOS and enable that thing that has to do with loading network firmware in BIOS. If that's on WiFi works!
     
    Last edited: Aug 23, 2016
  12. HeartGoldrushup474

    HeartGoldrushup474 New Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >