Razer Core: mouse and keyboard via usb problem

Discussion in 'Systems' started by fakeian, Jun 3, 2016.

Thread Status:
Not open for further replies.
  1. I'm having this issue too: XPS 15, Razer Core (R9 290), and Black Widow Ultimate. The interesting thing to me, is that it seems fine with my other keyboard.
     
  2. Sidedoor

    Sidedoor Member

    Did the USB/Keyboard problem get resolved? I have the same issue. IT seems this thread went off on a tangent about laggy screens. Not that I minded as I need that information as well
     
  3. Derek712

    Derek712 Active Member

    I haven't checked in a week but I think it's still an issue. I just hook my USB hub directly to the blade now.
     
  4. Sidedoor

    Sidedoor Member

    Thanks for your reply, its a little annoying as I was loving the Core being a one stop docking station
     
  5. intractv

    intractv New Member

    It's still a problem. I've connected a USB hub to the RBS and run everything off of it. Even then I do get a mouse blip every great once in a while but nothing like when it was connected to the Core. I opened a ticket and they wanted me to send it back but I've decided not to at this point as I know it isn't specific to me and I just don't want to pack it up and be without it for an extended period.
     
  6. AmazingSpanoMan

    AmazingSpanoMan Active Member

    Hi guys,

    I'm having a similar problem. I have an orbweaver, BlackWidow TE, Mamba, and Firefly connected to the four ports on the Core. I find intermittent blackouts on my Mamba and BlackWidow (with the blackout on Chroma as well) along with slight quick lights off and on with the orbweaver. I also noticed that the Chroma would reset on the Mamba and that the keyboard keys I have bound to the top two buttons on the Mamba also stop working. It starts to work again once I do a restart but it only takes a couple minutes of use before things stop working again. I'm wondering if the Core just doesn't have enough bandwidth to run a GPU and the peripherals. A couple of videos on YouTube say that the benchmark scores go down with peripherals attached which also suggests a bandwidth issue.

    I plan on just getting a powered USB 3 hub and connecting directly to the laptop. I'm also going to put a support ticket in as well.
     
  7. Cyraxus

    Cyraxus Active Member

    Honestly the only USB powered device I can connect to the core is my cooling pad which just controls a fan. If I plug anything else into that thing the performance gets shitty. That's concerning considering I want to buy a VR headset in the feature to plug into that thing. Doesn't look like that's happening until they fix this. I'm also wondering why the Pascal cards aren't "supported" yet in the core.
     
    Circuit.Board likes this.
  8. Sidedoor

    Sidedoor Member

    Which USB hub are you guys using. Have to bite the bullet and get one as getting too many things to connect now and the mouse and keyboard problems are diving me nuts
     
    Circuit.Board likes this.
  9. AmazingSpanoMan

    AmazingSpanoMan Active Member

    Not sure but I'm checking Amazon right now...
     
  10. Sidedoor

    Sidedoor Member

  11. AmazingSpanoMan

    AmazingSpanoMan Active Member

    I got something similar. So far everything seems to be working, though I did need to use the extender that came with my Man O War headphones to move the dongle away from the USB Array. For some reason it was causing interference. Apparently it has something to do with USB 3.0.

    I am having issues with the Razer Mamba saving my Chroma Configurator settings though still. Such a pain. I sent in a bug report and they told me to reinstall Synapse, no dice.

    Then I got another response asking for a ton of copies of files that may or may not be in hidden folders. What a pain!
     
  12. warsock

    warsock New Member

    Why hasn't this been addressed by razer? Seems like a ton of people are having issues with the cores USBs
     
    hubick, Cyraxus and dyeLucky like this.
  13. BenHead1

    BenHead1 New Member

    A ton and one. I got my Core yesterday, installed with a 1080 connected to a 2016 Blade. The first USB issue I noticed was with my Vive: one controller would randomly stop tracking while I was using it. Then when trying to Google that problem, I had the keyboard trouble, with key events registering late (either a delay before the letter appeared, or letters repeating for no reason). I'm not using a Razer keyboard, I have a basic Logitech setup connected to a powered USB 3.0 hub. (The Vive was connected directly to the Core, not through the hub.)

    Like others, everything works connected directly to the Blade, so it's definitely an issue with the Core's USB ports. One-plug docking would obviously be much nicer, and there's no way a keyboard should cause bandwidth problems. I'm hoping a software update will fix it, since it'd be a hell of a big deal to fix this many people's hardware issues. Obviously Razer should at least recognize it.
     
    warsock and Cyraxus like this.
  14. warsock

    warsock New Member

    Blows my mind. They came out with a whole new blade stealth but they haven't replied to this thread.
     
  15. SaltyDawgz

    SaltyDawgz Member

    It may be a faulty Thunderbolt cable or maybe to do with your drivers. I doubt it though, by the looks of it there seems to be alot people having the same problem.
     
  16. warsock

    warsock New Member

    At first I thought you were suggesting this because your device functions normally. Are there people who don't have this problem?
     
  17. BenHead1

    BenHead1 New Member

    It would be really weird for it to be a bad cable since the graphics works fine. The PCIe bandwidth is way higher than USB, so more demanding of cable tolerances. It's possible TB3 carries USB and PCIe on different pins - I don't know - and Razer got a bad cable batch with only the USB pins faulty, but that would be as weird as a bad batch of Cores not caught in QA.

    I hope it's a driver (or firmware) problem, since then they could fix it more easily, at least once they acknowledge it. I assume I'm using the same drivers as everyone else, since it's stock Windows 10 on a two-month-old Blade.

    For now I'm going to wait and watch (and maybe tinker with some settings if I have time). As others have said, I have another 11.9 months of warranty if it needs RMA, and in the meantime, they may acknowledge it as a known issue or even fix it with a software patch. Fingers crossed.
     
    tasumask and warsock like this.
  18. BenHead1

    BenHead1 New Member

    It looks like the main 40Gbps TB3 channel is used for both PCIe graphics and the Core's USB ports and ethernet. (TB3 also has a separate USB channel on other pins, but it's USB 2.0.) In Device Manager I can see the device connections fork, with an "Intel USB 3.1 eXtensible Host Controller" as a sibling to my GTX 1080 card. (The ethernet is provided by a USB ethernet controller hanging off that.)

    This still doesn't exactly tell us where the problems are. Is it the USB 3.1 controller driver (a generic Microsoft driver right now, and I don't see others from Intel)? Is it the Thunderbolt driver (Intel has newer ones here than what came with my Blade, which work but don't fix this problem)? Is it Core firmware not properly managing signaling between the graphics card and the USB controller? Something between the keyboard and operating system is sometimes delaying USB signals, but which of the many items in the chain is it? I can't tell.

    On the bright side, the more I learn about it, the more it starts to seem like something that can be fixed in software - either drivers or firmware - rather than something that would require a hardware replacement.

    (FWIW I also tried the old chestnut of disabling power management on the various USB hubs serving the keyboard, but no luck.)
     
    tasumask and warsock like this.
  19. Tazzik

    Tazzik New Member

    I was having this problem big time on my Razer Blade 2016 + Razer Core w/ GTX 1080. My mouse and keyboard are the Blackwidow Ultimate and the Mamba 2012. I've also got an Orbweaver. The stuttering appeared to happen mostly with apps designed for Windows 10 (such as Microsoft Edge, Cortana, the start menu, etc.). Anyway, I tried a lot of stuff from this thread with no success.

    So, I tried some of my own experimenting and eventually tried disabling the Intel HD Graphics from the device manager (so that both the Intel and 970M inside the laptop are disabled). Lo and behold, I've had zero problems with stuttering since!
     
    BenHead1 and Cyraxus like this.
  20. BenHead1

    BenHead1 New Member

    Interesting. Do you have any more details, because I see unexpected behavior when I try that. For one thing, when I disable the Intel HD Graphics, my laptop display still works! Windows thinks it's connected to a "Microsoft Basic Display Driver" adapter. Is this what you see as well?

    Also of note, my 970M is still enabled in Device Manager. It's just "Inactive" according to Nvidia GPU Activity tool, because there's nothing on that display that'd trigger Optimus to switch. I had hoped to keep that chip available for things like PhysX, even though apparently my Vive space is 10cm too small for Nvidia Funhouse. :expressionless: Is that also how yours is configured?

    Still, it seems to work for me, too! I haven't encountered a keyboard issue typing this long-winded reply, although Chrome is one of the apps where I encountered problems before. (Like you, it seemed to depend on the app - I did a bunch of typing into Notepad to test some of my earlier attempts and it didn't happen there.) This workaround would have interesting implications for who/what/where is culpable, though I'm not sure exactly what they are. Either Windows not working the way it should or one (or both) of the Intel or Nvidia drivers, I guess.

    Assuming this is a proper workaround, the remaining question for me is which is more hassle: disabling/enabling this driver when I dock/undock, or connecting/disconnecting one or two more USB cables. :stuck_out_tongue_winking_eye_: Perhaps the device switching could be scripted somehow... Did you also try just disabling the laptop display, without disabling the device? I might try that, since Windows will remember and automatically make that change when I dock/undock. Having the second screen always seems like something I'll want but never actually use...

    Anyway, thanks for posting, Tazzik. I still hope a proper fix comes out soon (rather than Razer, Intel, Nvidia, and Microsoft all just pointing fingers at each other), but this is awesome!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >