Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

RAZER KRAKEN 7.1 V2

Discussion in 'Razer Support' started by s_a_s_k, Jul 3, 2018.

Thread Status:
Not open for further replies.
  1. s_a_s_k

    s_a_s_k New Member

    My device is not showing up in Razer Synapse 2, I tried to plug it in another USB port but sadly no effects also I tried to plug it in other computer. Any ideas?
     

    Attached Files:

  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Oh hi there! When did this start to happen? Also, have you tried uninstalling the drivers, unplugging the Kraken 7.1 V2, restarting the PC then replugging it?
     
  3. s_a_s_k

    s_a_s_k New Member

    This started like two days ago, I tried installing the most recent drivers for my device and unplugging when my PC was off and then plugging it again when it was on
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >