Razer Man O War 7.1 Chroma USB device not recognized

Discussion in 'Razer Support' started by SkyeDrive, Sep 6, 2018.

Thread Status:
Not open for further replies.
  1. SkyeDrive

    SkyeDrive New Member

    I recently bought the Razer Man O War Chroma yesterday. I'm having an error when connecting it to my pc. This is the error "USB Device not recognized" I tried to plug the Wireless USB Tranceiver to other ports of my pc but the error always pop up. I also tried to plug it to my brother's laptop and my brother's pc but it's having the same error. I tried to google the solution of the error but none of them works on me. Please help me with this problem. Sorry for my bad english.
    [​IMG]
     
  2. LuiProyekto

    LuiProyekto New Member

    i have the same problem, i tried to unplug it, work like 5mins then Unknown USB device again
     
  3. SkyeDrive

    SkyeDrive New Member

    yup that's my problem too works in a couple of minutes then Unknown USB device again. I manage to make it work try to system restore your pc.
     
  4. LuiProyekto

    LuiProyekto New Member

    This might work, connect the usb dongle directly to the usb port. Mine is working now
     
  5. Razer.FirePenguin

    Razer.FirePenguin Keeper of the Flames, Bane of Sardines

    Are you using a USB HUB? Try what @LuiProyekto mentioned by plugging it in directly to the USB port.
     
    freakydoctor likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >