Razer Naga Chroma *not* enabled in Razer Synapse - PLEASE HELP ME ...

Discussion in 'Mice and Surfaces' started by Belgianfilmfreak, May 4, 2017.

Thread Status:
Not open for further replies.
  1. Belgianfilmfreak

    Belgianfilmfreak New Member

    Hey everyone,

    I'm very new here and have recently bought a new mouse: Razer Naga Chroma.

    I installed the Razer Synapse, but the mouse is *not* recognized. I can't access any of the options. The only thing I see is the word 'STATS'. (see attachment, please)

    Please help me ... I'm desperate ... I sooo wanted to play videogames during my spare time, and now I can't ...

    Thanks for any help.

    Respectfully,
    the Belgianfilmfreak. No mouse.JPG
     
  2. MrPonyy

    MrPonyy Member

    Try to unsistall/reinstall synapse maybe
     
  3. Belgianfilmfreak

    Belgianfilmfreak New Member

    thank you all for helping me, especially dridridu56. Through a relapse of trials and errors that would even madden a peaceful Chinese monastery priest, I have (accidentally perhaps?) found the solution. The key is that WINDOWS has to acknowledge your mouse, irregardless of whether one has Synapse installed or not.
    ---> Okay, Sam Fisher aka Splinter Cell ... I'm ready to save the world. Phew ... took me long enough to get this mouse working. Thanks again to all - I'm SUPERhappy now! :) :) :) :) :)
     
    Last edited: May 4, 2017
    MrPonyy likes this.
  4. MrPonyy

    MrPonyy Member

    Nice, that cool you solve, good game to you :)
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >