Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Phone Factory Images are now LIVE

Discussion in 'Mobile' started by Khanger, Feb 14, 2018.

Thread Status:
Not open for further replies.
  1. Khanger

    Khanger Administrator Staff Member

    Hey everyone, I know you all have been asking for the Razer Phone factory images for some time. We're happy to announce that along with the kernel source, they are now available at: https://developer.razerzone.com/razer-phone-dev-tools/.

    What this means is that you will be able to flash these images to restore your Razer Phone back to its original factory state.

    We strongly recommend that you read the General Instructions very carefully prior to attempting a flash of a factory image. If you are unfamiliar with this process, and don't feel comfortable with it, please do not try it as you may end up bricking your phone, rendering it unusable.

    Disclaimer: Unlocking your bootloader will void your warranty.
     
  2. hasimo14

    hasimo14 Well-Known Member

    now now.... since the commotion for a few days finally it's here.... told you all just need to wait
     
    MrPonyy likes this.
  3. Bruce_wayne8887

    Bruce_wayne8887 New Member

    Wow. Bravo you guys came through. :)

    Guys please notice this when flashing
    -
    Cables
    When connecting your Razer Phone to a computer for any development, it is advised by Razer to not use the in-box USB Type-C to Type-C charging cable for flashing. The supplied cable is specifically engineered for fast power delivery, not for data transfer. Razer recommends you use a USB 3 Type-A to Type-C spec-compliant cable for any device flashing.
     
    MrPonyy and Gabri110 like this.
  4. hasimo14

    hasimo14 Well-Known Member

    maybe this is also why a lot of razer phone users also have trouble while doing data transfer from pc....
     
    topher82, MrPonyy and Gabri110 like this.
  5. Bruce_wayne8887

    Bruce_wayne8887 New Member

    Unless you have a PC that has a USB C port (older computers do not) this wont affect you and you wouldn't be able to use the C to C cable. The Essential Phone has the same issues and can't use the cable in their box either.


    I know the disclaimer says just unlocking the bootloader voids your warranty but what if you unlock it and flash the factory image then relock the bootloader? As in no custom software or rooting involved. Does this still void the warranty @Khanger ?
     
    Last edited by a moderator: Feb 14, 2018
    Nanvinor123, MrPonyy and ltthckr like this.
  6. Runnerxs

    Runnerxs New Member

    Thanks for finally releasing this.
     
  7. charliest

    charliest New Member

    Ah, I suspect our complaints were heard by management. I thank you for the images and hope that this was a learning experience for Razer.

    I installed the latest image with no problems at all and things appear to be running well.
     
  8. Eoghan2018

    Eoghan2018 New Member

    I wonder if the global image can be installed on the UK three phone in order to debrand the device that way OTA updates that razer release should install with no waiting period. Me thinks it's time to test that one on my phone tonight by installing the MR2 image and see if the OTA downloads for mr3. I'll report back soon

    MR2 global firmware flashed and this is the result

    Goodbye three taking there time pushing the updates ;)

    EDIT: OTA update failed like i expected ad the delta checksum for the boot partition failed so the update failed. Razer could resolve this with future OTA's but as for now im manually flashing via fastboot. ether way if your on three and want to debrand your device its safe in my opinion to do so ;)
     

    Attached Files:

    Last edited: Feb 14, 2018
    Rox598 and ltthckr like this.
  9. ltthckr

    ltthckr New Member

    I'm from 3 too.
    I want to do the same thing like you.
    Wait until it can use OTA update.
     
  10. Eoghan2018

    Eoghan2018 New Member

    Go ahead and do it I would guess the next ota from razer will most likely be Oreo since the guide to flashing the factory images has instructions for Oreo as well. I just hope razer keep updating the factory images inline with future otas or at least upload corrected otas that won't fail on Delta updates
     
  11. angelbreathe

    angelbreathe Well-Known Member

    Patience really is a virtue...
     
  12. RobeusRT

    RobeusRT New Member

    Did you try to install Global MR1 or CHK (Three) MR1? Is it possible right now to be able to receive OTA updates again after flashing any of these images?
     
  13. Hi there, i flashed the global version and i was on three uk firmware before . when my device is booting i get an error with red . your device is corrupted and cannot be trusted. and i need to press power to continue. if i press power my device boot and works normal is fine .any ideea how i can get rid of that red error ? tried to disable oem lock on developer menu .after i flashed i lock the booloader again. tried to go to recovery and factory reseted,i don't know what to do to get rid of that error . somebody?
    thank you
     
  14. Eoghan2018

    Eoghan2018 New Member

    Explain the steps you did when you where installing the global image?
     
  15. so i installed the adb drivers from google .i launch CMD . i cd/ where i unzip the factory image and i write flash_all and is start to do it automatically then is rebooted itself so i keep press down button is booting back to bootloader so i lock the bootloader back when is trying to boot i got an circle with clearing message and the first boot i got an error witch i need to press power to skip it , your device is not corrupted and cannot be trusted
     
  16. Rox598

    Rox598 Keyblade Master VANGUARD

    Not the hero people on here need, but the one they deserve.

    Just out of curiosity did you try flashing the image on both A and B partitions to see if that helps with OTA?
     
  17. Eoghan2018

    Eoghan2018 New Member

    The flash_all script inside the package automatically flashes onto both A and B partitions. I think the deltas failed due to the image probably being compiled before the latest ota update so fingers crossed when razer release the next ota it won't fail.
     
  18. Rox598

    Rox598 Keyblade Master VANGUARD

    Smeg thought it only flashed one, ah well keep us informed please.
     
  19. ltthckr

    ltthckr New Member

    I think your problem is timeout command, because I found it when I tell my friend to flashing image.
    If you can't use timeout command like this, problem is path is not set to system32.
    [​IMG]
    please add system32 path:
    Code:
    set path=%path%;c:\windows\system32;
     
  20. techN00b

    techN00b New Member

    hello, i am using a singapore razer phone and till date i have not receive any updates, and since factory image have been released, i thought of doing the manual flash, will this void my warranty? and do i really need to unlock and relock bootloader?
     
    suhail and Nakoshi666 like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >