Razer Phone missing Fingerprint menu in Security. Finger scanner not working!!

Discussion in 'Mobile' started by cuberootg, Dec 28, 2017.

Thread Status:
Not open for further replies.
  1. cuberootg

    cuberootg New Member


    So ive been using my razerphone for the last 2 weeks. But i woke up today and finger print was no longer working. I tried checking settings and it was gone now. I factory reset and it still doesnt show "fingerprint" in security menu. What is going on? Anyone who encountered this? thanks!

    Attached Files:

    DragonNemesis likes this.
  2. Rox598

    Rox598 Keyblade Master

    I had this happen to me I had to factory reset the device about 5 times before it started working again (and wipe the to surface with a wipe pretty hard too) as I kept doing it it eventually started to come back to life.

    Phone is away now doing an RMA but keep factory reseting and hope it comes back, you'll know it does when it asks for a secure screen using fingerprint and pattern etc
  3. Khanger

    Khanger Administrator Staff Member

    Thanks for letting us know. I'll inform our engineers.
  4. Anichenfire

    Anichenfire New Member

    Hi there,

    I was having a similar issue with my Razer mobile device. Sometime yesterday afternoon the fingerprint option stopped working to unlock my device. I kept getting this persistent error: "Fingerprint enrollment didn't work. Try again or use a different finger." So here is what I did:

    1. Restarted the device a few times. Error persisted.
    2. I deleted my current fingerprints and tried to setup a new fingerprint under Settings>Security>Fingerprint. Again, error persisted.
    3. Reset device back to factory settings a few times. Error persisted, even during the setup process.
    4. Reset to factory settings one last time and setup up my accounts. Error still occurred.
    5. I then let the battery drain all the way to 0%. While the device was dead, I clean the fingerprint scanner VERY thourougly with a microfiber cloth, making sure there was not prints or oils left over. I then plugged the device in to charge and let it sit until the battery was 100%. Once the battery was full, I turned the device back on and ...what?

    It worked? Just like that, I was able to setup a fingerprint and the scanner is back to working properly. I am not sure if this is a permanent fix or if its even a fix at all but the scanner is working properly again. Just thought I would bring my experience to the table.

  5. Micronuke

    Micronuke New Member

    I'm also having the same issue, "Couldn't process fingerprint, Please try again" I've tried all of the above steps as referred by 'Anichenfire' and still not working.

    Hopefully its not a hardware fault, and we hear back form the engineers soon :)
  6. TheCrazyLex

    TheCrazyLex New Member

    It would be cool if someone who is experiencing this issue could generate and upload a bug report zip (in developer settings). I would be happy to take a look.
    leonardrogers likes this.
  7. Micronuke

    Micronuke New Member

    As an update for people interested or facing a similar issue, my finger print sensor started working again after 2 days of not working suddenly. It was behaving as if it was detecting a wrong fingerprint constantly and and just jumping to the exception of 'too many attempts'.
    firstQUARTZLilac434 likes this.
  8. adamcwy

    adamcwy New Member

    I am facing exactly the same problem.

    I received my phone on last Friday (a very proud owner of the Razer phone ever since). However, the finger print scanner is not working at the moment and I can't find it on Security setting either... I am only into day 4 of the phone daresay!
  9. dpgx81

    dpgx81 New Member

    This worries me because I've seen issues where it wont read my finger print occasionally but it hasn't disappeared altogether. In my case I think I receive an error in regards to 'the device admin' which I'm assuming is due to corporate Outlook Settings messing something up. I've had no issues on other Android phones with corporate policy and fingerprint readers though. Hopefully it's addressed in the next firmware update.
    0V3R_K1LL likes this.
  10. unkn0wnfreed0m

    unkn0wnfreed0m New Member

    I have had to same issue today. I went to bed with the phone working 100%. I have woke up and it is having this issue.
  11. Crana

    Crana New Member

    Same Issue for me today, too lazy to reset it multiple times though, hopefully and update can fix it, if not imma live without the sensor i guess...
  12. Dysention

    Dysention New Member

    I just recently got my phone as well; this issue just happened. I tired to factory reset it and nothing happened, the option for the fingerprint was there for a split second and when I tried to open it it would crash every timeo. After 3 months it's kinda disappointing to see this issue hasn't been resolved yet.
  13. Sorakh

    Sorakh Member

    Perhaps you need to update your firmware first? Im not having this issue though. If it persist, let the support team know!
  14. Dysention

    Dysention New Member

    Currently my phone is on the latest version.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >