Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Ripsaw Problems?

Discussion in 'Broadcaster' started by AndyDrewGames, Aug 9, 2016.

Thread Status:
Not open for further replies.
  1. coastDrabretro926

    coastDrabretro926 New Member

    Hey guys, so I just got a brand new Ripsaw, but it can't seem to get the video from my consoles (xbone).
    Any idea? Light is green, reinstalled drivers, have dual 970s with an AMD FX vishera 4.0GHz processor.
    I was also wondering if it's simply not supported with AMDs... Thanks guys!
     
  2. Vivulux

    Vivulux Active Member

  3. Junch

    Junch Associate Product Manager Staff Member

    Hi @AndyDrewGames just as a quick question, are you using the Ripsaw with OBS, XSplit or something else?
     
    AndyDrewGames likes this.
  4. coastDrabretro926

    coastDrabretro926 New Member

    Already tried! Thanks though

    Thanks for the response! I'be tried using it with OBS Classic and studio, as well as XSplit Broadcaster/Gamecaster.
    For all of those programs, my ripsaw just wasn't putting out any signal, even though I was able to switch to the game on my tv and see it through the Ripsaw.
    I think this is worth mentioning, I have an AMD processor, and I see that the CPU Req calls for an intel. Will that affect anything?
    Thanks again!
     
    Last edited by a moderator: Aug 10, 2016
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >