Razer Support

Discussion in 'General Discussion' started by technokat, Nov 9, 2014.

Thread Status:
Not open for further replies.
  1. EODeuce

    EODeuce Active Member

    I think the only battery indicator is in the utility app
     
  2. Shawzborne

    Shawzborne New Member

    battery was at 90%
     
  3. Antosa

    Antosa Active Member

    Wow, this is really sad. But I guess you can always expect there to be a few defectives in the lot.
     
  4. babbyai

    babbyai New Member

    Is y
    the baterry problem?? Or did your drop before?
     
  5. Shawzborne

    Shawzborne New Member

    it is brand new out of the packaging
     
  6. NineTailFx

    NineTailFx Member

    That does sound a bit odd. I would consider doing a factory reset to double check. That might clear up the problem. If not than I would have to say there are still a few bugs even with the latest release in the firmware, and another update will fix it. Otherwise, it does sound like a possible hardware issue. If that's the case submitting a ticket for support is your best bet right now like you have done. It doesn't sound like it would a problem with the Razer application nor your device. If it was your device pairing anything else would have a similar effect. Unfortunately, it could be the Nabu
     
    justinpierson likes this.
  7. NineTailFx

    NineTailFx Member

    That does suck, that it happened. To you, it is actually the second post I have seen that someone has had the same issue regarding their screen cracked. For example. I would like to hope, it has nothing to do with the actual manufacturing of the device. Either way, the cracked screen is an issue. If it really did come out the box that way, I would contact support and open a ticket. They should be able to replace it without a problem. They respond within 24 hours so, I would imagine you can hear back from them shortly.
     
  8. Till now most of Nabu fans must have tested it. This thread is to post all the bugs/solution that you figured out while testing it.
    I have noticed few bugs till now.
    Phone- iPhone 6 plus
    Update Nabu firmware

    1. Sleep tracker dint work for me (will check again tonight).
    2. steps count is not accurate and counts steps even if you swing your arm.
    3. battery discharge is 30% in 15 hours ( all settings on minimal)
    4. App app data and device data doesn't match even after pairing and syncing.
    5. Brightness doesn't change when I switch it from low-medium-high
     
  9. Sycks

    Sycks New Member

    Is this a common thing? I'd hope for it to be highly uncommon. I understand it's still a beta kinda thing but that sucks man. Are they going to help at all?
     
  10. XxZIOIMIBIExX

    XxZIOIMIBIExX Active Member

    well, i can safely say that number 2 is not a bug (i dont know of a pedometer, that can track every single step in a day, and not miscount a single one, want that kind of accuracy? count them yourself is the only option)........but carry on.
     
    Last edited: Dec 10, 2014
    socca and Tengu like this.
  11. Khetix

    Khetix Active Member

    If it was like that out of the box or no obvious outward damage to the device I'm sure Razer Support will replace it as part of the device warranty. Reading from others who've posted here and what I've seen on the Insider... 2 of 5,000 units (for the first release) is a really low rate of failure or defect. That number would likely decrease as manufacturing increases.

    It totally sucks for those 2 people, but Razer has shown excellent customer service over the years and I'm sure they'll resolve quickly, imo.
     
  12. Destrok

    Destrok Well-Known Member

    One thing to keep in mind about the sleep tracker is that your sleep counts for the next day after it hits midnight. Also it is easy to forget to set it in sleep mode. I am not really sure if this is the best medium to report all your bugs. But then again I guess not everyone has access to the feedback platform. The Nabu has come a long way since when the beta units first shipped. And although alot of progress has been made, Razer was working with only 500 of our beta units, and now they have already shipped 5000, with the number of units and different devices they are being used on continuing to increase. While we all use the same few operating systems on our devices, the coding can still interact in a few different ways. Just be patient. It is a launch of a brand new product and a few kinks are to be expected. During the beta Razer took all my feedback seriously and even got back to me personally within a timely manner when it was necessary. They have also used some different materials than the beta units because we determined a few of the parts were not quite rugged enough. So please just bear with them, I am sure that soon enough the kinks with the app will be worked out.
     
    Zoidbee likes this.
  13. Destrok

    Destrok Well-Known Member

    It very well may be a manufacturing defect. When I received my first beta unit the screen would not light up at all. It paired with my phone perfectly fine, I was able to connect to and use the apps. However the screen was just dead. However, I would be more willing to bet that it is damage that occurred during shipping. I work in retail and even the shipments we get direct from corporate or even activision have damaged product just from shipping. I had a delivery guy leave my brand new Astro's in 18 degree weather on my front porch without even ringing my doorbell. And bottom line, no matter who is at fault, shit happens. Razer very promptly got back to me and shipped a new Nabu when I contacted support about my broken screen.
     
  14. XxZIOIMIBIExX

    XxZIOIMIBIExX Active Member

    no it cuts off your sleep goal time at 12 am, i have screenshots on my thread
     
  15. Destrok

    Destrok Well-Known Member

    Link me the thread so I can take a look. Maybe yours is different because I have a beta unit and an older phone. Or maybe we are just describing the same thing, haha.
     
  16. Destrok

    Destrok Well-Known Member

    I have also been crazy busy with work and everything lately, this has been my first day off in a few weeks so I may need to update my firmware and just missed the notification.
     
  17. XxZIOIMIBIExX

    XxZIOIMIBIExX Active Member

  18. Destrok

    Destrok Well-Known Member

    Lol yeah we were talking about the same issue, we just worded it in different ways.
     
  19. XxZIOIMIBIExX

    XxZIOIMIBIExX Active Member

    ahh lulz...i feel dumb now...again XD
     
  20. Destrok

    Destrok Well-Known Member

    Lol nah, it happens to all of us. We just described the same thing in different ways. The way you said it made more sense than the way I worded it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >