Rocket League Chroma Control

Discussion in 'Razer Chroma' started by manni, Feb 15, 2016.

Thread Status:
Not open for further replies.
  1. the take the shot button does not seem to work for me. I.e: doesn't do anything.
    is there any chance it's because i'm hoping to use it on the "new razer blade 14" 2016 ?
    (i located the .exe file using the steam method described)
    thanks for your help
     
  2. heavenleetBisque926

    heavenleetBisque926 New Member

    That's a notebook, right? I have no idea if the keyboard will take the effects and how it looks.

    Is it just that nothing is happening when you click the button? I am having a problem on my end of the Steam launch request window not showing up properly, until I bring Steam into the foreground, so try hitting the button then bringing up Steam.
     
  3. lokasz

    lokasz New Member

    Can you help me? Nothing is happening. (Blackwidow Chroma)
    [Edit]: It's not even detected as chroma app by Razer Synapse
     
    Last edited: Sep 24, 2016
  4. heavenleetBisque926

    heavenleetBisque926 New Member

    It will only show up in the chroma apps once it successfully launched. If you managed to locate your .exe file correctly and "nothing is happening" when you click take the shot, try the following:
    without closing RLCC, bring up the Steam main window. Maybe this will make the security dialog show up for you. On my PC, the Dialog is kind of hidden for some reason but I always thought that was because of Displayfusion (3rd party app). Anway, check if bringing up the Steam Main Window after clicking the button brings up the modified launch window, it does for me.

    Okay guys I have heard your pleas, locating RL failed or whatever. This new version reads from the registry again and instructs Steam to launch Rocket League with the relevant parameters for you. This means that as long as you have installed Steam correctly and own Rocket League, nothing can go wrong anymore (here's hoping).

    Conveniently, this also gets rid of the security alert from Steam when launching RL!

    Note that you can no longer use this if you're using a pirated version of RL, but I don't care in the slightest.

    If you could kindly grab v 1.1 here: https://github.com/d-karl/Rocket-League-Chroma-Control/releases/tag/v1.1 and let me know if it works for you, I'll publish it to the Chroma Webstore unless I hear complaints. Thank you!
     
    Last edited by a moderator: Sep 27, 2016
  5. lokasz

    lokasz New Member

    [​IMG]
    I'm so annoying.
     
  6. heavenleetBisque926

    heavenleetBisque926 New Member

    :confused_: So basically, my program finds the correct path but it doesn't work for some reason. Are you on a limited user account (not admin) by any chance? I honstly do not know what to make of this right now.

    So here's a workaround, its not optimal but it will work.
    • Just start RLCC and leave it sitting there.
    • Go to Steam Library, find Rocket League, right click and go into preferences
    • Click set launch options and enter "-log" in the text box
    • You can now start Rocket League throught Steam and you should get keyboard effects.
     
  7. chrizZztian

    chrizZztian New Member

    The startup with the new version works better - nonetheless somehow the keyboard still switches to "white breathing mode".
     
  8. heavenleetBisque926

    heavenleetBisque926 New Member

    Version 1.1.1 is up, this now relies on QT (framework) to start the RL process. I assume they are better coders than me and this might fix the start for some people. Feel free to get it from https://github.com/d-karl/Rocket-League-Chroma-Control/releases/tag/v1.1.1 if you are still having launch problems.

    In regards to:
    The white breathing effect is intentional to signal that RLCC has taken control of your lighting. It should switch to something more colorful though if you reach the main menu, that's not working for you? First report I have had of that.
     
  9. chrizZztian

    chrizZztian New Member

    Hmm no it's not working for me. It just keeps breathing. Already tried disable / enable, task switches etc.

    The only thing I could image is that I am using a "second" directory for my steam games. Steam is installed on C:/.... My SteamLibrary is on D:/.... (Just a guess - don't know if this has any effect.)

    Guess I'll simply swap it to the original path and see if there are any changes.

    €dit: Nope doesn't work.
     
    Last edited: Oct 1, 2016
  10. heavenleetBisque926

    heavenleetBisque926 New Member

    chriZZtian, I am sorry if I am getting my people confused. Were you the person who said their console window has green letters? Did you do anything fancy to your console or something? Skinning, change fonts or something like that? What language is your Windows if I may ask? Feel free to PM if you don't want to disclose publicly.

    Edit: using v1.1 and higher should not care where your Rocket League is installed, RL is now launched through Steam.exe.
     
  11. chrizZztian

    chrizZztian New Member

    No my console is black & white. :) Haven't done anything fancy. But since you mentioned fonts: The Log file contains a warning regarding fonts during startup:

    [0005.98] Warning: Warning, Failed to load 'SwfMovie GFX_Fonts.Fonts_EFIGS': Failed to find object 'SwfMovie GFX_Fonts.Fonts_EFIGS'

    Windows language (Win10 x64) is German.
     
  12. cheapscott_

    cheapscott_ New Member

    Hello,

    I've tried up to v1.1.1 so far, but none of the countdown, goals, etc. are being triggered on the keyboard. Launching is fine; I have the white breathing on startup and the blue/orange on the main menu, but no change in-game. Using a Blackwidow Chroma TE (Stealth) on Win10 x64 with latest Synapse installed. Any suggestions?
     
  13. heavenleetBisque926

    heavenleetBisque926 New Member

    Huh, I play with this constantly and had not realized no effects were playing. It appears Psyonix changed the log level with one of the latest patches and I can no longer detect events simply because they are not being logged. I am going to investigate but there's a decent chance this won't work for quite some time, possibly ever again.

    Edit: so I tinkered with the whole afternoon, at this point it is clear that in order to make RLCC work again, I have to figure out a different way to get events again. This is a very tough task, so for now I am afraid you have to consider RLCC broken and defect. I honestly don't know if I'll get back on it, the other way to figure out any events is basically reading RL's memory manually and finding specific values, which is difficult to say the least.
     
    Last edited: Oct 2, 2016
    MrAltamente likes this.
  14. MrAltamente

    MrAltamente New Member

    No Worries Manni :D
    Thanks for all the effort.
    Gotta say i love your work around RLCC.
     
  15. its not doing the countdown for me, just changes the colours. how can i fix that
     
  16. StrikeRaid

    StrikeRaid Member

    Try actually reading the posts...
     
  17. it says "Please note that so far I can only guarantee this works with the Blackwidow Chrom" so i wasnt sure if it worked just for blackwidows or nothing all together
     
  18. StrikeRaid

    StrikeRaid Member

    You were so close and yet so far... Read the whole thing next time.

    This is what it says:
    "This piece of software is currently defect, it does not work any more.
    In one of the latest patches, Psyonix apparently changed the log level, meaning I can't detect events anymore. At this time, I am investigating alternate means to do so but it is not looking good.

    Please note that so far I can only guarantee this works with the Blackwidow Chroma
    I don't know what happens when you try to use different models of chroma keyboard or have additional mice, etc. attached to your PC, since I don't own any of these devices.

    Current version: 1.1.1 as of 2016-10-01
    Broken, all previous versions are defect, too due to a change by Psyonix"
     
  19. BryanChung

    BryanChung New Member

    It's working for my Blackwidow Chroma. :D Can you also make the lights for Firefly and Mamba mouse? :D
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >