So far so stable Oculus Rift+Touch on Stealth+Core

Discussion in 'Systems' started by vitorious, Dec 28, 2016.

Thread Status:
Not open for further replies.
  1. vitorious

    vitorious New Member

    After some futzing, I think I have a stable setup of an Oculus Rift with Touch controllers on a Razer Blade Stealth (early 2016 [Skylake 6500U], QHD) with Razer Core. I've played for hours at a time and haven't experienced crashes yet.

    The Oculus Sensors seem to work fine hanging off a single USB 3.0 port on the Razer Blade Stealth through a USB 2.0 or 3.0 hub, along with the Xbox Wireless Adapter and an SSD, rather than through the USB ports on the Razer Core.

    Using the Razer Blade Stealth exclusively through an external monitor plugged into the video card in the Core, and disabling the laptop LCD, makes the Steam VR desktop view and Virtual Desktop work.

    Disabling Intel Turbo Boost seems to prevent overheating and a WHEA_UNCORRECTABLE_ERROR blue screen during long play sessions.

    Details here: http://vitor.io/razer-blade-stealth-core-oculus-rift-touch
     
    Razer|Jaisani_Choe likes this.
  2. henrideath

    henrideath New Member

    Thanks for that @vitorious I have had the exact same issues with oculus and the same GPU (a Gigabyte GTX1080). 2 questions for you:

    1) Have you tried to put your powered hub onto the core directly (to rule out a power issue)

    2) Have you thought about returning the unit to Razer (the core)?

    I think that the problem comes from TB3 sharing the bandwidth with USB but I'm not sure. And while I get disconnections or "poor tracking" issues as well, I cannot get the Core to recognize the rift at all (USB plugged in gives me a hdmi disconnected error)
     
  3. vitorious

    vitorious New Member

    I haven't. That's an interesting idea, although I wonder if putting a third hub in the chain wouldn't be just as bad (the Rift HMD is already its own hub). Something like this USB power injector might be something else to try. I'll reply when I try it.

    It hadn't occurred to me. Other USB devices seem to work fine, including my SSD. I don't appear to get random disconnects (e.g. 1, 2) or anything. No-one seems to be talking about the two Genesys Logic GL3522 USB chips in the Core as being specifically incompatible with the Cypress CYUSB3304 USB 3.0 hub in the Rift (although Genesys Logic chips seem to have had problems in the past, e.g. 1, 2), but no-one's talking about them being tested as compatible, either.

    Same, I describe that in my original May 2016 post. I have the Rift HDMI plugged into the GTX 1080, and the Rift USB plugged into the left-side USB port on the laptop. I haven't tried it on the hub. I'll reply when I experiment some more.

    I did some light testing, and I feel like it's a USB chipset compatibility and/or bus bandwidth issue, not an issue with my particular Core hardware. I feel like it's possible drivers or firmware upgrades for the chipsets in the Core could fix it. At least, I'm not convinced a different Core (RMA or otherwise) would work better/differently. Also, I haven't tried any extended gameplay yet, but I've generally seen failures at this stage, so I'm fairly sure this follows.

    Plugging in my Anker USB 3.0 hub into the Core, and the Sensors into the Anker, makes the Sensors flake out just as if they were plugged into the Core directly. Plugging the Rift into the Anker makes it be not recognized just as if it was plugged into the Core directly.

    Plugging the Hawking UH214 USB 2.0 hub into the Core, and the Sensors into the Hawking, and the Sensors show up seemingly stable as USB 2.0 devices, just as they did when that hub was plugged into the Stealth. (The Rift does not work on a USB 2.0 bus.)

    Plugging the Sensors into USB 2.0 extension cables, and then directly into the Core, also makes the Sensors show up seemingly stable as USB 2.0 devices.

    We know there's a single Intel USB host in the Stealth, and two Genesys Logic in the Core, and the ethernet port is a USB device internally. We know there's a Cypress USB host in the Rift HMD, and that the Rift doesn't like some USB chipsets (but not specifically whether or not it likes the chips in the Core). We know the Rift does like most Intel chipsets (like the one in the Stealth).

    Also, I don't think I see random disconnections or dropouts like others have reported, and the Xbox Wireless Adapter, my SSD, and the ethernet on the Core all seem/seemed to be stable.

    It could still be a power issue, but I think it's more likely something's up with the USB chipsets in the Core, and they're just incompatible with the Rift and Sensors right now. It sounds like this is a brand new chip and firmware ("GL3522 integrates Genesys Logic self-developed USB 3.1 Gen 1 Super Speed transmitter/receiver physical layer (PHY) and USB 2.0 High-Speed PHY") being used in the Core, and the Rift and Sensors didn't exist when they were building it. USB 2.0 is older, probably better tested, and probably runs as completely independent firmware from the 3.x firmware in the chip, so it's possible that's why the Sensors are fine when run in 2.0 mode.

    (There was this lone bit of speculation that "Fast back-to-back transaction" support was one of the things the Rift needs, and the Intel host in the Stealth supports that, but the chips in the Core don't. This is literally the only place suggesting that, though.)

    Because everything's going into the single Intel bus in the Stealth, it also probably doesn't matter so much where in the hierarchy everything is. There probably isn't a huge speed improvement to be had by plugging one device or another directly into the Stealth, versus into a hub or into the Core.

    Keeping devices off the Core allows for the maximum bandwidth to/from the video card, at least. I'm pretty okay with having all the Oculus hardware hanging off a USB hub off the Stealth.
     
    Last edited by a moderator: Apr 9, 2017
  4. Zorn_

    Zorn_ Active Member

    Really great info. I've been reading into this quite a bit myself since I just bought the Rift + Touch and also ordered a third sensor (although I have the Blade 14 and Core). Your findings seem to support what I have read, which is that with all the sensors plus the headset set to USB 3.0, the laptop is running into a bandwidth limitation on the USB bus. That's why you get stable results at USB 2.0 with the sensors. It's really a shame that the Core is so unstable and flaky with its' USB ports, as it really does make the perfect dock and would be great if the ports were usable. As it stands, the only thing I can plug into the Core without it freaking out is the Firefly.
     
  5. vitorious

    vitorious New Member

    So, how to test if it's a bandwidth/bus management issue? Get rid of other stuff on the bus.

    I removed my GTX 1080 from the Core. Plugging the Sensors into the empty Core, they seemed stable. (Of course, with a Stealth I can't playtest like this, but someone with a new Blade could.)

    I put my GTX 1080 back in, and disabled the onboard gigabit Ethernet. Plugging the Sensors into the Core, again they seemed stable.

    (The Rift refused to register on the Core regardless; I still think that's a USB compatibility issue.)

    @Zorn or @Tleej, if you feel like testing, try disabling the onboard Ethernet, see if the Sensors are stable when plugged into the Core then.

    @Zorn, you could try pulling your video card from the Core and playing just from the onboard video on the Blade, with the Sensors plugged into the Core, also.
     
    Last edited: Jan 8, 2017
  6. Cautier

    Cautier New Member

    The core just keeps impressing me, I'm glad I picked it up.
     
  7. Zorn_

    Zorn_ Active Member

    I have had the Ethernet on the Core disabled for some time as I had read early on that it helps it be more stable. I have since found out that any sensors cannot be plugged into the Core at all. Anytime even one sensor is plugged into the Core, tracking is very jittery and jumpy all over the place. Makes the Rift seem broken. When I plugged both sensors into the USB 3.0 hub built into my monitor, it's a night & day difference. I have a 3rd sensor on order, so I'm really curious if it will work running in USB 2.0 mode in the Core, or if I'll need to plug it in my laptop directly. It will run me completely out of USB ports if so.
     
  8. vitorious

    vitorious New Member

    Ugh, that's a shame, I was hoping the ethernet might be it. I hope you find USB 2.0 works.

    I bought a Startech ST3300GU3B USB 3.0 hub that has the same Genesys Logic GL3522 USB chip and same ASIX AX88179 USB 3.0 gigabit ethernet adapter as the Core. Plugged it into the Stealth, and then plugged the Rift HMD and Sensor into it, and both show up in the Oculus software, seemingly stable. (Again, haven't tried any extended use.)

    If it was a compatibility issue with the GL3522, I'd have expected it to flake out pretty quick. Guess it's probably not, and it's more likely to be the Core specifically.

    Also, I realized that USB power injector is not likely to help, as it'll be USB 2.0 also. I haven't seen a pre-made USB 3.0 power injector.

    Doesn't seem like it's a power issue for me. Came across this USB 3.0 power adapter y-cable and ordered it from NewEgg: https://www.apricorn.com/usb3-y-cable

    Plugged it into the Core, power from an Aukey USB desktop charger, but the Rift headset and Sensors both failed as usual.

    Seeing that other thread where some people have working USB ports is kind of a bummer, though, but I don't think anyone was talking about an Oculus Rift, at least.
     
    Last edited by a moderator: Apr 9, 2017
  9. henrideath

    henrideath New Member

    Hey all, sorry for the late reply.

    I got my Core replaced by Razer for another issue (loud fans). I can confirm that the problem remains. I think it has nothing to do with the graphic card or HDMI, but it is related to the USB problem that everybody is having. Not sure if it is TB3 related (lots of implementations of it are, to say the least, flakey) or if it's a bandwidth problem (most of the 40 gb/s used by the GPU not leaving enough the USB hub). Power doesn't seem to change a thing.

    I hope Razer is going to fix it (if they can and haven't put a crappy usb chipset in the box), otherwise the only solution is to plug everything on the blade itself which is quite annoying...

    That's all I have for now
     
  10. vitorious

    vitorious New Member

    Found some bright green silicone USB dust plugs and I guess I've solved the problem of what to do about my Core's USB ports :sweat_smile:

    [​IMG]
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >