Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

[Update] Razer Synapse and macOS Sierra

Discussion in 'General Discussion' started by Razer.WolfPack, Sep 7, 2016.

Thread Status:
Not open for further replies.
  1. I tested having two or more Keyboards attached BT or Wired and the problem of stuck CTRL KEY , only affects the RAZER.
    I got rid of my custom key maps for all the problems I was getting.

    I got a reply from Razer so give them all what they want.

     
  2. I hope Razer compensates you for your time spent! Lol. Don't they have a QA department that can do this? By the number of posters in this thread, these issues seem to be easily replicable.
     
  3. I got that exact same reply. I went through that process and ultimately it finished with this "Unfortunately we don't have a fix for your issue as of yet, however we have forwarded it to our development team, and will notify you if a fix is released in a future update. We are always looking to improve the functionality of our software, and your feedback helps." So annoying!
     
  4. Wengeinsiderfast671

    Wengeinsiderfast671 New Member

    Well, now the kext doesn't crash the system: woot! It's a start.

    But the constant double clicking(?), inability to select normal macOS objects - like panes in Mail - etc. makes this still a LONG way off usable.

    PLEASE spend/acquire the resources needed to make Razer products usable.

    While you're at it, get rid of that worse-than-useless Synapse always-on DRM (best case scenario): since the dawn of computing, we have not needed mouse drivers to live in the "cloud"; nothing has changed, except the extreme annoyance factor, and questions about true purpose/computer security.
     
    Last edited: Dec 18, 2016
  5. Well, we are all having the same issues.... I will add another:

    While using my Orochi 2013 in bluetooth mode, it changes the TRACKPAD sensitivity to very low.... yes the damn trackpad. I wrote to support (again) and they replied that I should reinstall synapse... giving me windows instructions :eek_::eek_::eek_::eek_:o_O

    Nonetheless, I go to my trackpad settings and of course the level is at normal position, if I move it then it works as expected.... TILL, I use the mouse again. In wired mode this happens once, and then after fixing the trackpad is stays good.

    Now I unloaded the Razer services and i was able to use the mouse in bluetooth mode properly... so definitely a Synapse issue. BUT, again but, when I reached home and connected my Mamba I couldn't adjust the sensitivity and was moving weird and the keyboard was not working properly.. so i had to load synapse again.

    FOR GOD SAKE PLEASE FIX YOUR SOFTWARE... this is borderline retarded! :mad_:
     
  6. Hadesgatee

    Hadesgatee Active Member

    Thank you for the release, my mouse is now finally working properly. my old 2009 razer mamba :)
     
  7. Most of the issues, aside for not being able to use the devices in a rudimentary and buggy manner, are still not resolved.

    Knowing it's new year's time I don't expect anything till maybe feb/march, BUT, I do hope your sales drop significantly because of how bad your support is for OSX.

    I know, most probably 1% of your sales are for mac systems (meaning you probably don't give a rat as it's costlier for you to support in relation to sales), but then do the honorable thing and just don't support it and don't make us buy devices that don't (or even worse WON'T) work.

    To aggravate things even further, your support keeps asking the same questions, they reply giving windows instructions and then your staff here that is not technical, waste my time testing my problem (and all the other people's problem) IN A WINDOWS MACHINE.

    Again, I do have 4 of your products, bought when Synapse was behind windows in functionality but still not giving the problems it's giving now. I also asked your support to give me a refund for the 3 products that don't work correctly since Sierra and I got no reply. Do you want me to stop nagging everyday? Then give me a refund from my Orochi 2013, Mamba TE and Blackwidow Ultimate 2016 and I'll happily return to a less conflicting relationship with my macbook and being able to play better using the money to buy other brands that actually work in MacOS.
     
    franctastic and NecroZek like this.
  8. steven.duh.13

    steven.duh.13 New Member

    Same thing happened on me. Orochi 2013 and 2016, both happened on wired and wireless mode. Since update to macOS 10.12.2 (from 10.12.1). Tired to keep uninstall and install..., Feel hopeless...

    Maybe the mouse problems is on Apple and beyond Razer can handle. If this is true. Apple have really bad support for 3rd party mouse. And we should turn this thread to bigger Apple related discussion board and make them hear the consumer's voice.
     
  9. Don't you think if there is the slightest chance it's Apple's fault, Razer would be issuing some official statement citing them? Also, Apple releases betas before the official announcement. There are no excuses really.
     
  10. mbob111

    mbob111 New Member

    Definitely not Apple's fault, since Synapse made my mouse and keyboard practically unusable I've uninstalled it and switched to USB Overdrive and Better Touch Tool for remapping keys and mapping applications to buttons and everything else I did with Synapse and it works perfectly. Had no issues at all with stuck keys or reverted mouseclicks or anything else. Downside of that is no LED control but there was really no other option.

    Also you just need to look at all the other Synapse issues like losing remappings randomly or not loading profiles at startup and the million other issues with it on MacOS to see how little effort they put into the Mac version of Synapse.
     
    Damiancito likes this.
  11. Can you be kind enough to provide a step by step? Like I have Synapse installed.. so from there how it goes? Now when I uninstall Synapse I lose the ability to change DPI and doesn't remember my previous settings. Like yesterday again my mouse started to do disconnects for a couple of seconds for no reason.. it's really tiring, specially when you are playing ranked.
     
  12. Well it's a 20 USD app.... Razer should 1) give us a voucher to get that app 2) contact the guy to do some programming and fix Synapse for once..

    GOD, I'm really annoyed.
     
  13. Well, I run the shareware version and i couldn't control the speed/acceleration in my Mamba TE. So I have to cope still with Synapse. Maybe with older mice works fine.
     
  14. ConstructorTrurl

    ConstructorTrurl New Member

    I've skimmed this thread and haven't see anyone mention this yet. A couple weeks back I updated to one of the new MacBook Pros with a touch bar. For the most part it has worked well with my Orbweaver and Naga Hex.

    However, I haven't been able to find any way to assign buttons that are now only available from the touch bar. For example, if I want to bind "escape" or any of the function keys to my Orbweaver, Synapse always detects them as if I had pressed "Left Control + Left Shift".

    Is there any way to configure a specific keypress in Synapse without having to actually press the key? I've filed a ticket with Razer support about the problem, but I figured I'd check to see if anyone knew about a workaround in the meantime.
     
    skchurch likes this.
  15. xPearfirst218

    xPearfirst218 New Member

    Just installed Razer Synapse on a brand new system and it won't even start. Damm. A Naga is pretty worthless without the software. And only reading the first and last page here depresses me. Is there any hope at all?
     
  16. No hope at all... new symptom today. Put the computer to sleep, went back from dinner, I couldn't input from the keyboard. A few strokes and froze the input... I had to open the activity monitor (sans keyboard), look for the razer process and force quit it.. after that now my keyboard opens again. A good 5 minutes of my life lost again with this stupid software..... today in the office every time I woke up the computer of after the screen saver was on, my trackpad sensitivity went to to the bottom automatically. I wish your company cease to exist Razer.... you are that bad.
     
  17. Random3

    Random3 New Member

    I am having problems with macros registering modifiers (cmd, shift, ctrl) as being constantly pressed. Tried everything I can, doesn't work. I am running Yosemite. Will updating to Sierra make any difference?
     
  18. Nope. I have the exact same problem as you, except the opposite. No matter which modifier I hold, it is being registered as if I'm holding down nothing
     
  19. Random3

    Random3 New Member

    Christ... I bought an Orbweaver for Christmas with the intention of using it for music production and gaming. If I can't remap any of the keys or make macros, it is about as useful as half of a keyboard.
     
  20. Random3

    Random3 New Member

    Had a response from the support guys after submitting a detailed explanation, they requested some system info from my Mac which I have now sent. Fingers crossed...
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >