Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

zSilver

Discussion in 'Razer Cortex' started by sukuswarrior, Mar 26, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. sukuswarrior

    sukuswarrior New Member

    Everytime i end my game it says zSilver earned. Later i see it says 0 earned playing this game and i see i havent gotten zSilver. What do i do?
     
  2. Eiolei

    Eiolei Active Member

  3. Mozartino

    Mozartino New Member

    Had same problem yesterday, I solved it by logging out of cortex, restarting pc, then logging back in.
     
  4. Bees_ZA

    Bees_ZA New Member

    Are you maybe playing the wrong game?
     
  5. RZ2000

    RZ2000 Active Member

    Make sure it's a compatible game, then make sure your balance is actually correct! Then try restating client
     
  6. sukuswarrior

    sukuswarrior New Member

    I am playing Dota :stuck_out_tongue_winking_eye:
     
  7. Sim3Gamer

    Sim3Gamer Well-Known Member

    Then just reinstall Cortex like one of the Members already told above and give us an update if it worked ;)
     
  8. sukuswarrior

    sukuswarrior New Member

    OK, will try

    Still 0 zSilver earned.....
     
    Last edited by a moderator: Mar 30, 2017
  9. Rav3nous1337

    Rav3nous1337 New Member

    Did you open the game through the Cortex application? If not, you won't earn zSilver.
     
  10. sukuswarrior

    sukuswarrior New Member

    Reinstalled, Started game from Cortex (CS:GO) and still no zSilver earned...
     
  11. swiftwilly1986

    swiftwilly1986 New Member

    not buggy for me but slow, when i am in rewards section it hardly ever loads.
     
    Chessiepup likes this.
  12. JohnsonYap

    JohnsonYap Member

    Hi,

    I'm currently facing keep "loading" screen in REWARDS tab after that blank white page, I cannot claim it at all. I have tried reinstall the cortex it's still same.

    anyone help? I don't want miss my daily reward just because of this bug.

    Update:
    OK, now it is showing "Reward Notification" and I'm was clicking the zSilver logo to claim it but it was spinning over and over again like never stop.

    Update:
    It seen to be OK already because after sitting here and doing own stuff almost nearly 12am, the Reward system in Razer Cortex are working perfectly as same as before. This is wired.
     
    Last edited: Apr 1, 2017
  13. Djoezzy

    Djoezzy New Member

    Yea having the same issue. Screen now popped up but now it is stuck on loading my claim.
    Also did not get any reward for the time I played overwatch.
     
  14. sukuswarrior

    sukuswarrior New Member

    I don't understand, why zSilver system is broken for me. I can claim daily rewards fine from Cortex and Arena but games earn me 0 zSilver

    Rewards in Cortex not working for me either
     
    Last edited by a moderator: Apr 1, 2017
  15. .Surf.

    .Surf. Well-Known Member VANGUARD

    You don't have to open the game via cortex in order to lunch the zSilver paid to play, i'm always starting Overwatch by Battle.net and the paid and play shoud start on it's own it dosen't matter where you open it from.

    I have the same issue with the time played on cortex after i'm done it tells me that i have 0 zSilver gained, but if i check the transaction history on the site i see that my ammount is added.
     
    Last edited by a moderator: Apr 1, 2017
    JohnsonYap likes this.
  16. PlatinumC

    PlatinumC Active Member

    It will probably fixed soon again, just be patient.
     
  17. sukuswarrior

    sukuswarrior New Member

    Doesnt even show in transactions for me :stuck_out_tongue_winking_eye:
     
  18. .Surf.

    .Surf. Well-Known Member VANGUARD

    Shoud be working now. Check again the paid to play is working along with the daily streak and the arena too. Just completed mine. If not try to log out and sign in again or reinstall the cortex shoud do the trick. Good luck!
     
  19. JohnsonYap

    JohnsonYap Member

    In this morning, I get a message from Razer Support he call me to fully reinstall the Cortex and restart the laptop. Now the Razer Cortex are working perfectly.
     
  20. .Surf.

    .Surf. Well-Known Member VANGUARD

    Anyone succeded in claiming the today's coins?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >