Black screen on booting Kali Linux via USB

Discussion in 'The Linux Corner' started by Jithvan, Sep 25, 2017.

Thread Status:
Not open for further replies.
  1. Jithvan

    Jithvan New Member

    Hi, so I've been using Kali Linux on a bootable USB. It works on all machines except my new Razer Blade Pro 4K 2017 Model.

    Secure boot is turned off, I select the pendrive and I run the persistence mode, after which I get a black display.
    Initially I thought this was because the RBP has only one dedicated GPU and no Intel GPU. So I updated the distro and installed the Nvidia Toolkit using another machine and tried again with no success.

    For some reason running it on live works, and the first time I ran it with persistence to unify my partitions.
     
  2. In my adventures trying to get Kali working on various boxes, I've had luck with using nomodeset kernel option (and one time setting the available ram, but I don't recall that one very well)

    Like this https://community.linuxmint.com/tutorial/view/842

    May help
     
  3. KazWolfe_

    KazWolfe_ New Member

    Serious question: why are you using Kali?

    It's not exactly an operating system meant for your average Linux user, and is definitely not meant to be used outside of actual professional security testing.

    That said, it's rather unsurprising that this doesn't work too well on the Blade. I haven't experimented with it on my own Blade yet (no reason to), but this definitely does sound like an nvidia driver issue. As the post above me has stated, try running with nomodeset. However, i'd also recommend you try to jump to the bleeding edge where there may be better drivers (or just not use Kali at all - most hacking tools that Kali has can be installed on any distro).
     
  4. mefb90

    mefb90 New Member

    I got kali running on my stealth and even got it working with the razer core v1 but I don't remember where I found the instructions for it. PM me and I will look for them. You are still going to need to get a wifi card capable of injection for any wifi shenanigans you have planned
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >