Core V2/GTX 1080/UWQHD Monitor over HDMI

Discussion in 'Systems' started by JustAnotherJay, Jul 21, 2018.

Thread Status:
Not open for further replies.
  1. JustAnotherJay

    JustAnotherJay New Member

    I would assume that the NVIDIA GeForce GTX 1080 would connect to my UWQHD monitor over HDMI, however I can't get it to work that way. When I plug the monitor into the Core V2/1080, I get no signal. When I plug the HDMI cable into the HDMI port on my Blade Stealth laptop, I get a signal to my monitor... any ideas? I don't have a DisplayPort cable to try on the monitor/Core V2. I've tried all three HDMI ports on my monitor as well - they all work with the Stealth but not with the 1080/Core V2. I'm assuming I'd get better video throughput direct from the Core V2 as opposed to routing through the TB3 port and then HDMI to the monitor.
     
  2. Jenjar

    Jenjar Well-Known Member VANGUARD

    I think you need to hook up the Core 2 with Thunderbolt 3 to the stealth and then hook up the monitor using the HDMI port on the Blade Stealth, don't think it works plugging the HDMI into the 1080 to a monitor.
     
  3. JustAnotherJay

    JustAnotherJay New Member

    Yup that's how I have it set up now. Odd though... you'd think you could use the HDMI port on the 1080.
     
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    Try plug and unplug the hdmi cable on core, I had similar issue, if I’m not wrong it was when using new card or installing new Nvidia driver on my core v2, don’t quite remember. Yes by using hdmi on stealth data looping from core to host (Blade) will reduce the performance, but since stealth has PCIe3x4 lanes it won’t be huge, but still it should work actually directly from core to monitor and get better experience on this setting.
     
  5. JustAnotherJay

    JustAnotherJay New Member

    Tried that, will try again - but just to confirm you have HDMI working from the Core V2 directly to the monitor?
     
  6. Joikansai

    Joikansai Well-Known Member VANGUARD

    Yes, I’m always using so on my old Blade 14 to play 4K games and that’s how the setting should be. Though on stealth I play often without external monitor since it feels cool;)
     
  7. JustAnotherJay

    JustAnotherJay New Member

    Yah tried that no go, even tried a different HDMI cable. Oh well... have a couple other monitors I can try on Monday.
     
  8. JustAnotherJay

    JustAnotherJay New Member

    Got it fixed, for some reason the 1080 was disabled under displays in the Windows device settings tab. Enabled it and bam, it works. Weird though... noticed something was amiss because the NVIDIA GPU Activity app wasn't showing in the Windows taskbar and Heroes wouldn't let me go above High settings.
     
    Joikansai likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >