Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

(FIXED)Synapse 2.0 wont even LAUNCH(win10)

Discussion in 'Razer Synapse' started by TheRussianMafia, Dec 2, 2017.

Thread Status:
Not open for further replies.
  1. TheRussianMafia

    TheRussianMafia New Member

    Hello everyone...

    I have just received my Razer Ornata Chroma Keyboard and I absolutely love it. The problem is that I can't use all of the wonderful lights and Chroma features because I'm having major issues with the software. I have installed the Synapse 2.0 software on my pc running Windows 10 Pro. The installation went just fine except it didn't prompt me to restart my computer to finish the installation as it should have. Instead, it just told me to click "finish" and that's it. The software itself when clicked does absolutely nothing. Just the mouse with the loading circle for a few seconds and that's it. No error, no sign that its opened in task manager, absolutely nothing. I think I have tried every solution their is to this problem and went through Razer's chat support 3 times with no luck.

    Methods I tried (or at least the ones I remember)

    • running application as admin
    • running application with the compatibility of Win7/vista from properties
    • reinstalling application
    • rebooting pc
    • reinstalling all drivers
    • installing older version of application
    • going through with installation and then rebooting manually(since I didn't get a window to do it)
    • deleting all hidden folders from Razer on C: drive, reinstalling all drivers, rebooting, and reinstalling application
    • updating everything in windows settings
    • unplugging the keyboard itself and plugging in to different ports
    • blocking Windows defender, firewall, and listing Synapse as exclude from windows defender list
    • and more I cant remember...

    All of these methods I tried and with some, more than once. I don't know if its my system or Razer servers are having a bad day today... (if that even makes sense?) I have tried to find a solution for about 3 hours today, I'll try tomorrow and will keep updated. Any help is much appreciated and I mean ANY!!!


    P.S.

    If anyone needs any screenshots just tell me.
     
  2. FiszPL

    FiszPL Well-Known Member

    I'd contact Razer Support, and describe precisely your problem - they'll help you. And before this I'd download C#, C++ Redistributables and install it in system.
     
    DestaKhoo likes this.
  3. TheRussianMafia

    TheRussianMafia New Member

    Hey, thanks for the reply. Still no luck even with installing C++. Also this was my 4th time contacting Razer Support with no luck. I'm reinstalling windows atm. Will keep updated to see it that will work. so people can know what to do if they have the same problem like me...

    ITS FIXED!!!

    Probably deleted something in the system directory when I was trying to remove virusesfrom a couple years ago or who knows from how long...

    FIX:
    Just reinstall windows... Took me about 50 minutes, it's that simple. I used this video to help me out. Also your files and applications will be 100% saved(if you choose to)


    After that, the application is running flawlessly. Also any problems that you have on windows (any applications not starting/viruses) it can be fixed with this method too, so your basically killing 2 birds with one stone.

    If your someone like me who had this problem I really recommend this option. Good luck
     
    Last edited by a moderator: Jan 4, 2018
  4. MyNameIsToni

    MyNameIsToni Active Member

    these freaking hacker trolls.... holy f*ck what trash this world is full of
     
    Last edited: Dec 29, 2017
  5. dedreiix

    dedreiix Member

    Seriously reinstalling Windows for fixing such an issue?!

    Absolutely not acceptable. Razer should improve the reability of their software.
     
  6. FiszPL

    FiszPL Well-Known Member

    In most cases it's windows fault, not 3rd party software. Dunno why I had more strange problems with W10, than Windows 7.
    Few days ago I had to reinstall / clean install windows 10 on my laptop, because some OS functions were not working OK... so it's a lottery.
     
    H00dy likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >