Frame Rate Discrepancies. Razer Blade Stealth + Core

Discussion in 'Systems' started by bartikus_, Oct 20, 2016.

?

Do you experience lower frame rates on a lower resolution external monitor versus the UHD display?

  1. Yes, significantly lower

    100.0%
  2. Yes, slightly lower

    0 vote(s)
    0.0%
  3. No, and they are about the same

    0 vote(s)
    0.0%
  4. No, and the external monitor is higher when plugged into the core directly

    0 vote(s)
    0.0%
Thread Status:
Not open for further replies.
  1. Hey all. I've tried searching for related topics, but nothing quite fits what I'm observing.

    I recently (a month ago) got a Razer Blade Stealth (not the new RBS) and a Core. I have an EVGA Superclocked GTX 1080 in my Core and overall I am pretty happy about it.

    However, I noticed some discrepancies in frame rate when using an external monitor versus the RBS display.

    The first few weeks, I just used the RBS display (3840x2160) with Paragon and Fraps running. For the purpose of this test, I set Paragon's settings to 1920x1080, fullscreen, all settings maxed. I used my mouse plugged into the side USB port of the RBS, and used the RBS keyboard. My game ran at 100+ fps, never dropping down to lower than 80.

    Then I set up my 1080p external monitor, because I was tired of using the tiny RBS display, despite how great it looks. I kept everything the same in the in game settings, but attached a USB hub to the RBS to plug in my mouse and keyboard, as I then had my RBS off to the side. I didn't have Fraps running, and the lower framerate was very noticeable, so I ran Fraps again, and was averaging 55 fps, with frame rates as low as 30. I also had in display settings selected the external monitor as my primary monitor, and "Display only on this monitor" which I assumed would result in the GPU only needing to render output for the external monitor, and not both displays. Am I wrong in assuming this?

    I had read threads on this forum that explained that the external monitor should be plugged in to the Core directly, which is what I did. I don't think that with a GTX 1080, with only one 1080p display attached, that I should be getting the frame rates I am, especially when I have used the same card with the higher resolution display of the RBS and gotten more than double the frame rate.

    Am I missing something here, or can anyone confirm they see this issue too?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >