Help with Razor Naga

Discussion in 'Mice and Surfaces' started by LittleMissGeek, Mar 25, 2016.

Thread Status:
Not open for further replies.
  1. I've had this mouse for a few years. Haven't used it because there's something wrong with the usb and it won't go into the port. So when you pick it up, face it toward you it has this extra slot thing which is there. I'm not sure if that's normal, I also have no idea how to explain it. Heres pics.
    Razer mouse:
    webcam-toy-photo45.jpg
    Another mouse:
    webcam-toy-photo47.jpg

    Clear difference. The other mouse is able to slide in the usb port while the razer one can't. Can I fix this?
     
  2. JonasuofBleach

    JonasuofBleach New Member

    Well the pic of the naga USB looks the same as mine, so i don't think there should be any problems with it. What you can try is to put it into another USB port. Mine didn't fit in one so i tried in in the other and it worked. Not sure if this can solve your problem but i hope it helps
     
  3. Blockmonster57

    Blockmonster57 Active Member

    You're using an OLD mouse it has an USB 2.0 port xD
     
    JonasuofBleach likes this.
  4. Blockmonster57

    Blockmonster57 Active Member

    I think you can use some cable to convert the old USBs to new ones
     
  5. Horace_no_id

    Horace_no_id New Member

    i think the plastic from a usb port snapped and got stuck in your cable's usb, try getting it out with a tooth pick
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >