Is Synapse Really This Bad?

Discussion in 'General Discussion' started by Misuteri, May 28, 2016.

Thread Status:
Not open for further replies.
  1. Misuteri

    Misuteri New Member

    I just purchased a Death Adder Chroma and Blackwidow Chroma keyboard and the hardware itself, seems to be incredible.

    However I'm running into consistent, I mean every 5-10 minutes consistent, stoppage of the mouse working and/or the right click button sticking and never letting its actions go unless there's a default in game action that stops it (Clicking an in game object as an example.) the keyboard has also stuck on a button action repeating, repeating, repeating etc.

    I don't have this issue in normal use. I can sit and type for hours, no issue, I can surf the web, write comments etc. no issue.

    However I play a game and both pieces of hardware just do stupid, stupid stuff again, and again, and again.

    The funniest part is that I've had to physically unplug the mouse to stop it doing what it's doing and when it's plugged back in it tells me I'm using a Call of Duty Chroma. Um, no, no I am not. I've unplugged it other times rinse/repeat because of same issues and it now tells me I have a Call of Duty mouse and the Chroma running at the same time. Lastly, it's also told me that I have no mouse and only a Blackwidow keyboard.

    Oh and last but not least, the FN+0-9? None of the buttons are shortcutting to software programs selected.

    This is just brilliant software writing.

    I called customer service told them exactly what I've posted here. Their answer, well, it could likely be your account. As in my log in account. Now, um, how can that be?

    I love this product from a design, feel and looks standpoint but what good is it if the reason I purchased it for, playing games, is garbage compared to the $20 Microsoft laser mouse and OEM Dell keyboard they've replaced?
     
  2. RoastierThanToastier

    RoastierThanToastier Active Member

    I found that with the new synapse update it did that a lot with my deathadder. I just reinstalled synapse at a lower version and it worked fine for me
     
  3. Misuteri

    Misuteri New Member

    Where can I find a lower version?
     
  4. RoastierThanToastier

    RoastierThanToastier Active Member

    I just installed it off the Razer site and it gave me a version lower than the current one that was glitching
     
  5. Misuteri

    Misuteri New Member

    Customer service had me uninstall absolutely everything Razer related. I did a "clean" install and after an hour, limited time I know, I encountered no in game issues that I listed.

    What perplexes me is that this software was 100% new as of Thursday (I had no Razer products prior.) and by Saturday it seemingly corrupted to the point I had to re-install everything. I've never had that problem before with any vendor.

    The FN-0 through FN-9 shortcuts are still not launching/activating programs assigned to them.

    Also, Chroma apps (KeyboardVisualizerVC 1.16) which are most current of this writing and available for download from Razer's site are not showing up in Synapse. I'm having to launch and manage from standalone/desktop shortcuts. The software works, Synapse just doesn't know they exist.
     
    Last edited: May 28, 2016
  6. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Hey @Misuteri ,

    Sorry you had trouble using our software but glad that it's working now. Let me know if you encounter the same issue again. Seems like it was a weird glitch in the matrix.

    As for the FN0-9 shortcuts. Those are meant to manually switch between your keyboard profiles.

    The game/application that you have linked under "Linked Programs" is not supposed to launch when you press the shortcut. What "linked program" means is that when you run this program, the associated profile will be activated automatically (and then revert back to original when you close the program).

    As a sidenote, you can use the "Launch Program" option under Key Assignments to launch programs with a single keypress.

    Regards,
    Razer|The_Fiend
     
    Last edited: May 28, 2016
  7. wiking19950309

    wiking19950309 Active Member

    A good advice: when you buy a Razer product, not just plug in and us it, but download the newest Synapse 2.0 update for it and then plug out and in to update the driver on it by the newest Synapse. The cause of this trouble is usually the fact that some f the Razer pages haven't update their data after each patch and it messes up the whole system.
     
  8. Psyjin

    Psyjin Well-Known Member

    As The_Fiend mentioned above, you want to use 'Launch Program' instead of 'Link Program' for your specific purpose if you aren't already doing so. In addition, it's a bit weird but you cannot customize FN + 0-9 for your own purposes because they are already assigned as shortcuts for switching between profiles. To be clear, multi-key combination macros are not possible in Razer Synapse. For example, you cannot make FN + [Key] or Shift + [Key] perform some other action. Vice versa, however, is possible - you may assign a single key to perform multiple actions.

    Ikr, I would be insulted too.
     
    VikasG likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >