Keyboard Not in Synapse

Discussion in 'Keyboards' started by kajira, Nov 26, 2014.

Thread Status:
Not open for further replies.
  1. kajira

    kajira Mother of Gaming

    Hey folks!

    I got treasures in the mail today! My new Vespula mouse pad and my Blackwidow Chroma Stealth showed up, so I'm trilled - happy early thanksgiving to me! :D

    However, I'm having an issue -- the new keyboard isn't showing up in Synapse along with my headset and mouse. Now, when I right click on the Synapse icon in my task bar it's listed there, and tells me I'm currently using the default profile, but when I click "open Synapse" it's not along the bottom list for me to open up the configurations. :confused:

    Anyone experience this, know where to find the configurations or have any ideas on how to help out?

    Thanks!!
     
  2. Jp720

    Jp720 Active Member

    Not sure as of now but will do a bit a research to see if I can be of any help.
     
  3. Jp720

    Jp720 Active Member

    How many devices do you currently have plugged in?
    edit: Razer devices
     
  4. Dbroome81

    Dbroome81 Active Member

    Stupid question but I will throw it out there anyway... have you restarted your computer since you installed the keyboard?
     
    ph4n10m likes this.
  5. SuP3rM4nNy

    SuP3rM4nNy Active Member

    That typical "have you tried turning it on and off?"

    but maybe your answer is somewhere here?
    http://www.razersupport.com/software/synapse/
     
    ph4n10m likes this.
  6. SuP3rM4nNy

    SuP3rM4nNy Active Member

  7. Dbroome81

    Dbroome81 Active Member

    Or, we can always go with the answer i learned while flying helicopters in the Army.... hit it with something hard a couple times...that works alot.
     
    Destrok likes this.
  8. Jp720

    Jp720 Active Member

    I feel like I'm giving the infamous "restart your computer suggestion", lol. Anyways, to the point, have you re-installed synapse and/or checked for firmware updates?
     
  9. Jp720

    Jp720 Active Member

    Just realized you said chroma... brand new... probably no new firmware... oops.
     
  10. TugboatSpenny

    TugboatSpenny Active Member

    a502a7c1b68aa28b8deb8f71bbbe0d25dc910f1f871b66a4e7f544840539c8a9 copy.jpg oooooo
     
    Destrok likes this.
  11. kajira

    kajira Mother of Gaming

    I should only have three items in my Synapse list (mouse, keyboard & Surround Pro). Earlier today my Blackwidow Stealth that I replaced showed up there just fine, just when I moved over to the Chroma version it wasn't there.

    I did uninstall Synapse and reinstall, I also rebooted the whole PC. (I actually installed with the PC shut off and then restarted yet again after it first didn't show up)

    And like I initially said: It's *almost* there -- because if I right click the Synapse icon it IS in that list and says I'm using the "default profile" for it (and clicking on that does nothing, it just gives me an arrow to change profiles- IF I could make any others to change to. lol) ... it's just when I actually open Synapse where I should be able to make configuration change that it's no longer displayed.

    I'll keep poking around Razer support as well.
     
  12. number12

    number12 Active Member

    Whenever I plugged in new razer gear (last was my orbweaver and naga epic) it would download a new update automatically then it would show them after I restarted my pc. See if you can download a new update.
     
  13. kajira

    kajira Mother of Gaming

    I went to the "settings" button on Synapse and checked for updates and it told me my software was entirely up to date - I also went to the Support section on the www.razerzone.com website and tried to download updates for my specific device, and installed those.

    I even turned off my PC again and unplugged it then plugged it back in again in different USB ports (all 4 of mine are USB 3.0) and still no change. It's in the right click on the icon list, but not in the main window of Synapse where I should be able to click on the picture to configure it. I'm out of ideas unless a Razer person response. lol

    Oh, and the colors are cycling on the keyboard constantly, so it's working, per se ... I'd just like to actually control them LOL :stuck_out_tongue_winking_eye: :D
     
  14. number12

    number12 Active Member

    What OS and does it show it in the Device and Printer section in Control Panel?
     
  15. kajira

    kajira Mother of Gaming

    Windows 7 Home Premium 64 - I just haven't bothered upgrading it yet.

    Yes, it does show the "Devices and Printers" in control panel, and when I bring it up it lists my Monitor, my PC, Razer BlackWidow Chroma and Razer Naga 2014
    (and then below that all my printer, fax, etc stuff)
     
  16. NazgulStig

    NazgulStig Well-Known Member

    Tried unplugging it and plugging it back again while the system is on? similar issue used to happen with my Lycosa(not getting detected in synapse issue) and I use to fix it like this and just restarting did not help.
     
  17. kajira

    kajira Mother of Gaming

    I just gave that a shot -- and while it re-ordered the Surround Pro and my Naga across the bottom, it didn't change.

    However, I did get a Windows message telling me that my device was installed correctly and could now be used. And it's still listed correctly when I right click the Synapse icon in the task bar, just not there when I actually open the program. So it's halfway found. :D
     
  18. NazgulStig

    NazgulStig Well-Known Member

    What if the keyboard is shy? :stuck_out_tongue_winking_eye:
    You don't have USB 2.0?
     
  19. kajira

    kajira Mother of Gaming

    Not that I noticed ... There's at least 4 USB 3.0 in the back, I didn't notice there being any others, but I can check again.

    And it would seem my keyboard is definitely shy. It doesn't want to be seen by Synapse. :stuck_out_tongue_winking_eye:
     
  20. NazgulStig

    NazgulStig Well-Known Member

    There has to be USB 2.0 because most(almost all) mobos have both 3.0 and 2.0 in the back. If you find 2.0 then try it else, Go to device manager and uninstall the keyboard driver(make sure you select "delete the driver for this device" option) and then remove synapse and all associated stuffs from control panel, restart and then install synapse again
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >