Massive Product Registration Bug in Razer Synapse

Discussion in 'General Discussion' started by Tzolkat, Nov 4, 2016.

Thread Status:
Not open for further replies.
  1. Tzolkat

    Tzolkat New Member

    I just got my Blade (1060) this past Wednesday and upon turning it on, let it download the latest version of synapse. I attempted to register the device via synapse today, and noticed something strange.

    Input format: <day> <month> <year>
    Initial validation format: <day> <month> <year>
    Parsed upon registration as: <month> <day> <year>

    So, for instance, the date 11/2/16 gets sent to Razer's database as 2/11/16. I've tried all sorts of input and it always switches the month and day during registration (which messes up the estimated date for warranty expiration and probably some other things), but taking this in mind before attempting to register (entering 11 February 2016 to get 2 November 2016) also won't work because it validates the date against the format given in the UI before moving to the next step.

    I wonder, has anyone else noticed this happening? It seems to be a pretty narrow date range that is able to make it past the validation on both screens, so some might not even be able to register with synapse, while others will get the result I did, with a date of purchase several months before the date entered, skewing the warranty expiration.
     
  2. PT.Singer

    PT.Singer Jedi Master VANGUARD

    I hope you passed this bug on to Razer using the gear icon in the top right corner. If it's a new bug, or one that hasn't been noticed before, they will appreciate you bringing it to their attention.
     
  3. Tzolkat

    Tzolkat New Member

    Yes, I already contacted Razer via email and via the software about this bug. I thought it might be useful to people who, like me, are trying to register their new gear and running into problems. Plus, there is no character limit here, so I can better describe the different input tests I tried to make sure the bug was reproducible.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >