Must reset Razer Leviathan to get proper sound

Discussion in 'Audio' started by MartijnS, Jan 14, 2016.

Thread Status:
Not open for further replies.
  1. Hey guys,

    I've had the Razer leviathan for a while now and i keep having to reset the sound bar to get a good sound out of it. There is a notible difference in the before/after. I do not change the volume or basslevels so that is not the issue. Could this be due to a hardware fault or is this software related?

    The sound bar also makes a squeling sound from time to time. Ive contacted the support on the site but their tips did not make any difference what so ever. When i requested a new soundbar they directed me to where i bought the soundbar ( I did it on the official website ) and after that i did not get a response.

    So maybe someone has experience with my issues or knows a possible solution?

    Thnx !
     
  2. milkbottlec

    milkbottlec Active Member

    Squeling sound, do you mean when there is no music through the soundbar? I have some of this issue too.

    Haven't try reset the soundbar yet. How big difference do you see when doing the reset?
     
    MartijnS likes this.
  3. The sound is alot richer once i reset the soundbar. The squeeling does not stop however when resetting.
     
  4. ShamX0

    ShamX0 Active Member

    Hmm i have a leviathan and have no squealing sound you mention. Ok lets see, what you're plugged in to? have you tried any other device? im on optical for pc and bluetooth on mobile and all works fine. if 3.5mm try plugging to your phone sometimes motherboard input makes wierd noises.
     
    MartijnS likes this.
  5. The sound is audible when connected trough bluetooth and 3.5mm. Also, if i mute the sound bar, the squealing doesnt stop. The squaling is not always present though.
     
  6. Peratun

    Peratun New Member

    I've just recently returned mine because of the squealing and just made a thread about it because until Exzeros reply just now I haven't seen anyone denying the squealing problem. So I'm hoping it's just a problem with some units and not something all units have to some extent.

    It squealing no matter what input method was selected or plugged in, even with just the power cord. I even bought some ferrite beads which didn't do anything.

    Here is a post with an audio file of the squealing, mine sounded exactly like that.
    https://www.reddit.com/r/razer/comments/2w3ztu/support_does_your_leviathan_squeal_too/
     
  7. How did you manage to get it returned? Just contact the official razer support? What did you do next? i've never had to send anything back i bought online before.
     
  8. ShamX0

    ShamX0 Active Member

    from experience i had a motherboard with the audio output(3.5mm) that makes wierd noises thru speaker, like when you move your mouse etc. for audio hardware my 1st tiamat 7.1 had an annoying screeching noise no matter what i plugged in.
    All i can think of is use a different power outlet by itself, plug to your phone with nothing attached so you got no interference. still squealing maybe driver busted like my tiamat as i went back to support center, and the sound was much worse lol.
    Where you got yours from. if its from razer store contact them thru support they will give you an address to send the speaker. if its from whatever else online store gotta contact them instead.
     
  9. The sound still emits when the bar is not connected to the PC, but to my phone. I've just contacted the razer support site to return it.
     
  10. Peratun

    Peratun New Member

    I've ended up sending it back to my local online shop which gave me a refund. Depends on where you bought if from I guess, authorized resellers should offer that if you bought it less than 30 days ago. Otherwise write to razer support and they ask you to fill out some stuff to return it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >