Problem with Micro SD Why ?

Discussion in 'Razer Support' started by LouisMcShellby, Feb 4, 2018.

Thread Status:
Not open for further replies.
  1. LouisMcShellby

    LouisMcShellby New Member

    Hi guys ;). I have a problem with my MicroSD in Razer Phone or with Razer phone. I try everything solution or different card and still the same. MicroSD is Corrupted but only then when i choose second option "Internal Storage" Whats wrong ? Orange Wave 256GB class 10.

    Screenshot_20180204-203434.png
     
    Last edited: Feb 4, 2018
    pancholr likes this.
  2. ZiCott

    ZiCott Member

    not too sure, i have my Sandisk 200GB set as internal without any issues. Is there some hidden partition from your previous device this card was in? Insert into windows, and see what the disk manager shows.
     
    LouisMcShellby likes this.
  3. godashram

    godashram Active Member

    well, since it's corrupted, if wouldn't hurt to use diskpart in windows to clear it up and try again. I used it quite often lately to wipe sd cards used with raspberry pis lately.

    from cmd prompt type diskpart
    list disk
    select disk (# of your sd card, boot drive is usually 1, etc)
    clean
    create partition primary
    format fs=fat32 quick
    active
    exit (or quit)

    if it still corrupts, wipe again and look up testing to see if your sd card is genuine.
     
    LouisMcShellby likes this.
  4. LouisMcShellby

    LouisMcShellby New Member

    I think that this card is just too slow and phone can't connect card with internal storage which is much more faster than micro SD.
     
  5. godashram

    godashram Active Member

    if that were the case, it would tell you when you set it as internal (well, it did for me)
     
  6. SivaasPlays

    SivaasPlays New Member

    also they said its a class 10, I may be wrong but I don't think there is anything above 10.

    I had similar problems with mine at first also, I had to flash the sd card several times as well as rest the phone but it eventually worked. I'm not sure what the problem was but it worked itself out eventually.
     
  7. Same issue here, I've inserted 3 separate sd cards which have data on them already and razer phone notes as corrupted and only option is to format to use so I know it's the phone not the card with the problem as these sd cards work on all other phones I have used in the past

    Any solutions guys?
     
  8. suhail

    suhail New Member

    Razer Phone supports only FAT32 file system for sd card which is why you are getting as sd card is corrupted since most of the cards will be formatted in exFAT. The downside of a FAT32 file system is the 4gb file transfer limit. Lets hope Razer adds more file system support in Oreo
     
  9. Thanks for clarifying my issue mate now it makes sense, I also hope they allow for other formats
     
  10. HomerDoh

    HomerDoh Active Member

    the speed is not ONLY classified by the class - you also need to look at UHS speed.
     
  11. Razer.Winteryang

    Razer.Winteryang Ice Bear Staff Member

    Hey @LouisMcShellby! Still need help with this problem with your Razer Phone? Please check your inbox as I've sent you a message.

    *Moving this to the support board for visibility. :relaxed:
     
  12. rebster60

    rebster60 New Member

    I to am having the same problem 128gb card formatted to fat32
    But only works as portable storage and I want it as internal storage .
    Please help
     
  13. Razer.Winteryang

    Razer.Winteryang Ice Bear Staff Member

    Let me help you. I sent you a message please check your inbox. :smile_:
     
  14. ODragunov

    ODragunov New Member

    is the razer phone UHS-III compatiable or UHS-II or UHS-I? can't find any information on that help me please
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >