Razer 15 advanced crashes when trying to suspend

Discussion in 'The Linux Corner' started by lesmis24601, Jan 20, 2022.

Thread Status:
Not open for further replies.
  1. lesmis24601

    lesmis24601 New Member

    I recently purchased Razer Blade 15 Advanced Model - (OLED 4K Touch 60Hz - GeForce RTX 3080) and installed Ubuntu 21.04, dual boot with Windows.

    Since the minute I installed I'm having some random flickering and system freezes, meaning everything freezes quite randomly (sometimes after a few hours, sometimes less).

    I tried a ton of solutions offered online to solve the freezing problem, now it doesn't seem to freeze, but instead whenever I close and open the lid or just suspend it, it either reboots or crashes with a "*ERROR* CPU pipe A FIFO underrun" error or is stuck in a terminal login.

    My current setting is the following:
    • CUDA 460.91.03 (I tried 470 and 495 but then I had my laptop randomly freezes)
    • I disabled secure boot
    • In grub I added GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    • Bios version is 1.10
    • PRIME profiles in Nvidia x server settings is set to NVIDIA On-Demand

    If there's any further information needed, just let me know what to run/check and I will.

    Any help in solving it will be greatly appreciated.
  2. P5YKH3R

    P5YKH3R New Member

    Could you please try this on your grub?

    Update grub and restart:

    update-grub && systemctl reboot
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >