Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

RAZER Cortex not rewarding zSilver from Paid to Play games...!!!

Discussion in 'Razer Cortex' started by imtinan95, Jan 4, 2018.

?

How many of your RAZER insiders are having issue redeeming zSilvers from Cortex?

Poll closed Feb 4, 2018.
  1. Yes, I'm having same issue and want Technical support.

    91.8%
  2. No, we're good and hope you get your problem fixed ASAP.

    8.2%
Thread Status:
Not open for further replies.
  1. imtinan95

    imtinan95 New Member

    Hey everyone,
    I'm having an issue that when I open Cortex and launching a "Paid to Play" supported game, I don't get the message "Launching CS:GO and earning zSilver" and furthermore after quitting the game I'm unable to redeem any zSilvers. Any RAZER official I need technical support ASAP.
     
  2. GspecK

    GspecK Member

    Happened to me as well. Let's just try to restart the pc, reinstall the programm and then come back again. Best of luck mate
     
    Imperial-Eagle and imtinan95 like this.
  3. imtinan95

    imtinan95 New Member

    OK, I'll give it a shot.
     
  4. OmnipotentXK

    OmnipotentXK New Member

    I've tried that without luck... anyone able to get it work?
     
  5. Theallroundboys

    Theallroundboys New Member

    same its happening to me now i cant even log in so wo can only wait for razer staff to fix it :worried:
     
    imtinan95 likes this.
  6. th3r4pt0r

    th3r4pt0r Member

    I'm having the same issue. Have you tried checking your zVault account? I guess there's some maintenance going or on some ongoing issue with the zVault. The website is opening, but I cannot log in to my zVault account. Maybe this is the reason why we're unable to earn zSilver points?
     
  7. imtinan95

    imtinan95 New Member

    Trying...

    I haven't but let me open it.

    I'm able to open it and see my zSilvers as well.
     
    Last edited by a moderator: Jan 4, 2018
  8. Theallroundboys

    Theallroundboys New Member

    i've tried everything but the problem its not on our pc's our the cortex program but its at razer servers i think or the games that are being supported for the january
     
  9. th3r4pt0r

    th3r4pt0r Member

    OK. The website's working for me too, even the rewards tab on Cortex is working now. Lemme just take a quick check if I'm able to earn zSilver points now.
     
  10. OneTreadLife

    OneTreadLife Well-Known Member

    Same problem here.
     
  11. kliang87

    kliang87 Member

    Open game running 1 hour plus, but earn nothing...... same problem.... please fixed....
     
    poh2ho likes this.
  12. Theallroundboys

    Theallroundboys New Member

    dont think it will work coz i would be able to log in so i guess we should only wait and try later today :confused:
     

    Attached Files:

    • 123.png
      123.png
      File size:
      29.9 KB
      Views:
      8
  13. th3r4pt0r

    th3r4pt0r Member

    Yeah. Still no luck earning them silvers...
     
  14. municio

    municio New Member

    I've the same problem since three days ago, i dont know if the prolem is with servers, but i would like some fix or information from Razer about this problem
     
    imtinan95 likes this.
  15. 91xoL

    91xoL Active Member

  16. imtinan95

    imtinan95 New Member

  17. 91xoL

    91xoL Active Member

    Ye I know man, I agree with you, Razer has the problem of lack of communication.
     
    imtinan95 and Imperial-Eagle like this.
  18. eugenex6o4

    eugenex6o4 Active Member

    I haven't been playing the featured games for this month; was playing some Overwatch 12 hours ago and I was earning the zSilver, albeit at a slower pace. I'm seeing other threads mentioning something about maintenance is happening, but I see nothing on my side.

    Strange we weren't notified ahead of time, as they usually do... but: https://insider.razerzone.com/index...o-earn-zsilver-for-a-while.29549/#post-410237
     
  19. hawklegende

    hawklegende New Member

    i gamed for 5 hours to get no zsilver LUL, i didnt see any notice on maintanence or wat not..suspected server issues
     
  20. Giacomotg

    Giacomotg Active Member

    My cortex isn't working also... it's not rewarding the paid games and it doesn't show my profile photo or my total Zsilver/rewards. It's been like that for 2 days
     
    imtinan95 and Imperial-Eagle like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >