Razer Keyboard Spectrograph - Audio Visualizer [WIP]

Discussion in 'Razer Chroma' started by CalcProgrammer1, Mar 10, 2015.

Thread Status:
Not open for further replies.
  1. CalcProgrammer1

    CalcProgrammer1 Active Member

    Install the Chroma SDK and make sure to run the 32 and 64 bit .reg files. Those are needed to make the keyboard work. May have to reboot as well. That is if you have a Blackwidow Chroma, if you have the TE it's not supported yet (will be eventually).
     
  2. clankRazer

    clankRazer Member

    You know, I tried that maybe 3 times earlier and now I worked when you said it. Magic!
     
  3. CalcProgrammer1

    CalcProgrammer1 Active Member

  4. HELP! The binary link and the openal link has a 404 error.
     
  5. CalcProgrammer1

    CalcProgrammer1 Active Member

  6. waldemarzan

    waldemarzan New Member

    Did everything but it doesn't work on my Blackwidow TE. I've download the 1.05 version but when I open it nothing happens (my keyboard still goes on with the spectrum cycling)
     
  7. CalcProgrammer1

    CalcProgrammer1 Active Member

    Make absolutely sure that you run the x86 and x64 .reg files from the documentation zip file after you run the SDK installer. That is the number one issue people seem to be having and it's because they skipped that step. The SDK does not work unless you run the enabler .reg files and accept to add them into the registry. Then reboot for good measure to restart the SDK services.
     
  8. waldemarzan

    waldemarzan New Member

    Just Finished Installing the SDK Core and enabled the .reg files x64 and x86 after that I opened the VC 1.05 and my keyboard kept blinking and still continues its spectrum cycling.

    *EDIT* Opened Razer Synapse and made the the original background black it started working but it seems to be a bit out of proportion ( but anyways it still looks awesome thank you :D )
     
    Last edited: Oct 11, 2015
  9. PuceRedlifebuzz415

    PuceRedlifebuzz415 New Member

    I installed SDK, ran both reg files and I still can't seem to get the program to work. It will start and shows the visualizer preview working fine but the keyboard is not doing anything. I am using a Surface Pro 3 with Windows 10. I restarted my PC after the SDK was installed a few times. Any suggestions?
     
  10. hjilp

    hjilp Member

    This can match my rainmeter! Sick!
     
  11. PuceRedlifebuzz415

    PuceRedlifebuzz415 New Member

    I got everything working in Windows 10 by running everything as an administrator.
     
  12. Akashinda

    Akashinda New Member

    Hey i need help i can't launch the Visualizer because i have 3 errors popping
    1 : The program can't start because MSVCP140.dll is missing from your computer. Try reinstalling the program to fix this problem *Click ok*
    2 : The program can't start because mfc140.dll is missing from your computer try reinstalling the program to fix this problem *Click ok*
    3 : The program can't start because VCRUNTIME140.dll is missing from your computer try reinstalling the program to fix this problem.
    Edit : Nevermind i fix that problem but the keybord stay black for some reason and dont play react
     
    Last edited: Oct 25, 2015
  13. CalcProgrammer1

    CalcProgrammer1 Active Member

    Read the instructions. This is because you didn't install visual studio 2015 runtime x86.
     
  14. Akashinda

    Akashinda New Member

    Yeah i install it and i can open the visualizer but as soon as i launch it my keybord goes black and nothing happens
     
  15. austinjklim

    austinjklim New Member

    Just installed this and its working. But it keeps blinking. Maybe it was because I was running a custom color scheme on my Synapse? (Full Static Green then opened VC, audio waves came out find but the blinking of background light like its refreshing constantly at a very fast speed.)

    Workaround at the moment is closed synpase.

    Running Win 10 64 with tournament drivers Synapse
     
  16. njbmartin

    njbmartin Developer of Awesome

    Yep, any Advanced Configurator Profiles will currently break anything using the SDK.
     
  17. when i try to download the things for the visualiser it says error 404 not avalable
     
  18. Neiii

    Neiii New Member

    Hi CalcProgrammer1!
    Thank you for taking time to explain everything. Everything worked out fine for me.
    Thank you so much! :heart:
     
  19. Wesleypestly

    Wesleypestly New Member

    how does i get this to work on the mouse?
     
  20. CalcProgrammer1

    CalcProgrammer1 Active Member

    Same as on the keyboard. Install visual C++ 2015 redistributable (x86), make sure you have the latest Synapse, enable Chroma Apps, then download 1.09 and run it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >