Razer Phone, Fingerprint Sensor problem

Discussion in 'Mobile' started by TRoas, Apr 26, 2018.

  1. TRoas

    TRoas Member

    After 2 months of use, never squeezed or fallen, one and a half week after upgrading to 8.1 Oreo, the fingerprint sensor stopped working last night.

    When unlocking, the phone is vibrating like getting multiple touches in just a second, and does not recognize my finger. Many reboots and switching offs, uninstalled apps that were installed last of all, still nothing.

    In settings fingerprint, it does not react at all, i deleted all fingers and tried to put new ones but the sensor will not work. I switched it off at night and when I woke up it worked again and I got new fingerprints.

    Now after a few hours it stopped working again. Still no progress. I will try a factory reset, but I wanted to share it here first for people or support to see and ask for some info that maybe lost if factory reseted...
     
    Last edited: Apr 27, 2018
    0V3R_K1LL and DRIFT_IT like this.
  2. Joikansai

    Joikansai Well-Known Member

    TRoas likes this.
  3. TRoas

    TRoas Member

    Thank you for your interest @Joikansai. I will contact support. I just pray not to be a hardware issue cause I hate RMAing for no reason...
     
  4. Rox598

    Rox598 Well-Known Member

    Very unlikely Oreo is the cause of this.

    I had a FP scanner die on me too but the fingerprint option was gone in the system settings.

    Took an alcoholic wipe and whipped the hell out of it really hard and it eventually came back to life....dunno wtf happened or what was causing it i doubt the cleaning fixed it but my 2$
     
    TRoas likes this.
  5. Cliffeh

    Cliffeh Member

    It did this to me once and all I had to do was clean the button/sensor with a cloth and bingo, fixed. I'm assuming you've already tried that though?
     
  6. TRoas

    TRoas Member

    Yeah, I did try that, and I tend to keep it clean, cool and safe in general. Thank you for your interest and posting your way of fixing it. Sensor still having its "ups" and "downs", with "ups" being after long time no use... I hope this thing ends soon... From what I can see, I can only cross fingers...
     
  7. Cliffeh

    Cliffeh Member

    EDITED TO INCLUDE LINK

    Ah, sorry to hear that man. I genuinely hope it resolves itself. I'm always reading stuff about our phones (I lurk the subreddit quite a bit too https://www.reddit.com/r/razerphone/ ) so if I come across anything, I'll PM you or reply on here.
     
    TRoas likes this.
  8. TRoas

    TRoas Member

    Update:

    Fingerprint Sensor never recovered again, even for a minute.

    I ve contacted support and they direct me to RMA, after following every step of software trials, hypothesizing the problem is of harware nature... Been told the costs are free provided your phone is under warranty.

    I checked the partner company, building the fingerprint sensor. It is a leading company in biometrics and blah blah blah...
     
  9. Cliffeh

    Cliffeh Member

    Ah that sucks dude, RMA is always a pain in the ass with ANY company. Hope the turnaround is quick at least.
     
  10. twistedmjc

    twistedmjc Member

    I just started noticing my fingerprint scanner is starting to act funny.. Not sure if it's just really dirty as sometimes I can just wipe it off and it works, other times no dice.. I'm hoping it's not dying and gonna give it a good scrubbing with a qtip and rubbing alcohol and hope that helps.
     
  11. TRoas

    TRoas Member

    Good luck! Lets hope its nothing... be careful with it though and keep it clean as always ;)
     
  12. TRoas

    TRoas Member

    Update

    I had a long trip abroad, so I didn't RMA my phone. During the trip, the fingerprint sensor started working and only stopped for an hour after a week and then working again propperly...

    What I remember to do last, before working again, was to uninstall Avast Antivirus and its subprogramms like avast clean up etc. Strange thing is when rebooted the Android OS many times, it still didnt work properly

    After working properly, last thing I remember is starting lineage II and started getting notifications from it. Then stopped working again... uninstalled it and after a restart about an hour later, it started working again...

    I have my doubts in general, of what is causing it, and from what I noticed in total, the most possible reason to find why this is happening, is programms that are involved in small changes at the notifications in lock screen, or maybe the number of it or maybe the amount of info allowed to be viewed at lock screen.

    In my opinion chances are 65% software problem, 35% hardware problem...

    I wish someone that have a similar problem, could try out and give us feedback here. I wish the sensor will not stop working again :) For now its about 2-3 weeks with the sensor working...
     
    RegularPerson1217 likes this.
  13. RegularPerson1217

    RegularPerson1217 New Member

    Hey man I have the same problem and didn't know what to do so I just lived without the sensor, which sucks...
     
  14. TRoas

    TRoas Member

    Did you try these things I mentioned??
     
    RegularPerson1217 likes this.
  15. RegularPerson1217

    RegularPerson1217 New Member

    Yeah, so it must be a software problem cuz it happened after installing O.
     
  16. Joikansai

    Joikansai Well-Known Member

    Just adding not a problem though it can be used more than 2 finger prints which is cool;) I don’t think it could, on my old Apple phone, that phone fingerprint is even not working on weat fingers, even a bit. Sometimes it’s hard to unlock with thumb but now with pointing finger I can unlock it too which is helpful in some condition.
     
  17. Joikansai

    Joikansai Well-Known Member

    Can’t comment about it since some one stated it’s not more social forum but also support. But maybe they’re still not in that support forum level that people are expecting, but you can still get support from official support page, and f you face any problem, they’re helpful in my experience. Though for RMA there’s a new policy that you’ll get it only as first buyer, and if you can provide them the purchase proof they’ll give you that guarantee within its period, oh if you buy from random store yes maybe you’ll face an issue and that is not only Razer, you should buy from their officiall retailers or cellular providers that works with Razer.
     
  18. Emilyemms

    Emilyemms New Member

  19. Joikansai

    Joikansai Well-Known Member

    TRoas and Cliffeh like this.
  20. RegularPerson1217

    RegularPerson1217 New Member

    Hey TRoas, I managed to get the fingerprint scanner working! I was looking for a parallax wallpaper, saw this https://play.google.com/store/apps/details?id=com.in.w3d and tried it out. It looks good blabla then I was on a trip and thought to myself if the scanner will work anymore or no, needless to say that it worked! Also tried it using multiple fingers, but it acted up again, so I removed it like there was no hope. On a morning days later, I tried it again but only using one print, and it worked! One week later and still works! Not sure if the 3D Parallax app has something to do with it, but I left a link if you wanna try it out.
    Have a great day!

    EDIT:
    It died again after I made this post, and left it for a day and still none :-(
     
    Last edited: Jul 16, 2018
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >