[SOLVED] Turned off from Low Battery & won't turn back on

Discussion in 'General Q&A' started by Brandon Giesing, Apr 8, 2017.

Thread Status:
Not open for further replies.
  1. bgiesing

    bgiesing New Member

    I was recording video on my Robin running AOSPA 6.0.3 and the device powered down cause it had low battery (1%), it's been plugged in for 6+ hours now and still won't come on.

    I've tried unplugging and replugging, holding down basically every button combo for 10, 20, 30, 60, and even 120 seconds, using different USB wall bricks (some Quick Charge and some not) and ports on 2 computers, different cables (the stock USB 2 one and a third party USB 3), etc.

    Nothing has worked at all so any ideas? I doubt the phone got bricked from a low power shutdown.
     
  2. bgiesing

    bgiesing New Member

    I've been trying that multiple times every hour (now going on 12+) and mentioned that in the post already: "holding down basically every button combo for 10, 20, 30, 60, and even 120 seconds"
     
  3. dataautoAmaranth397

    dataautoAmaranth397 New Member

    What I found is some custom ROMs are not able to charge the device while the device is shut off ........So be careful if you modded your device
     
  4. bgiesing

    bgiesing New Member

    Was AOSPA one of those? Cause that's what I'm running

    It's been over 24 hours now and still want turn on no matter what I do :sob:
     
    Last edited by a moderator: May 2, 2017
  5. TheBaymax

    TheBaymax Member

  6. bgiesing

    bgiesing New Member

    Yeah forgot to update this thread :sweat_smile: It took almost 2 days plugged into my PC's USB port to turn back on.
     
    Baymax likes this.
  7. TheBaymax

    TheBaymax Member

    Brandon Giesing likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >